summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2021-09-09 18:57:43 +0200
committerUffe Jakobsen2021-09-09 18:57:43 +0200
commiteef3e8da561b0c18d4839c924f1d95d12dee8c96 (patch)
treeea093b0217fef985eda2e92965c62f56f0e9e4a6
parentce1f64753eafc0dfce4b7993306992a74983637b (diff)
downloadaur-eef3e8da561b0c18d4839c924f1d95d12dee8c96.tar.gz
Apply local patch until fixed upstream
-rw-r--r--PKGBUILD2
-rw-r--r--codelite-quickfindbar-focus-tweak.patch40
2 files changed, 41 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 58c0a99e4560..df19f436b38b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -93,7 +93,7 @@ BUILD_DIR="_build"
prepare()
{
cd "${srcdir}/${_pkg_name_ver}"
- #patch -p0 < "${startdir}/CMakeLists.txt.patch"
+ patch -p0 < "${startdir}/codelite-quickfindbar-focus-tweak.patch"
}
diff --git a/codelite-quickfindbar-focus-tweak.patch b/codelite-quickfindbar-focus-tweak.patch
new file mode 100644
index 000000000000..c4118e2857ea
--- /dev/null
+++ b/codelite-quickfindbar-focus-tweak.patch
@@ -0,0 +1,40 @@
+commit b465885b9dbd1683f39a4b81b186004fa4189a74 (HEAD -> refs/heads/master_cl_quick_find_tweak, refs/remotes/origin/master_cl_quick_find_tweak)
+Author: Uffe Jakobsen <uffe@uffe.org>
+AuthorDate: Thu Sep 9 18:02:18 2021 +0200
+Commit: Uffe Jakobsen <uffe@uffe.org>
+CommitDate: Thu Sep 9 18:02:18 2021 +0200
+
+ Change QuickFindBar behaviour to the best of both worlds (#2806)
+
+ This minor tweak changes the QuickFindBar behaviour to the best of both worlds in respect to issue #2806
+
+ With this change quickfindbar will show and get focus upon Find...
+ The change is that pressing Find Next/Prev will not affect focus.
+ This means that if focus already is at the quickfindbar it will stay there.
+ But if focus is at the editor - Find Next/Prev will not change focus from the editor and back to the quickfindbar.
+ This has the advantage that you can instantly find and edit - without having to press ESC to get focus back to the editor.
+---
+:100644 100644 e9bc3c6bb 68eadf2bf M LiteEditor/frame.cpp
+ LiteEditor/frame.cpp | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git LiteEditor/frame.cpp LiteEditor/frame.cpp
+index e9bc3c6bb..68eadf2bf 100644
+--- LiteEditor/frame.cpp
++++ LiteEditor/frame.cpp
+@@ -5863,7 +5863,6 @@ void clMainFrame::OnFindSelection(wxCommandEvent& event)
+ wxString selection =
+ editor->GetSelection().IsEmpty() ? GetMainBook()->GetFindBar()->GetFindWhat() : editor->GetSelection();
+ find_bar->SetFindWhat(selection);
+- GetMainBook()->ShowQuickBar(true);
+ find_bar->FindNext();
+ }
+
+@@ -5878,7 +5877,6 @@ void clMainFrame::OnFindSelectionPrev(wxCommandEvent& event)
+ wxString selection =
+ editor->GetSelection().IsEmpty() ? GetMainBook()->GetFindBar()->GetFindWhat() : editor->GetSelection();
+ find_bar->SetFindWhat(selection);
+- GetMainBook()->ShowQuickBar(true);
+ find_bar->FindPrevious();
+ }
+