summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Kaspar Rudert (mortzu)2015-05-21 14:41:31 +0200
committerMoritz Kaspar Rudert (mortzu)2015-05-21 14:41:31 +0200
commitb86b53f14cce50be91b67f51985c8385eff15ddf (patch)
tree588dd153b954b3b9d207f961c0556bb00b69bef2
downloadaur-coherence-svn.tar.gz
initial commit
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD52
-rw-r--r--coherence.conf94
-rw-r--r--samsung.patch22
4 files changed, 210 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..884f359836dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = coherence-svn
+ pkgdesc = Coherence acts as a DLNA/UPnP MediaServer and MediaRenderer.
+ pkgver = r1676
+ pkgrel = 1
+ url = https://coherence.beebits.net/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python2-distribute
+ depends = python2
+ depends = epsilon
+ depends = axiom
+ depends = twisted-web2
+ depends = python-elementtree
+ depends = python-configobj
+ depends = pylouie
+ depends = libcaca
+ optdepends = ampache: for the Ampache Backend
+ optdepends = axiom: for the MediaStore Backend
+ optdepends = elisa: for the Elisa DB Backend and Elisa DLNA Player
+ optdepends = gstreamer0.10-python: for the gstreamer MediaRenderer
+ optdepends = libmtag: for MediaStore Backend ID3 Option A
+ optdepends = pyid3lib: for MediaStore Backend ID3 Option B
+ optdepends = python-gdata: for the Picasa and YouTube Backends
+ optdepends = python-mechanize: for the Flickr Backend
+ optdepends = rhythmbox: for the Rhythmbox DB Backend
+ optdepends = taglib: for MediaStore Backend ID3 Option A or C
+ optdepends = tagpy: for MediaStore Backend ID3 Option C
+ optdepends = tracker: for the TrackerStore Backend
+ optdepends = dvb-daemon: for the DVB Daemon Backend (no package yet)
+ provides = coherence
+ conflicts = coherence
+ backup = etc/coherence.conf
+ source = coherence-svn::svn+https://coherence.beebits.net/svn/trunk/Coherence
+ source = coherence.conf
+ source = samsung.patch
+ md5sums = SKIP
+ md5sums = 9a2fd979a83a4f4ceb6fd3564cdeda86
+ md5sums = 039d4b84c0f0d023d9e9519fba1b101e
+
+pkgname = coherence-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..217b5a1c151a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Contributor: Paul Nicholson <brenix@gmail.com>
+# Contributor: Jon Kristian Nilsen <jokr.nilsen@gmail.com>
+
+pkgname=coherence-svn
+pkgver=r1676
+pkgrel=1
+pkgdesc="Coherence acts as a DLNA/UPnP MediaServer and MediaRenderer."
+arch=('i686' 'x86_64')
+url="https://coherence.beebits.net/"
+license=('MIT')
+source=("$pkgname"::'svn+https://coherence.beebits.net/svn/trunk/Coherence'
+ 'coherence.conf'
+ 'samsung.patch')
+md5sums=('SKIP'
+ '9a2fd979a83a4f4ceb6fd3564cdeda86'
+ '039d4b84c0f0d023d9e9519fba1b101e')
+depends=('python2' 'epsilon' 'axiom' 'twisted-web2' 'python-elementtree' 'python-configobj' 'pylouie' 'libcaca')
+optdepends=('ampache: for the Ampache Backend'
+ 'axiom: for the MediaStore Backend'
+ 'elisa: for the Elisa DB Backend and Elisa DLNA Player'
+ 'gstreamer0.10-python: for the gstreamer MediaRenderer'
+ 'libmtag: for MediaStore Backend ID3 Option A'
+ 'pyid3lib: for MediaStore Backend ID3 Option B'
+ 'python-gdata: for the Picasa and YouTube Backends'
+ 'python-mechanize: for the Flickr Backend'
+ 'rhythmbox: for the Rhythmbox DB Backend'
+ 'taglib: for MediaStore Backend ID3 Option A or C'
+ 'tagpy: for MediaStore Backend ID3 Option C'
+ 'tracker: for the TrackerStore Backend'
+ 'dvb-daemon: for the DVB Daemon Backend (no package yet)')
+provides=('coherence')
+conflicts=('coherence')
+makedepends=('python2-distribute')
+backup=('etc/coherence.conf')
+
+pkgver() {
+ cd "$pkgname"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "$pkgname"
+ patch -Np0 -i "$srcdir/samsung.patch"
+ python2 setup.py build
+}
+
+package() {
+ cd "$pkgname"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+ install -Dm755 "$srcdir/coherence.conf" "$pkgdir/etc/coherence.conf"
+}
diff --git a/coherence.conf b/coherence.conf
new file mode 100644
index 000000000000..517fcc2126a3
--- /dev/null
+++ b/coherence.conf
@@ -0,0 +1,94 @@
+<config>
+ <logging level="warn">
+ <logfile>/var/log/coherence.log</logfile>
+ </logging>
+ <controlpoint>no</controlpoint>
+ <use_dbus>no</use_dbus>
+ <web-ui>no</web-ui>
+ <serverport>41932</serverport>
+ <interface>eth0</interface>
+ <transcoding>no</transcoding>
+
+
+<!-- Movies -->
+ <plugin active="yes">
+ <name>Videos</name>
+ <content>/mnt/media/movies/,/home/user/downloads/</content>
+ <backend>FSStore</backend>
+ </plugin>
+
+<!-- Music -->
+ <plugin active="yes">
+ <name>Music</name>
+ <backend>MediaStore</backend>
+ <medialocation>/mnt/media/music/</medialocation>
+ <coverlocation>/mnt/media/music/covers/</coverlocation>
+ <mediadb>/tmp/media.db</mediadb>
+ <icon>
+ <mimetype>image/png</mimetype>
+ <width>120</width>
+ <height>106</height>
+ <depth>24</depth>
+ <url>coherence-icon.png</url>
+ </icon>
+ </plugin>
+
+ <plugin active="no">
+ <name>GStreamer Audio Player</name>
+ <backend>GStreamerPlayer</backend>
+ </plugin>
+
+ <plugin active="no">
+ <name>Elisa</name>
+ <backend>ElisaPlayer</backend>
+ <host>localhost</host>
+ </plugin>
+
+ <plugin active="no">
+ <name>iRadio</name>
+ <backend>IRadioStore</backend>
+ </plugin>
+
+ <plugin active="no">
+ <name>Flickr Images</name>
+ <backend>FlickrStore</backend>
+ <refresh>60</refresh>
+ <proxy>yes</proxy>
+ <icon>
+ <mimetype>image/png</mimetype>
+ <width>98</width>
+ <height>26</height>
+ <depth>24</depth>
+ <url>flickr-icon.png</url>
+ </icon>
+ </plugin>
+
+ <plugin active="no">
+ <name>Elisa is watching you</name>
+ <backend>AxisCamStore</backend>
+ <cam>
+ <name>Cam 1</name>
+ <url>http://192.168.1.222:554/mpeg4/1/media.amp</url>
+ <protocol>rtsp-rtp-udp:*:video/MP4V-ES:*</protocol>
+ </cam>
+ <cam>
+ <name>Cam 2</name>
+ <url>http://192.168.1.222:554/mpeg4/2/media.amp</url>
+ <protocol>rtsp-rtp-udp:*:video/MP4V-ES:*</protocol>
+ </cam>
+ </plugin>
+
+ <plugin active="no">
+ <name>Buzztard Media</name>
+ <backend>BuzztardStore</backend>
+ <host>localhost</host>
+ <port>7654</port>
+ </plugin>
+
+ <plugin active="no">
+ <name>Buzztard Player</name>
+ <backend>BuzztardPlayer</backend>
+ <host>localhost</host>
+ <port>7654</port>
+ </plugin>
+</config>
diff --git a/samsung.patch b/samsung.patch
new file mode 100644
index 000000000000..06c76576da8d
--- /dev/null
+++ b/samsung.patch
@@ -0,0 +1,22 @@
++++ coherence/upnp/core/DIDLLite.py 2010-10-24 16:09:53.218250816 -0700
+@@ -190,6 +190,10 @@
+ additional_info = ['*']
+ if content_format == 'video/x-ms-wmv':
+ additional_info = ['DLNA.ORG_PN=WMV_BASE']+simple_dlna_tags
++ if content_format in ['video/avi', 'video/divx']:
++ additional_info = ['DLNA.ORG_PN=AVI']+simple_dlna_tags
++ if content_format == 'video/quicktime':
++ additional_info = ['DLNA.ORG_PN=QUICKTIME']+simple_dlna_tags
+ if content_format == '*':
+ additional_info = simple_dlna_tags
+
++++ coherence/backends/fs_storage.py 2010-10-21 21:55:10.814224348 -0700
+@@ -24,7 +24,7 @@
+ mimetypes.add_type('video/mpegts', '.ts')
+ mimetypes.add_type('video/divx', '.divx')
+ mimetypes.add_type('video/divx', '.avi')
+-mimetypes.add_type('video/x-matroska', '.mkv')
++mimetypes.add_type('video/mpeg', '.mkv')
+
+ from urlparse import urlsplit
+