summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-04-04 00:13:42 +0200
committerbartus2018-04-04 00:13:42 +0200
commit339fd3a18fdcf6247600dfbe1c0da498613696d0 (patch)
tree12797732a6b0826e38779cbe7aadf0be88777e2f
parent770541a5c64abe941e9383949d69eb4f0ac67651 (diff)
downloadaur-339fd3a18fdcf6247600dfbe1c0da498613696d0.tar.gz
add _BUILD_CUDA control variable, remove redundant .desktop file
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD41
-rw-r--r--colmap.desktop14
3 files changed, 23 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9cfb32ce1a0..4563739f79e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = colmap-git
pkgdesc = COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface.
- pkgver = 3.3.r88.gb2af900
- pkgrel = 1
+ pkgver = 3.4.r44.g827bbb8
+ pkgrel = 2
url = https://colmap.github.io/
install = colmap-git.install
arch = i686
@@ -26,14 +26,12 @@ pkgbase = colmap-git
source = colmap-git::git+https://github.com/colmap/colmap.git#branch=dev
source = nvm-export.patch
source = colmap-git.install
- source = colmap.desktop
source = vocabulary-tree-64K.bin::https://demuc.de/colmap/vocab_tree-65536.bin
source = vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree-262144.bin
source = vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree-1048576.bin
md5sums = SKIP
md5sums = 3c0027625739e972f8af8bea6f557b35
md5sums = ebb1dc43e014a1e720a06422c6248a40
- md5sums = 55d81534d969cf706719007462f20443
md5sums = 3521ff3c601596473c6ce5256772f606
md5sums = e423daecc45d56b749d25eeace9de1c8
md5sums = 7ec70d4137d9b7ca9f076df34808ccc7
diff --git a/PKGBUILD b/PKGBUILD
index d4f31e7749c4..82a28e4f5441 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
# Maintainer: bartus szczepaniak <aur@bartus.33mail.com>
+
+####to disable cuda kernel comment out this line
+_BUILD_CUDA="on"
+
name=colmap
#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
fragment="#branch=dev"
pkgname=${name}-git
-pkgver=3.3.r88.gb2af900
-pkgrel=1
+pkgver=3.4.r44.g827bbb8
+pkgrel=2
pkgdesc="COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface."
arch=('i686' 'x86_64')
url="https://colmap.github.io/"
license=('GPL')
groups=()
depends=('gflags' 'suitesparse' 'freeglut' 'glew' 'google-glog' 'freeimage' 'boost-libs' 'qt5-base')
-makedepends=('ceres-solver' 'boost' 'git' 'cmake' 'eigen' 'cuda')
-optdepends=('cuda: for cuda sfm/mvs acceleration')
-provides=()
-# Fix: -fno-plt flag not supported by cuda host compiler (gcc5)
-options=(!buildflags)
-CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong"
-CXXFLAGS="${CFLAGS}"
+makedepends=('ceres-solver' 'boost' 'git' 'cmake' 'eigen' )
+if [ "$_BUILD_CUDA" == "on" ] ; then
+ makedepends+=('cuda')
+ optdepends=('cuda: for cuda sfm/mvs acceleration')
+ # Fix: -fno-plt flag not supported by cuda host compiler (gcc5)
+ options=(!buildflags)
+ CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong"
+ CXXFLAGS="${CFLAGS}"
+fi
install=${pkgname}.install
source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
"nvm-export.patch"
"${pkgname}.install"
- "${name}.desktop"
"vocabulary-tree-64K.bin::https://demuc.de/colmap/vocab_tree-65536.bin"
"vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree-262144.bin"
"vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree-1048576.bin"
@@ -30,7 +35,6 @@ source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
md5sums=('SKIP'
'3c0027625739e972f8af8bea6f557b35'
'ebb1dc43e014a1e720a06422c6248a40'
- '55d81534d969cf706719007462f20443'
'3521ff3c601596473c6ce5256772f606'
'e423daecc45d56b749d25eeace9de1c8'
'7ec70d4137d9b7ca9f076df34808ccc7')
@@ -42,7 +46,7 @@ pkgver() {
prepare() {
cd ${srcdir}/${pkgname}
- patch -Np1 -i ../nvm-export.patch
+ git apply ${srcdir}/nvm-export.patch
}
@@ -51,13 +55,15 @@ build() {
# determine whether we can precompile CUDA kernels
_CUDA_PKG=`pacman -Qq cuda 2>/dev/null` || true
- if [ "$_CUDA_PKG" != "" ]; then
- _EXTRAOPTS="-DCUDA_ENABLED=ON -DCUDA_HOST_COMPILER=/opt/cuda/bin/gcc -DCUDA_TOOLKIT_ROOT_DIR=/opt/cuda"
+ if [ -n "$_CUDA_PKG" -a "$_BUILD_CUDA"=="on" ]; then
+ _EXTRAOPTS="-DCUDA_ENABLED=ON -DCUDA_HOST_COMPILER=/opt/cuda/bin/gcc -DCUDA_TOOLKIT_ROOT_DIR=/opt/cuda -DCUDA_NVCC_FLAGS=\"--compiler-options -fPIC\""
+ else
+ _EXTRAOPTS="-DCUDA_ENABLED=OFF"
fi
mkdir -p build
cd build
- cmake -DTESTS_ENABLED=OFF -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ${_EXTRAOPTS} -DCUDA_NVCC_FLAGS="--compiler-options -fPIC" ../${pkgname}
+ cmake -DTESTS_ENABLED=OFF -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ${_EXTRAOPTS} ../${pkgname}
make
}
@@ -66,11 +72,6 @@ package() {
cd ${srcdir}/build
make DESTDIR=${pkgdir} install
- # install desktop entry
- install -d -m755 "${pkgdir}/usr/share/applications"
- install -m644 "${srcdir}/${name}.desktop" "${pkgdir}/usr/share/applications"
- sed -i "s#Version=.*#Version=$pkgver#" "${pkgdir}/usr/share/applications/${name}.desktop"
-
# install vocabulary trees for sequential,vocabulary matching
install -d -m755 ${pkgdir}/usr/share/${name}
for vocab_tree in ${srcdir}/vocabulary-tree-*.bin ; do
diff --git a/colmap.desktop b/colmap.desktop
deleted file mode 100644
index 9e56e1a1f79e..000000000000
--- a/colmap.desktop
+++ /dev/null
@@ -1,14 +0,0 @@
-[Desktop Entry]
-Version=$pkgver
-Name=ColMap
-Name[en_GB]=ColMap
-GenericName=Photogrametry reconstruction
-GenericName[en_GB]=Photogrametry reconstruction
-Comment=All-in-one reconstruction pipeline (sfm>mvs)
-Type=Application
-Exec=colmap
-TryExec=colmap
-#Icon=/usr/share/pixmaps/meshlab.png
-Terminal=false
-#MimeType=model/mesh;application/x-3ds;image/x-3ds;application/sla;
-Categories=Graphics;3DGraphics;Viewer;Qt;