summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-07-19 18:02:14 +0200
committerbartus2018-07-19 18:02:14 +0200
commit3d9805fad521d446495673e22b3d2286fc9a707d (patch)
treeb9cd72bb1971cf4405afa2662e1698d7ec07c0c0
parentc7b62a59c62465239ca01d716397a30f3411c5c1 (diff)
downloadaur-3d9805fad521d446495673e22b3d2286fc9a707d.tar.gz
remove freeimage fix
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
-rw-r--r--freeimage.patch28
3 files changed, 3 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d84cff1d3a9c..de23f2b23c32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = colmap-git
pkgdesc = COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface.
- pkgver = 3.5.dev.1.r12.g6a04a6a
+ pkgver = 3.5.dev.2.r0.g9f70659
pkgrel = 1
url = https://colmap.github.io/
install = colmap-git.install
@@ -19,27 +19,18 @@ pkgbase = colmap-git
depends = glew
depends = google-glog
depends = freeimage
- depends = openexr
- depends = openjpeg2
- depends = libtiff
- depends = libpng
- depends = libwebp
- depends = libraw
- depends = jxrlib
depends = libjpeg
depends = boost-libs
depends = qt5-base
optdepends = cuda-toolkit: for cuda sfm/mvs acceleration
source = colmap-git::git+https://github.com/colmap/colmap.git#branch=dev
source = nvm-export.patch
- source = freeimage.patch
source = colmap-git.install
source = vocabulary-tree-64K.bin::https://demuc.de/colmap/vocab_tree-65536.bin
source = vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree-262144.bin
source = vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree-1048576.bin
md5sums = SKIP
md5sums = 3c0027625739e972f8af8bea6f557b35
- md5sums = b57f6eecef6589688665b9c01e68cae9
md5sums = ebb1dc43e014a1e720a06422c6248a40
md5sums = 3521ff3c601596473c6ce5256772f606
md5sums = e423daecc45d56b749d25eeace9de1c8
diff --git a/PKGBUILD b/PKGBUILD
index c1e10f0b2890..9fb5705430a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,14 @@ name=colmap
#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
fragment="#branch=dev"
pkgname=${name}-git
-pkgver=3.5.dev.1.r12.g6a04a6a
+pkgver=3.5.dev.2.r0.g9f70659
pkgrel=1
pkgdesc="COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface."
arch=('i686' 'x86_64')
url="https://colmap.github.io/"
license=('GPL')
groups=()
-_freeimage_deps=('openexr' 'openjpeg2' 'libtiff' 'libpng' 'libwebp' 'libraw' 'jxrlib')
-depends=('gflags' 'suitesparse' 'freeglut' 'glew' 'google-glog' 'freeimage' ${_freeimage_deps[@]} 'libjpeg' 'boost-libs' 'qt5-base')
+depends=('gflags' 'suitesparse' 'freeglut' 'glew' 'google-glog' 'freeimage' 'libjpeg' 'boost-libs' 'qt5-base')
makedepends=('ceres-solver' 'boost' 'git' 'cmake' 'eigen' )
if [ "$_BUILD_CUDA" == "on" ] ; then
makedepends+=('cuda-sdk')
@@ -23,7 +22,6 @@ fi
install=${pkgname}.install
source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
"nvm-export.patch"
- "freeimage.patch"
"${pkgname}.install"
"vocabulary-tree-64K.bin::https://demuc.de/colmap/vocab_tree-65536.bin"
"vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree-262144.bin"
@@ -31,7 +29,6 @@ source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
)
md5sums=('SKIP'
'3c0027625739e972f8af8bea6f557b35'
- 'b57f6eecef6589688665b9c01e68cae9'
'ebb1dc43e014a1e720a06422c6248a40'
'3521ff3c601596473c6ce5256772f606'
'e423daecc45d56b749d25eeace9de1c8'
@@ -45,7 +42,6 @@ pkgver() {
prepare() {
cd ${srcdir}/${pkgname}
git apply ${srcdir}/nvm-export.patch
- git apply ${srcdir}/freeimage.patch
}
diff --git a/freeimage.patch b/freeimage.patch
deleted file mode 100644
index 72cec6f83216..000000000000
--- a/freeimage.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/cmake/FindFreeImage.cmake b/cmake/FindFreeImage.cmake
-index 1466f92..114559d 100755
---- a/cmake/FindFreeImage.cmake
-+++ b/cmake/FindFreeImage.cmake
-@@ -80,12 +80,14 @@ find_library(FREEIMAGE_LIBRARIES
-
- if(FREEIMAGE_INCLUDE_DIRS AND FREEIMAGE_LIBRARIES)
- set(FREEIMAGE_FOUND TRUE)
-+ set(FREEIMAGE_LINKER_FLAGS "-lpng -ljpeg -lwebp -lwebpmux -ltiff -lraw -lIlmImf -lopenjp2 -ljxrglue -ljpegxr")
- endif()
-
- if(FREEIMAGE_FOUND)
- message(STATUS "Found FreeImage")
- message(STATUS " Includes : ${FREEIMAGE_INCLUDE_DIRS}")
- message(STATUS " Libraries : ${FREEIMAGE_LIBRARIES}")
-+ message(STATUS "Linker Flags: ${FREEIMAGE_LINKER_FLAGS}")
- else()
- if(FreeImage_FIND_REQUIRED)
- message(FATAL_ERROR "Could not find FreeImage")
-diff --git a/src/exe/CMakeLists.txt b/src/exe/CMakeLists.txt
-index 0d126a9..c7e8763 100755
---- a/src/exe/CMakeLists.txt
-+++ b/src/exe/CMakeLists.txt
-@@ -33,3 +33,4 @@ set(FOLDER_NAME "exe")
-
- COLMAP_ADD_EXECUTABLE(colmap_exe colmap.cc)
- set_target_properties(colmap_exe PROPERTIES OUTPUT_NAME colmap)
-+set_target_properties(colmap_exe PROPERTIES LINK_FLAGS ${FREEIMAGE_LINKER_FLAGS})