summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-05-21 13:29:26 +0200
committerbartus2018-05-21 13:29:26 +0200
commit6b28a316f5553c09f8fc0690e2ed1bb6b8523045 (patch)
tree93d2db2010e5f1a576b489cd8a397a428d01df06
parent81bd56327e8db4bc61b719e6fc1e1884194f693e (diff)
downloadaur-6b28a316f5553c09f8fc0690e2ed1bb6b8523045.tar.gz
fix gcc5 flags for nvcc
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4563739f79e6..8c91961f9949 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = colmap-git
pkgdesc = COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface.
- pkgver = 3.4.r44.g827bbb8
- pkgrel = 2
+ pkgver = 3.4.r68.g3803109
+ pkgrel = 1
url = https://colmap.github.io/
install = colmap-git.install
arch = i686
@@ -22,7 +22,6 @@ pkgbase = colmap-git
depends = boost-libs
depends = qt5-base
optdepends = cuda: for cuda sfm/mvs acceleration
- options = !buildflags
source = colmap-git::git+https://github.com/colmap/colmap.git#branch=dev
source = nvm-export.patch
source = colmap-git.install
diff --git a/PKGBUILD b/PKGBUILD
index d28e8d8d89a5..a40486490e5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ name=colmap
#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
fragment="#branch=dev"
pkgname=${name}-git
-pkgver=3.4.r44.g827bbb8
-pkgrel=2
+pkgver=3.4.r68.g3803109
+pkgrel=1
pkgdesc="COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface."
arch=('i686' 'x86_64')
url="https://colmap.github.io/"
@@ -49,6 +49,9 @@ prepare() {
build() {
cd ${srcdir}
+ export CFLAGS=${CFLAGS/-fno-plt/}
+ export CXXFLAGS=${CFLAGS/-fno-plt/}
+
# determine whether we can precompile CUDA kernels
_CUDA_PKG=`pacman -Qq cuda 2>/dev/null` || true
if [ -n "$_CUDA_PKG" -a "$_BUILD_CUDA"=="on" ]; then