summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-01-23 21:46:56 +0100
committerbartus2018-01-23 21:46:56 +0100
commit770541a5c64abe941e9383949d69eb4f0ac67651 (patch)
tree3b0b1a85ec120d99b2d077eea53b1e7972c39922
parent51b40bec70eb8af66c680ee336884f9cb2b78ede (diff)
downloadaur-770541a5c64abe941e9383949d69eb4f0ac67651.tar.gz
single binary version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--nvm-export.patch20
3 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d85537f7d9dc..d9cfb32ce1a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = colmap-git
pkgdesc = COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface.
- pkgver = 3.3.r4.g1305bfb
+ pkgver = 3.3.r88.gb2af900
pkgrel = 1
url = https://colmap.github.io/
install = colmap-git.install
@@ -23,7 +23,7 @@ pkgbase = colmap-git
depends = qt5-base
optdepends = cuda: for cuda sfm/mvs acceleration
options = !buildflags
- source = colmap-git::git+https://github.com/colmap/colmap.git#branch=master
+ source = colmap-git::git+https://github.com/colmap/colmap.git#branch=dev
source = nvm-export.patch
source = colmap-git.install
source = colmap.desktop
@@ -31,7 +31,7 @@ pkgbase = colmap-git
source = vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree-262144.bin
source = vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree-1048576.bin
md5sums = SKIP
- md5sums = 8a9f76c21ae93e5f5571f372f5401423
+ md5sums = 3c0027625739e972f8af8bea6f557b35
md5sums = ebb1dc43e014a1e720a06422c6248a40
md5sums = 55d81534d969cf706719007462f20443
md5sums = 3521ff3c601596473c6ce5256772f606
diff --git a/PKGBUILD b/PKGBUILD
index 13c1ee90eb48..d4f31e7749c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: bartus szczepaniak <aur@bartus.33mail.com>
name=colmap
#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
-fragment="#branch=master"
+fragment="#branch=dev"
pkgname=${name}-git
-pkgver=3.3.r4.g1305bfb
+pkgver=3.3.r88.gb2af900
pkgrel=1
pkgdesc="COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface."
arch=('i686' 'x86_64')
@@ -28,7 +28,7 @@ source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
"vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree-1048576.bin"
)
md5sums=('SKIP'
- '8a9f76c21ae93e5f5571f372f5401423'
+ '3c0027625739e972f8af8bea6f557b35'
'ebb1dc43e014a1e720a06422c6248a40'
'55d81534d969cf706719007462f20443'
'3521ff3c601596473c6ce5256772f606'
diff --git a/nvm-export.patch b/nvm-export.patch
index a0c995c04900..0ef590c27c2e 100644
--- a/nvm-export.patch
+++ b/nvm-export.patch
@@ -1,8 +1,8 @@
diff --git a/src/base/reconstruction.cc b/src/base/reconstruction.cc
-index 5674363..794b994 100755
+index c9a65fc..29358b3 100755
--- a/src/base/reconstruction.cc
+++ b/src/base/reconstruction.cc
-@@ -952,7 +952,7 @@ void Reconstruction::ImportPLY(const std::string& path) {
+@@ -972,7 +972,7 @@ void Reconstruction::ImportPLY(const std::string& path) {
}
}
@@ -11,7 +11,7 @@ index 5674363..794b994 100755
std::ofstream file(path, std::ios::trunc);
CHECK(file.is_open()) << path;
-@@ -979,7 +979,13 @@ bool Reconstruction::ExportNVM(const std::string& path) const {
+@@ -999,7 +999,13 @@ bool Reconstruction::ExportNVM(const std::string& path) const {
-1 * camera.Params(SimpleRadialCameraModel::extra_params_idxs[0]);
const Eigen::Vector3d proj_center = image.ProjectionCenter();
@@ -39,11 +39,11 @@ index 7cb5ffb..c2b1d84 100755
bool ExportBundler(const std::string& path,
const std::string& list_path) const;
void ExportPLY(const std::string& path) const;
-diff --git a/src/exe/model_converter.cc b/src/exe/model_converter.cc
-index 9e14d73..c5bfcbf 100755
---- a/src/exe/model_converter.cc
-+++ b/src/exe/model_converter.cc
-@@ -43,7 +43,7 @@ int main(int argc, char** argv) {
+diff --git a/src/exe/colmap.cc b/src/exe/colmap.cc
+index 0a8476b..07e2954 100755
+--- a/src/exe/colmap.cc
++++ b/src/exe/colmap.cc
+@@ -838,7 +838,7 @@ int RunModelConverter(int argc, char** argv) {
} else if (output_type == "txt") {
reconstruction.WriteText(output_path);
} else if (output_type == "nvm") {
@@ -53,10 +53,10 @@ index 9e14d73..c5bfcbf 100755
reconstruction.ExportBundler(output_path + ".bundle.out",
output_path + ".list.txt");
diff --git a/src/ui/main_window.cc b/src/ui/main_window.cc
-index 09d8020..48c1177 100755
+index 2811fc4..e01a4bb 100755
--- a/src/ui/main_window.cc
+++ b/src/ui/main_window.cc
-@@ -855,7 +855,7 @@ void MainWindow::ExportAs() {
+@@ -807,7 +807,7 @@ void MainWindow::ExportAs() {
const Reconstruction& reconstruction =
reconstruction_manager_.Get(SelectedReconstructionIdx());
if (filter == "NVM (*.nvm)") {