summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-04-04 09:04:00 +0200
committerbartus2018-04-04 09:04:00 +0200
commit81bd56327e8db4bc61b719e6fc1e1884194f693e (patch)
tree653871ca3f20943e13c78a3574a2d59b7fc4d7fb
parent339fd3a18fdcf6247600dfbe1c0da498613696d0 (diff)
downloadaur-81bd56327e8db4bc61b719e6fc1e1884194f693e.tar.gz
remove gcc5 fix as cuda uses gcc6 now, remove -fPIC flag as it was included upstream
-rw-r--r--PKGBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82a28e4f5441..d28e8d8d89a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,10 +19,6 @@ makedepends=('ceres-solver' 'boost' 'git' 'cmake' 'eigen' )
if [ "$_BUILD_CUDA" == "on" ] ; then
makedepends+=('cuda')
optdepends=('cuda: for cuda sfm/mvs acceleration')
- # Fix: -fno-plt flag not supported by cuda host compiler (gcc5)
- options=(!buildflags)
- CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong"
- CXXFLAGS="${CFLAGS}"
fi
install=${pkgname}.install
source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
@@ -56,7 +52,7 @@ build() {
# determine whether we can precompile CUDA kernels
_CUDA_PKG=`pacman -Qq cuda 2>/dev/null` || true
if [ -n "$_CUDA_PKG" -a "$_BUILD_CUDA"=="on" ]; then
- _EXTRAOPTS="-DCUDA_ENABLED=ON -DCUDA_HOST_COMPILER=/opt/cuda/bin/gcc -DCUDA_TOOLKIT_ROOT_DIR=/opt/cuda -DCUDA_NVCC_FLAGS=\"--compiler-options -fPIC\""
+ _EXTRAOPTS="-DCUDA_ENABLED=ON -DCUDA_HOST_COMPILER=/opt/cuda/bin/gcc -DCUDA_TOOLKIT_ROOT_DIR=/opt/cuda"
else
_EXTRAOPTS="-DCUDA_ENABLED=OFF"
fi