summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2020-11-30 22:41:50 +0800
committerYour Name2020-11-30 22:41:50 +0800
commit3cd943954567416f696d5285531764f05144b431 (patch)
tree269480964bb025a88c1c7612e502178db02616c5
downloadaur-com.taobao.aliclient.qianniu.deepin.tar.gz
Pack com.taobao.aliclient.qianniu.deepin
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD37
-rw-r--r--qianniu.install10
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ae72a64dc5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = com.taobao.aliclient.qianniu.deepin
+ pkgdesc = Ali Qian Niu Client on Deepin Wine
+ pkgver = 7.22.06N
+ pkgrel = 11
+ url = https://cts.alibaba.com/product/qianniu.htm
+ install = qianniu.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = tar
+ depends = deepin-wine5-stable>=5.0.0.10
+ depends = deepin-wine-helper>=5.1.10
+ depends = p7zip
+ depends = xdg-utils
+ depends = hicolor-icon-theme
+ optdepends = ttf-ms-fonts: Microsoft Core fonts
+ optdepends = noto-fonts-cjk: Google Noto CJK fonts
+ source = https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/com.taobao.aliclient.qianniu.deepin/com.taobao.aliclient.qianniu.deepin_7.22.06Ndeepin11_i386.deb
+ sha512sums = a0168d694035250879a529e2b5fc9550c726af2a19e610c5ae9524aa52184263769eecc8eacfd5fc3fc39b9aa4a27be10eeddb663c1bb793fd01bf487649bb7d
+
+pkgname = com.taobao.aliclient.qianniu.deepin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..d17d0a1b842a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributer: Sam L. Yes <samlukeyes123@gmail.com>
+pkgname=com.taobao.aliclient.qianniu.deepin
+pkgver=7.22.06N
+pkgrel=11
+epoch=
+pkgdesc="Ali Qian Niu Client on Deepin Wine"
+arch=('i686' 'x86_64')
+url="https://cts.alibaba.com/product/qianniu.htm"
+license=('unknown')
+groups=()
+depends=('deepin-wine5-stable>=5.0.0.10' 'deepin-wine-helper>=5.1.10' 'p7zip' 'xdg-utils' 'hicolor-icon-theme')
+makedepends=('tar')
+checkdepends=()
+optdepends=('ttf-ms-fonts: Microsoft Core fonts'
+ 'noto-fonts-cjk: Google Noto CJK fonts')
+provides=()
+replaces=()
+backup=()
+options=()
+install=qianniu.install
+changelog=
+source=("https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/${pkgname}/${pkgname}_${pkgver}deepin${pkgrel}_i386.deb")
+sha512sums=('a0168d694035250879a529e2b5fc9550c726af2a19e610c5ae9524aa52184263769eecc8eacfd5fc3fc39b9aa4a27be10eeddb663c1bb793fd01bf487649bb7d')
+validpgpkeys=()
+
+package() {
+ cd ${pkgdir}
+ tar xpvf ${srcdir}/data.tar.xz --xattrs-include='*' --numeric-owner
+ install -d usr/share
+ mv opt/apps/${pkgname}/entries/* usr/share
+ rmdir opt/apps/${pkgname}/entries
+ cd opt/apps/${pkgname}/files
+ sed -i "/extract_archive \"/d" run.sh
+ sed -i "s|\$HOME/.deepinwine/deepin-wine-helper|/opt/deepinwine/tools|" run.sh
+ sed -i "s|\$HOME/.deepinwine|/usr/lib|" run.sh
+ rm wine_archive.* helper_archive.*
+}
diff --git a/qianniu.install b/qianniu.install
new file mode 100644
index 000000000000..68fd2c0507f9
--- /dev/null
+++ b/qianniu.install
@@ -0,0 +1,10 @@
+post_upgrade() {
+ echo
+ echo "Remove ~/.deepinwine/Deepin-QianNiu to generate a new bottle."
+ echo
+}
+
+post_remove() {
+ echo "Deleting existing QianNiu bottles..."
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/Deepin-QianNiu/ \;
+} \ No newline at end of file