summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-03-27 21:52:09 +0000
committerMilk Brewster2020-03-27 21:52:09 +0000
commit4ba1e2cf776c3d27f169a93b64497eeeb9bbe0ae (patch)
tree7011e8faa63460e52fd5ae5e10ed7ffb50443b86
downloadaur-commons-category-downloader.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c71b1fcf5538
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = commons-category-downloader
+ pkgdesc = Quick and dirty shell script to fetch all images from a category on Wikimedia Commons
+ pkgver = r7.a3864da
+ pkgrel = 1
+ url = https://github.com/aucuparia/commons-category-downloader
+ arch = x86_64
+ license = GPL
+ depends = jq
+ source = git+https://github.com/aucuparia/commons-category-downloader
+ md5sums = SKIP
+
+pkgname = commons-category-downloader
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..282c5e294d92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Milkii Brewster <milkii on Freenode IRC>
+pkgname=commons-category-downloader
+pkgdesc="Quick and dirty shell script to fetch all images from a category on Wikimedia Commons"
+pkgver=r7.a3864da
+pkgrel=1
+epoch=
+arch=(x86_64)
+url="https://github.com/aucuparia/commons-category-downloader"
+license=(GPL)
+groups=()
+depends=(jq)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(git+https://github.com/aucuparia/commons-category-downloader)
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p "$pkgdir"/usr/bin
+ mv commons_category_downloader.sh "$pkgdir"/usr/bin
+}