summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXuanrui Qi2023-08-08 02:57:12 +0900
committerXuanrui Qi2023-08-08 02:57:12 +0900
commitd8b463faa83c4a98db3b8dd4ff893c783fe9af92 (patch)
tree00dd50ceecc1d925275956dff8d454efc73bec00
parenta943a2e5eb7eed807861a5a2fe8fee67bc1b100d (diff)
downloadaur-d8b463faa83c4a98db3b8dd4ff893c783fe9af92.tar.gz
Release 3.13
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f490770498b4..ea6d47961dac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = compcert
pkgdesc = The formally verified C compiler
- pkgver = 3.12
+ pkgver = 3.13
pkgrel = 1
url = http://compcert.inria.fr
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = compcert
makedepends = ocaml-menhir>=20190626
makedepends = ocaml-findlib
depends = gcc
- source = https://github.com/AbsInt/CompCert/archive/v3.12.tar.gz
- sha256sums = ebd1d1f281995ed874736b20f178361120fe1df59dda9bf4be431fab864cf7d4
+ source = https://github.com/AbsInt/CompCert/archive/v3.13.tar.gz
+ sha256sums = eba7b8168f4d852daab057efa5aedb5c7dcbcfa7115a1122175333e591b776ef
pkgname = compcert
diff --git a/PKGBUILD b/PKGBUILD
index b099d7637b61..66c39ac5fc2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=compcert
_dirname=CompCert
-pkgver=3.12
+pkgver=3.13
pkgrel=1
pkgdesc="The formally verified C compiler"
arch=('x86_64')
@@ -15,7 +15,7 @@ makedepends=('coq>=8.12.0' 'ocaml>=4.05.0'
)
checkdepends=('parallel')
source=("https://github.com/AbsInt/CompCert/archive/v$pkgver.tar.gz")
-sha256sums=('ebd1d1f281995ed874736b20f178361120fe1df59dda9bf4be431fab864cf7d4')
+sha256sums=('eba7b8168f4d852daab057efa5aedb5c7dcbcfa7115a1122175333e591b776ef')
prepare() {
cd ${srcdir}/${_dirname}-${pkgver}
@@ -28,7 +28,7 @@ build() {
# -clightgen: builds and installs the clightgen tool
# -install-coqdev: also installs the Coq development, implied by -clightgen, useful
# if you will use tools such as the Princeton VST)
- ./configure -ignore-coq-version -prefix /usr ${CARCH}-linux
+ ./configure -ignore-coq-version -ignore-ocaml-version -prefix /usr ${CARCH}-linux
make all
}