summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2019-02-16 23:45:01 +0000
committerCharles Bos2019-02-16 23:45:01 +0000
commit84758853239989cb9eadaa351f124c7e537a3364 (patch)
tree8129b25e99871a131ea385cc97fe2fbabde56161
parent31966d36dd113a165e68109750d82fa6c36a5903 (diff)
downloadaur-84758853239989cb9eadaa351f124c7e537a3364.tar.gz
Patch cmake file to stop glib-compile-schemas from being called during make install
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--no-compile-gschemas.patch19
3 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3bca9598560..b6ea20fe89f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = compiz
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM
pkgver = 0.9.14.0
- pkgrel = 2
+ pkgrel = 3
url = https://launchpad.net/compiz
arch = i686
arch = x86_64
@@ -45,11 +45,13 @@ pkgbase = compiz
source = gtk-extents.patch
source = reverse-unity-config.patch
source = screenshot-launch-fix.patch
+ source = no-compile-gschemas.patch
sha256sums = 52cd6a90ffe987bd0415fda23c34e1f3284aa34c4d8b4eefb160fbf4d1f33a2c
sha256sums = f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b
sha256sums = 16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9
sha256sums = fba56d3e5fc8d1b47be2b8eaa6d79f48635daccc26db9b0b88fa281cc50c635e
sha256sums = 89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61
+ sha256sums = 4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a
pkgname = compiz
diff --git a/PKGBUILD b/PKGBUILD
index 4e61128963b1..a3ebc122cd24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=compiz
pkgver=0.9.14.0
-pkgrel=2
+pkgrel=3
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM"
arch=('i686' 'x86_64')
url="https://launchpad.net/compiz"
@@ -22,12 +22,14 @@ source=("https://launchpad.net/${pkgname}/${pkgver:0:6}/${pkgver}/+download/${pk
"focus-prevention-disable.patch"
"gtk-extents.patch"
"reverse-unity-config.patch"
- "screenshot-launch-fix.patch")
+ "screenshot-launch-fix.patch"
+ "no-compile-gschemas.patch")
sha256sums=('52cd6a90ffe987bd0415fda23c34e1f3284aa34c4d8b4eefb160fbf4d1f33a2c'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
'fba56d3e5fc8d1b47be2b8eaa6d79f48635daccc26db9b0b88fa281cc50c635e'
- '89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61')
+ '89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61'
+ '4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -47,6 +49,9 @@ prepare() {
# Fix application launching for the screenshot plugin
patch -p1 -i "${srcdir}/screenshot-launch-fix.patch"
+
+ # Don't try to compile gschemas during make install
+ patch -p1 -i "${srcdir}/no-compile-gschemas.patch"
}
build() {
diff --git a/no-compile-gschemas.patch b/no-compile-gschemas.patch
new file mode 100644
index 000000000000..05627a858d2c
--- /dev/null
+++ b/no-compile-gschemas.patch
@@ -0,0 +1,19 @@
+diff -Nur original/cmake/recompile_gsettings_schemas_in_dir_user_env.cmake modified/cmake/recompile_gsettings_schemas_in_dir_user_env.cmake
+--- original/cmake/recompile_gsettings_schemas_in_dir_user_env.cmake 2019-02-16 12:44:41.000000000 +0000
++++ modified/cmake/recompile_gsettings_schemas_in_dir_user_env.cmake 2019-02-16 23:36:58.589706824 +0000
+@@ -15,9 +15,9 @@
+
+ find_program (GLIB_COMPILE_SCHEMAS glib-compile-schemas)
+
+-if (GLIB_COMPILE_SCHEMAS)
+-
+- message ("-- Recompiling GSettings schemas in ${SCHEMADIR}")
+- execute_process (COMMAND ${GLIB_COMPILE_SCHEMAS} ${SCHEMADIR})
+-
+-endif (GLIB_COMPILE_SCHEMAS)
++#if (GLIB_COMPILE_SCHEMAS)
++#
++# message ("-- Recompiling GSettings schemas in ${SCHEMADIR}")
++# execute_process (COMMAND ${GLIB_COMPILE_SCHEMAS} ${SCHEMADIR})
++#
++#endif (GLIB_COMPILE_SCHEMAS)