summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2015-09-05 11:24:40 +0100
committerCharles Bos2015-09-05 11:24:40 +0100
commit8785fb1b4c62c5abb34d930d77c49ae28a11d2aa (patch)
tree2598781b5e21d12e65a8f39742f0f72784dc52e4
parentc82f2467e88525ce389a1ada80ae07c4a8e1a3c8 (diff)
downloadaur-8785fb1b4c62c5abb34d930d77c49ae28a11d2aa.tar.gz
remove gwd patch. comsmetic pkgbuild fixes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--set-gwd-default.patch12
3 files changed, 8 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44ceaece7382..21140e940010 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = compiz
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM (release version)
pkgver = 0.9.12.2
- pkgrel = 1
+ pkgrel = 2
url = https://launchpad.net/compiz
install = compiz.install
arch = i686
@@ -35,11 +35,9 @@ pkgbase = compiz
conflicts = compiz-core
replaces = compiz-core-devel
source = https://launchpad.net/compiz/0.9.12/0.9.12.2/+download/compiz-0.9.12.2.tar.bz2
- source = set-gwd-default.patch
source = focus-prevention-disable.patch
source = gtk-extents.patch
sha256sums = 8917ac9e6dfdacc740780e1995e932ed865d293ae87821e7a280da5325daec80
- sha256sums = 3aa6cb70f357b3d34d51735f4b5bcb0479086d7c7336de4bd8157569d6c52c08
sha256sums = f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b
sha256sums = 16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9
diff --git a/PKGBUILD b/PKGBUILD
index 3ce81e294b2f..730729f262e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=compiz
pkgver=0.9.12.2
_pkgseries=0.9.12
-pkgrel=1
+pkgrel=2
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM (release version)"
arch=('i686' 'x86_64')
url="https://launchpad.net/compiz"
@@ -20,24 +20,23 @@ optdepends=(
conflicts=('compiz-core')
replaces=('compiz-core-devel')
source=("https://launchpad.net/compiz/${_pkgseries}/${pkgver}/+download/compiz-${pkgver}.tar.bz2"
- "set-gwd-default.patch"
"focus-prevention-disable.patch"
"gtk-extents.patch")
sha256sums=('8917ac9e6dfdacc740780e1995e932ed865d293ae87821e7a280da5325daec80'
- '3aa6cb70f357b3d34d51735f4b5bcb0479086d7c7336de4bd8157569d6c52c08'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9')
install='compiz.install'
prepare() {
- cd "compiz-${pkgver}"
+ cd "${pkgname}-${pkgver}"
- # Set gtk-window-decorator as default in the Window Decoration plugin
- patch -Np1 -i "${srcdir}/set-gwd-default.patch"
+ # Fix decorator start command
+ sed -i 's/exec \\"${COMPIZ_BIN_PATH}compiz-decorator\\"/\/usr\/bin\/compiz-decorator/g' plugins/decor/decor.xml.in
# Set focus prevention level to off which means that new windows will always get focus
patch -Np1 -i "${srcdir}/focus-prevention-disable.patch"
+ # Use Python 2
find -type f \( -name 'CMakeLists.txt' -or -name '*.cmake' \) -exec sed -e 's/COMMAND python/COMMAND python2/g' -i {} \;
find compizconfig/ccsm -type f -exec sed -e 's|^#!.*python|#!/usr/bin/env python2|g' -i {} \;
@@ -49,7 +48,7 @@ prepare() {
}
build() {
- cd "compiz-${pkgver}"
+ cd "${pkgname}-${pkgver}"
export PYTHON="/usr/bin/python2"
@@ -78,7 +77,7 @@ build() {
}
package() {
- cd "compiz-${pkgver}/build"
+ cd "${pkgname}-${pkgver}/build"
make DESTDIR="${pkgdir}" install
# findcompiz_install needs COMPIZ_DESTDIR and install needs DESTDIR
diff --git a/set-gwd-default.patch b/set-gwd-default.patch
deleted file mode 100644
index 624cffbdd5f5..000000000000
--- a/set-gwd-default.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur original/plugins/decor/decor.xml.in modified/plugins/decor/decor.xml.in
---- original/plugins/decor/decor.xml.in 2013-07-23 20:58:03.000000000 +0100
-+++ modified/plugins/decor/decor.xml.in 2014-06-11 00:01:50.332286339 +0100
-@@ -101,7 +101,7 @@
- <option name="command" type="string">
- <_short>Command</_short>
- <_long>Decorator command line that is executed if no decorator is already running.</_long>
-- <default>exec \"${COMPIZ_BIN_PATH}compiz-decorator\"</default>
-+ <default>gtk-window-decorator</default>
- </option>
- <option name="mipmap" type="bool">
- <_short>Mipmap</_short>