summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2020-05-17 01:02:48 +0100
committerCharles Bos2020-05-17 01:02:48 +0100
commit8a64270c02024d406bd280615e04831be588136b (patch)
treec599052d5553b3f6997836b89e5f85b148f0a0f8
parent9c10881496d53ea1cf013f4e95e6fa86156a5a8f (diff)
downloadaur-8a64270c02024d406bd280615e04831be588136b.tar.gz
Patch a build issue introduced by gcc 10
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--gcc10_common_fix.patch24
3 files changed, 35 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27bfa62cae0d..7d9ba2b6bdcb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = compiz
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM
pkgver = 0.9.14.1
- pkgrel = 1
+ pkgrel = 2
url = https://launchpad.net/compiz
arch = i686
arch = x86_64
@@ -46,12 +46,14 @@ pkgbase = compiz
source = reverse-unity-config.patch
source = screenshot-launch-fix.patch
source = no-compile-gschemas.patch
+ source = gcc10_common_fix.patch
sha256sums = 2505602b6c93d6565e681473df4157634268533c6874c3cdc9493b73b301ac52
sha256sums = f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b
sha256sums = 16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9
sha256sums = 6ec9c04540ca1649c687d9ab2c8311caea7075831e2cffe719ec7958c9ebab7b
sha256sums = 89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61
sha256sums = 4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a
+ sha256sums = 580f237fc4800669d5c50d9af392dd5f5cf2750131a9fa1d5edfd17df02d0a3c
pkgname = compiz
diff --git a/PKGBUILD b/PKGBUILD
index 830857746ae4..61acbf1a89ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=compiz
pkgver=0.9.14.1
-pkgrel=1
+pkgrel=2
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM"
arch=('i686' 'x86_64')
url="https://launchpad.net/compiz"
@@ -23,13 +23,15 @@ source=("https://launchpad.net/${pkgname}/${pkgver:0:6}/${pkgver}/+download/${pk
"gtk-extents.patch"
"reverse-unity-config.patch"
"screenshot-launch-fix.patch"
- "no-compile-gschemas.patch")
+ "no-compile-gschemas.patch"
+ "gcc10_common_fix.patch")
sha256sums=('2505602b6c93d6565e681473df4157634268533c6874c3cdc9493b73b301ac52'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
'6ec9c04540ca1649c687d9ab2c8311caea7075831e2cffe719ec7958c9ebab7b'
'89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61'
- '4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a')
+ '4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a'
+ '580f237fc4800669d5c50d9af392dd5f5cf2750131a9fa1d5edfd17df02d0a3c')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -48,6 +50,9 @@ prepare() {
# Don't try to compile gschemas during make install
patch -p1 -i "${srcdir}/no-compile-gschemas.patch"
+
+ # Fix linker error that gets raised with gcc 10 due to multiple definitions
+ patch -p1 -i "${srcdir}/gcc10_common_fix.patch"
}
build() {
diff --git a/gcc10_common_fix.patch b/gcc10_common_fix.patch
new file mode 100644
index 000000000000..a5867b495160
--- /dev/null
+++ b/gcc10_common_fix.patch
@@ -0,0 +1,24 @@
+diff -Nur original/gtk/window-decorator/gtk-window-decorator.c modified/gtk/window-decorator/gtk-window-decorator.c
+--- original/gtk/window-decorator/gtk-window-decorator.c 2019-11-27 13:24:31.000000000 +0000
++++ modified/gtk/window-decorator/gtk-window-decorator.c 2020-05-17 00:28:11.586617947 +0100
+@@ -122,7 +122,7 @@
+
+ XRenderPictFormat *xformat_rgba;
+
+-const gchar * window_type_frames[WINDOW_TYPE_FRAMES_NUM] = {
++const gchar * __attribute__((__common__))window_type_frames[WINDOW_TYPE_FRAMES_NUM] = {
+ "normal", "modal_dialog", "dialog", "menu", "utility"
+ };
+
+diff -Nur original/gtk/window-decorator/gtk-window-decorator.h modified/gtk/window-decorator/gtk-window-decorator.h
+--- original/gtk/window-decorator/gtk-window-decorator.h 2019-11-27 13:24:31.000000000 +0000
++++ modified/gtk/window-decorator/gtk-window-decorator.h 2020-05-17 00:27:21.383286282 +0100
+@@ -272,7 +272,7 @@
+ } default_frame_references_t;
+
+ extern default_frame_references_t default_frames[WINDOW_TYPE_FRAMES_NUM * 2];
+-const gchar * window_type_frames[WINDOW_TYPE_FRAMES_NUM];
++const gchar * __attribute__((__common__))window_type_frames[WINDOW_TYPE_FRAMES_NUM];
+
+ extern char *program_name;
+