summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2015-10-15 15:49:45 +0100
committerCharles Bos2015-10-15 15:49:45 +0100
commit9ab54be326c86cee2a2f8046c23b63cbef573641 (patch)
treea86632bac118b3929dd5d109465785bf7375dd4e
parent90e04f97bb6f20d1dd1517f00a2984451ce8fa22 (diff)
downloadaur-9ab54be326c86cee2a2f8046c23b63cbef573641.tar.gz
add upstream patch to suppress cmake3 policy messages
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--cmake3.patch31
3 files changed, 42 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b654b6ec2621..b1fc6fa455fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = compiz
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM
pkgver = 0.9.12.2
- pkgrel = 6
+ pkgrel = 7
url = https://launchpad.net/compiz
install = compiz.install
arch = i686
@@ -39,12 +39,14 @@ pkgbase = compiz
source = xfce4-notifyd-nofade.patch
source = c++11.patch
source = switcher-background.patch
+ source = cmake3.patch
sha256sums = 8917ac9e6dfdacc740780e1995e932ed865d293ae87821e7a280da5325daec80
sha256sums = f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b
sha256sums = 16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9
sha256sums = 273aa79cb0887922e3a73fbbe97596495cee19ca6f4bd716c6c7057f323d8198
sha256sums = eb8b432050d1eed9cb1d5f33d2645f81e2bdce2bf55d5cc779986bb751373a45
sha256sums = e3125ed3a7e87a7d4bdaa23f1b6f654a02d0b050ad7a694ce9165fff2c6ff310
+ sha256sums = e5016fd62f9c9659d887eeafd556c18350615cd6d185c8ffa08825465890c5e0
pkgname = compiz
diff --git a/PKGBUILD b/PKGBUILD
index 2717c837f972..10ffd19307b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=compiz
pkgver=0.9.12.2
_pkgseries=0.9.12
-pkgrel=6
+pkgrel=7
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM"
arch=('i686' 'x86_64')
url="https://launchpad.net/compiz"
@@ -23,13 +23,15 @@ source=("https://launchpad.net/${pkgname}/${_pkgseries}/${pkgver}/+download/${pk
"gtk-extents.patch"
"xfce4-notifyd-nofade.patch"
"c++11.patch"
- "switcher-background.patch")
+ "switcher-background.patch"
+ "cmake3.patch")
sha256sums=('8917ac9e6dfdacc740780e1995e932ed865d293ae87821e7a280da5325daec80'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
'273aa79cb0887922e3a73fbbe97596495cee19ca6f4bd716c6c7057f323d8198'
'eb8b432050d1eed9cb1d5f33d2645f81e2bdce2bf55d5cc779986bb751373a45'
- 'e3125ed3a7e87a7d4bdaa23f1b6f654a02d0b050ad7a694ce9165fff2c6ff310')
+ 'e3125ed3a7e87a7d4bdaa23f1b6f654a02d0b050ad7a694ce9165fff2c6ff310'
+ 'e5016fd62f9c9659d887eeafd556c18350615cd6d185c8ffa08825465890c5e0')
install=${pkgname}.install
prepare() {
@@ -59,6 +61,9 @@ prepare() {
# Allow user to change switcher background colour (fixes blank background for Emerald)
patch -Np1 -i "${srcdir}/switcher-background.patch"
+
+ # Get rid of the cmake policy warning messages
+ patch -Np1 -i "${srcdir}/cmake3.patch"
}
build() {
diff --git a/cmake3.patch b/cmake3.patch
new file mode 100644
index 000000000000..e59a4a037ca6
--- /dev/null
+++ b/cmake3.patch
@@ -0,0 +1,31 @@
+=== modified file 'cmake/CompizCommon.cmake'
+--- a/cmake/CompizCommon.cmake 2014-11-04 15:54:44 +0000
++++ b/cmake/CompizCommon.cmake 2015-07-30 19:36:21 +0000
+@@ -17,6 +17,8 @@
+ cmake_policy (SET CMP0003 NEW)
+ cmake_policy (SET CMP0005 OLD)
+ cmake_policy (SET CMP0011 OLD)
++cmake_policy (SET CMP0022 OLD)
++
+
+ set (CMAKE_SKIP_RPATH FALSE)
+
+@@ -381,7 +383,6 @@
+ add_custom_target (release-upload-component)
+ add_custom_target (release-upload)
+
+- add_dependencies (release-upload-component release-upload-version)
+ add_dependencies (release-upload release-upload-component)
+
+ endmacro ()
+
+=== modified file 'compizconfig/CMakeLists.txt'
+--- a/compizconfig/CMakeLists.txt 2014-11-25 13:15:56 +0000
++++ b/compizconfig/CMakeLists.txt 2015-07-30 19:36:21 +0000
+@@ -37,5 +37,3 @@
+ endif (COMPIZ_BUILD_TESTING)
+
+ add_custom_target (pyclean)
+-
+-add_dependencies (pyclean pyclean_ccsm pyclean_compizconfig)
+