summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2016-05-08 14:17:34 +0100
committerCharles Bos2016-05-08 14:17:34 +0100
commit9cc75f11278cb2482c6468cb365b1ed9cb6e5ad0 (patch)
tree70813db9a58f89d2b415d55d792520392ffde08c
parent342c4f1aadad88d1cf78e344ffec7fda8e1705ae (diff)
downloadaur-9cc75f11278cb2482c6468cb365b1ed9cb6e5ad0.tar.gz
add fix for ambiguous function call in trailfocus
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--trailfocus-fix.patch12
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bad317e31f5e..00a9ad947b00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Apr 9 11:13:22 UTC 2016
+# Sun May 8 13:16:56 UTC 2016
pkgbase = compiz
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM
pkgver = 0.9.12.2
- pkgrel = 11
+ pkgrel = 12
url = https://launchpad.net/compiz
install = compiz.install
arch = i686
@@ -44,6 +44,7 @@ pkgbase = compiz
source = cmake3.patch
source = cube-texture.patch
source = marco-in-mate.patch
+ source = trailfocus-fix.patch
sha256sums = 8917ac9e6dfdacc740780e1995e932ed865d293ae87821e7a280da5325daec80
sha256sums = f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b
sha256sums = 16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9
@@ -53,6 +54,7 @@ pkgbase = compiz
sha256sums = e5016fd62f9c9659d887eeafd556c18350615cd6d185c8ffa08825465890c5e0
sha256sums = 81780f8c56f5b27b09394ae9ed59d10ae50c58f9ade445e9f85d7c2a00445f7e
sha256sums = 0d7474aee60c1a482cf26d5d0be6ec2e1b1067fa1d601fdf4aa19a71b07e41d3
+ sha256sums = 01e94ac52cd39eb5462a8505c7df61c7b14b05159de64f8700dfadb524bdb2ce
pkgname = compiz
diff --git a/PKGBUILD b/PKGBUILD
index f7eef497abbf..36f1008cdd62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=compiz
pkgver=0.9.12.2
_pkgseries=0.9.12
-pkgrel=11
+pkgrel=12
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM"
arch=('i686' 'x86_64')
url="https://launchpad.net/compiz"
@@ -26,7 +26,8 @@ source=("https://launchpad.net/${pkgname}/${_pkgseries}/${pkgver}/+download/${pk
"switcher-background.patch"
"cmake3.patch"
"cube-texture.patch"
- "marco-in-mate.patch")
+ "marco-in-mate.patch"
+ "trailfocus-fix.patch")
sha256sums=('8917ac9e6dfdacc740780e1995e932ed865d293ae87821e7a280da5325daec80'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
@@ -35,7 +36,8 @@ sha256sums=('8917ac9e6dfdacc740780e1995e932ed865d293ae87821e7a280da5325daec80'
'e3125ed3a7e87a7d4bdaa23f1b6f654a02d0b050ad7a694ce9165fff2c6ff310'
'e5016fd62f9c9659d887eeafd556c18350615cd6d185c8ffa08825465890c5e0'
'81780f8c56f5b27b09394ae9ed59d10ae50c58f9ade445e9f85d7c2a00445f7e'
- '0d7474aee60c1a482cf26d5d0be6ec2e1b1067fa1d601fdf4aa19a71b07e41d3')
+ '0d7474aee60c1a482cf26d5d0be6ec2e1b1067fa1d601fdf4aa19a71b07e41d3'
+ '01e94ac52cd39eb5462a8505c7df61c7b14b05159de64f8700dfadb524bdb2ce')
install=${pkgname}.install
prepare() {
@@ -71,6 +73,9 @@ prepare() {
# Use the Marco gsettings in MATE session (commits 3997+4002)
patch -p1 -i "${srcdir}/marco-in-mate.patch"
+
+ # Fix ambiguous function call in trailfocus plugin
+ patch -Np1 -i "${srcdir}/trailfocus-fix.patch"
}
build() {
diff --git a/trailfocus-fix.patch b/trailfocus-fix.patch
new file mode 100644
index 000000000000..2300e57a1ddf
--- /dev/null
+++ b/trailfocus-fix.patch
@@ -0,0 +1,12 @@
+diff -Nur original/plugins/trailfocus/src/trailfocus.cpp modified/plugins/trailfocus/src/trailfocus.cpp
+--- original/plugins/trailfocus/src/trailfocus.cpp 2015-08-20 14:01:09.000000000 +0100
++++ modified/plugins/trailfocus/src/trailfocus.cpp 2016-05-08 13:57:35.867366143 +0100
+@@ -195,7 +195,7 @@
+ }
+ else
+ {
+- distance = abs (cur->activeNum () - best->activeNum ());
++ distance = abs ((int)(cur->activeNum () - best->activeNum ()));
+ if (distance < bestDist)
+ {
+ best = cur;