summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2017-05-27 15:49:18 +0100
committerCharles Bos2017-05-27 15:49:18 +0100
commitbe33ede445f4f1305496f18468457977812cb2b4 (patch)
tree9782bca965350fdfb8a61d124212df1c0076dbc9
parentde0687003f5a2cfe135726dd3e4e6c93ee495051 (diff)
downloadaur-be33ede445f4f1305496f18468457977812cb2b4.tar.gz
add patch to ensure that application is launched for screenshot plugin
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--screenshot-launch-fix.patch15
3 files changed, 27 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b770396d9148..88578b879fba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri May 26 09:11:47 UTC 2017
+# Sat May 27 14:48:42 UTC 2017
pkgbase = compiz
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM
pkgver = 0.9.13.1
- pkgrel = 2
+ pkgrel = 3
url = https://launchpad.net/compiz
arch = i686
arch = x86_64
@@ -54,10 +54,12 @@ pkgbase = compiz
source = focus-prevention-disable.patch
source = gtk-extents.patch
source = reverse-unity-config.patch
+ source = screenshot-launch-fix.patch
sha256sums = 9854802ba2a072a497552a55cc03cce1e947ff68ed3755b484c218f688222cbf
sha256sums = f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b
sha256sums = 16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9
sha256sums = 97778fde6eff779e10a03f5c03f26ffdda8bdb89091956fee19ce84d7d8c9ef9
+ sha256sums = 89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61
pkgname = compiz
diff --git a/PKGBUILD b/PKGBUILD
index 2746b51d4875..b876adbba21b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=compiz
pkgver=0.9.13.1
-pkgrel=2
+pkgrel=3
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM"
arch=('i686' 'x86_64')
url="https://launchpad.net/compiz"
@@ -21,11 +21,13 @@ provides=("compiz-core=${pkgver}" "compiz-bcop=${pkgver}" "ccsm=${pkgver}" "comp
source=("https://launchpad.net/${pkgname}/${pkgver:0:6}/${pkgver}/+download/${pkgname}-${pkgver}.tar.bz2"
"focus-prevention-disable.patch"
"gtk-extents.patch"
- "reverse-unity-config.patch")
+ "reverse-unity-config.patch"
+ "screenshot-launch-fix.patch")
sha256sums=('9854802ba2a072a497552a55cc03cce1e947ff68ed3755b484c218f688222cbf'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
- '97778fde6eff779e10a03f5c03f26ffdda8bdb89091956fee19ce84d7d8c9ef9')
+ '97778fde6eff779e10a03f5c03f26ffdda8bdb89091956fee19ce84d7d8c9ef9'
+ '89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -45,6 +47,9 @@ prepare() {
# Fix incorrect extents for GTK+ tooltips, csd etc
patch -p1 -i "${srcdir}/gtk-extents.patch"
+
+ # Fix application launching for the screenshot plugin
+ patch -p1 -i "${srcdir}/screenshot-launch-fix.patch"
}
build() {
diff --git a/screenshot-launch-fix.patch b/screenshot-launch-fix.patch
new file mode 100644
index 000000000000..8192961bbd33
--- /dev/null
+++ b/screenshot-launch-fix.patch
@@ -0,0 +1,15 @@
+diff -rupN compiz/plugins/screenshot/src/screenshot.cpp compiz.new/plugins/screenshot/src/screenshot.cpp
+--- compiz/plugins/screenshot/src/screenshot.cpp 2014-09-01 00:21:45.807271000 -0400
++++ compiz.new/plugins/screenshot/src/screenshot.cpp 2014-09-01 00:52:30.634288167 -0400
+@@ -434,10 +434,10 @@ namespace
+ compLogMessage ("screenshot", CompLogLevelWarn, "glReadPixels failed");
+ }
+
+- if (!success)
++ if (success)
+ success =
+ launchApplicationAndTakeScreenshot (alternativeApplication,
+- directory);
++ path);
+
+ return success; \ No newline at end of file