summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2019-02-03 16:36:09 +0000
committerCharles Bos2019-02-03 16:36:09 +0000
commitc1a346ae6e69ddd23834e569fe4ead6cd9e6f73b (patch)
tree6cad8a6160352e9b2cf6fd99973a8961540bdf84
parentc620e7ab7989c081b734e2602815bd2181ca0d44 (diff)
downloadaur-c1a346ae6e69.tar.gz
Cleanup dependencies list as per namcap, add a comment in prepare, install licenses
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18ba99ce2c12..874238c839d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,37 +1,26 @@
-# Generated by mksrcinfo v8
-# Sun Dec 10 19:05:43 UTC 2017
pkgbase = compiz
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM
pkgver = 0.9.13.1
- pkgrel = 4
+ pkgrel = 5
url = https://launchpad.net/compiz
arch = i686
arch = x86_64
license = GPL
license = LGPL
license = MIT
+ makedepends = boost
makedepends = cmake
makedepends = intltool
- depends = boost
+ depends = boost-libs
depends = xorg-server
- depends = libxcomposite
- depends = startup-notification
- depends = librsvg
- depends = dbus
- depends = mesa
- depends = libxslt
- depends = fuse
+ depends = fuse2
depends = glibmm
- depends = libxrender
depends = libwnck3
depends = pygtk
- depends = desktop-file-utils
depends = pyrex
depends = protobuf
depends = metacity
depends = glu
- depends = libsm
- depends = dconf
optdepends = xorg-xprop: grab various window properties for use in window matching rules
provides = compiz-core=0.9.13.1
provides = compiz-bcop=0.9.13.1
diff --git a/PKGBUILD b/PKGBUILD
index 8eca91718e75..2c4c4194b398 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@
pkgname=compiz
pkgver=0.9.13.1
-pkgrel=4
+pkgrel=5
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM"
arch=('i686' 'x86_64')
url="https://launchpad.net/compiz"
license=('GPL' 'LGPL' 'MIT')
-depends=('boost' 'xorg-server' 'libxcomposite' 'startup-notification' 'librsvg' 'dbus' 'mesa' 'libxslt' 'fuse' 'glibmm' 'libxrender' 'libwnck3' 'pygtk' 'desktop-file-utils' 'pyrex' 'protobuf' 'metacity' 'glu' 'libsm' 'dconf')
-makedepends=('cmake' 'intltool')
+depends=('boost-libs' 'xorg-server' 'fuse2' 'glibmm' 'libwnck3' 'pygtk' 'pyrex' 'protobuf' 'metacity' 'glu')
+makedepends=('boost' 'cmake' 'intltool')
optdepends=(
'xorg-xprop: grab various window properties for use in window matching rules'
)
@@ -38,6 +38,7 @@ prepare() {
patch -p1 -i "${srcdir}/reverse-unity-config.patch"
# Fix decorator start command
+ # This MUST be run AFTER reverse-unity-config.patch. Otherwise it has no effect at all
sed -i 's/exec \\"${COMPIZ_BIN_PATH}compiz-decorator\\"/exec \/usr\/bin\/compiz-decorator/g' plugins/decor/decor.xml.in
# Set focus prevention level to off which means that new windows will always get focus
@@ -76,7 +77,7 @@ build() {
-DBUILD_KDE4=Off \
-DCOMPIZ_BUILD_TESTING=Off \
-DCOMPIZ_WERROR=Off \
- -DCOMPIZ_DEFAULT_PLUGINS="composite,opengl,decor,resize,place,move,compiztoolbox,staticswitcher,regex,animation,wall,ccp" \
+ -DCOMPIZ_DEFAULT_PLUGINS="composite,opengl,decor,resize,place,move,compiztoolbox,staticswitcher,regex,animation,wall,ccp"
make
}
@@ -100,4 +101,11 @@ package() {
install -dm755 "${pkgdir}/usr/share/glib-2.0/schemas/"
install -m644 generated/glib-2.0/schemas/*.gschema.xml "${pkgdir}/usr/share/glib-2.0/schemas/"
fi
+
+ # Install licenses
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 "${srcdir}/${pkgname}-${pkgver}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 "${srcdir}/${pkgname}-${pkgver}/COPYING.GPL" "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 "${srcdir}/${pkgname}-${pkgver}/COPYING.LGPL" "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 "${srcdir}/${pkgname}-${pkgver}/COPYING.MIT" "${pkgdir}/usr/share/licenses/${pkgname}"
}