summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2015-09-14 14:44:07 +0100
committerCharles Bos2015-09-14 14:44:07 +0100
commitcbfdd626b23fa6c53691512d3e39473996d13518 (patch)
treefbb6b2b61f1bfed1d9c24e829fdd09d6d56c2391
parentd04036960a84556c6df469021664e765d9c49c84 (diff)
downloadaur-cbfdd626b23fa6c53691512d3e39473996d13518.tar.gz
add fix for double fading xfce4-notifyd notifications. add fix for blank background when using switcher or staticswitcher with emerald.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--c++11.patch104
-rw-r--r--switcher-background.patch162
-rw-r--r--xfce4-notifyd-nofade.patch12
5 files changed, 303 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfc57b56f0ef..20ef7aa1c4ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = compiz
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM (release version)
pkgver = 0.9.12.2
- pkgrel = 3
+ pkgrel = 4
url = https://launchpad.net/compiz
install = compiz.install
arch = i686
@@ -36,9 +36,15 @@ pkgbase = compiz
source = https://launchpad.net/compiz/0.9.12/0.9.12.2/+download/compiz-0.9.12.2.tar.bz2
source = focus-prevention-disable.patch
source = gtk-extents.patch
+ source = xfce4-notifyd-nofade.patch
+ source = c++11.patch
+ source = switcher-background.patch
sha256sums = 8917ac9e6dfdacc740780e1995e932ed865d293ae87821e7a280da5325daec80
sha256sums = f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b
sha256sums = 16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9
+ sha256sums = 273aa79cb0887922e3a73fbbe97596495cee19ca6f4bd716c6c7057f323d8198
+ sha256sums = eb8b432050d1eed9cb1d5f33d2645f81e2bdce2bf55d5cc779986bb751373a45
+ sha256sums = e3125ed3a7e87a7d4bdaa23f1b6f654a02d0b050ad7a694ce9165fff2c6ff310
pkgname = compiz
diff --git a/PKGBUILD b/PKGBUILD
index 75f109b9e1c9..dde5ca918dbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=compiz
pkgver=0.9.12.2
_pkgseries=0.9.12
-pkgrel=3
+pkgrel=4
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM (release version)"
arch=('i686' 'x86_64')
url="https://launchpad.net/compiz"
@@ -20,10 +20,16 @@ optdepends=(
conflicts=('compiz-core')
source=("https://launchpad.net/compiz/${_pkgseries}/${pkgver}/+download/compiz-${pkgver}.tar.bz2"
"focus-prevention-disable.patch"
- "gtk-extents.patch")
+ "gtk-extents.patch"
+ "xfce4-notifyd-nofade.patch"
+ "c++11.patch"
+ "switcher-background.patch")
sha256sums=('8917ac9e6dfdacc740780e1995e932ed865d293ae87821e7a280da5325daec80'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
- '16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9')
+ '16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
+ '273aa79cb0887922e3a73fbbe97596495cee19ca6f4bd716c6c7057f323d8198'
+ 'eb8b432050d1eed9cb1d5f33d2645f81e2bdce2bf55d5cc779986bb751373a45'
+ 'e3125ed3a7e87a7d4bdaa23f1b6f654a02d0b050ad7a694ce9165fff2c6ff310')
install='compiz.install'
prepare() {
@@ -44,6 +50,15 @@ prepare() {
# Fix incorrect extents for GTK+ tooltips, csd etc
patch -Np1 -i "${srcdir}/gtk-extents.patch"
+
+ # Ensure xfce4 notifications are not 'double faded'
+ patch -Np1 -i "${srcdir}/xfce4-notifyd-nofade.patch"
+
+ # Use C++11 (pre-requisite for switcher-background.patch)
+ patch -Np1 -i "${srcdir}/c++11.patch"
+
+ # Allow user to change switcher background colour (fixes blank background for Emerald)
+ patch -Np1 -i "${srcdir}/switcher-background.patch"
}
build() {
diff --git a/c++11.patch b/c++11.patch
new file mode 100644
index 000000000000..13aaa7fefe1b
--- /dev/null
+++ b/c++11.patch
@@ -0,0 +1,104 @@
+=== modified file 'cmake/CompizCommon.cmake'
+--- a/cmake/CompizCommon.cmake 2015-07-30 19:36:21 +0000
++++ b/cmake/CompizCommon.cmake 2015-07-30 20:16:16 +0000
+@@ -84,7 +84,7 @@
+ endif ()
+
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${COMMON_FLAGS}")
+-set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${COMMON_FLAGS}")
++set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${COMMON_FLAGS} -std=c++11")
+
+ set (COMMON_LINKER_FLAGS "-Wl,-zdefs")
+ set (CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} ${COMMON_LINKER_FLAGS}")
+
+=== modified file 'compizconfig/gsettings/mocks/CMakeLists.txt'
+--- a/compizconfig/gsettings/mocks/CMakeLists.txt 2012-10-08 13:50:56 +0000
++++ b/compizconfig/gsettings/mocks/CMakeLists.txt 2015-07-30 19:56:19 +0000
+@@ -8,7 +8,7 @@
+ ${CMAKE_CURRENT_SOURCE_DIR}/../gsettings_backend_shared
+ ${GLIB_INCLUDE_DIRS})
+
+- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+
+ add_library (compizconfig_ccs_gsettings_wrapper_mock STATIC
+ ${CMAKE_CURRENT_SOURCE_DIR}/ccs_gsettings_wrapper_mock.cpp
+
+=== modified file 'compizconfig/gsettings/tests/CMakeLists.txt'
+--- a/compizconfig/gsettings/tests/CMakeLists.txt 2013-07-17 06:06:08 +0000
++++ b/compizconfig/gsettings/tests/CMakeLists.txt 2015-07-30 19:56:19 +0000
+@@ -17,7 +17,7 @@
+
+ if (COMPIZCONFIG_TEST_GSETTINGS_FOUND)
+
+- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+
+ link_directories (${CMAKE_CURRENT_BINARY_DIR}/../../libcompizconfig/tests)
+ link_directories (${CMAKE_CURRENT_BINARY_DIR}/../testenvironments)
+
+=== modified file 'compizconfig/integration/gnome/gsettings/tests/CMakeLists.txt'
+--- a/compizconfig/integration/gnome/gsettings/tests/CMakeLists.txt 2013-05-13 13:41:19 +0000
++++ b/compizconfig/integration/gnome/gsettings/tests/CMakeLists.txt 2015-07-30 19:56:19 +0000
+@@ -11,7 +11,7 @@
+ link_directories (${CMAKE_CURRENT_BINARY_DIR}/../../tests/)
+ link_directories (${CMAKE_CURRENT_BINARY_DIR}/../src/)
+
+-set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+
+ add_executable (compizconfig_test_ccs_gnome_gsettings_integrated_setting
+ ${CMAKE_CURRENT_SOURCE_DIR}/compizconfig_test_ccs_gnome_gsettings_integrated_setting.cpp)
+
+=== modified file 'compizconfig/integration/gnome/tests/CMakeLists.txt'
+--- a/compizconfig/integration/gnome/tests/CMakeLists.txt 2013-05-13 13:42:28 +0000
++++ b/compizconfig/integration/gnome/tests/CMakeLists.txt 2015-07-30 19:56:19 +0000
+@@ -8,7 +8,7 @@
+ include_directories (${CMAKE_SOURCE_DIR}/compizconfig/tests)
+ link_directories (${CMAKE_INSTALL_PREFIX}/lib)
+
+-set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+
+ add_library (compizconfig_ccs_mock_gnome_integrated_setting_composition
+ ${CMAKE_CURRENT_SOURCE_DIR}/compizconfig_ccs_mock_gnome_integrated_setting_composition.c)
+
+=== modified file 'compizconfig/integration/mate/gsettings/tests/CMakeLists.txt'
+--- a/compizconfig/integration/mate/gsettings/tests/CMakeLists.txt 2015-02-04 22:20:18 +0000
++++ b/compizconfig/integration/mate/gsettings/tests/CMakeLists.txt 2015-07-30 19:56:19 +0000
+@@ -11,7 +11,7 @@
+ link_directories (${CMAKE_CURRENT_BINARY_DIR}/../../tests/)
+ link_directories (${CMAKE_CURRENT_BINARY_DIR}/../src/)
+
+-set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+
+ add_executable (compizconfig_test_ccs_mate_gsettings_integrated_setting
+ ${CMAKE_CURRENT_SOURCE_DIR}/compizconfig_test_ccs_mate_gsettings_integrated_setting.cpp)
+
+=== modified file 'compizconfig/integration/mate/tests/CMakeLists.txt'
+--- a/compizconfig/integration/mate/tests/CMakeLists.txt 2015-02-04 22:20:18 +0000
++++ b/compizconfig/integration/mate/tests/CMakeLists.txt 2015-07-30 19:56:19 +0000
+@@ -8,7 +8,7 @@
+ include_directories (${CMAKE_SOURCE_DIR}/compizconfig/tests)
+ link_directories (${CMAKE_INSTALL_PREFIX}/lib)
+
+-set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+
+ add_library (compizconfig_ccs_mock_mate_integrated_setting_composition
+ ${CMAKE_CURRENT_SOURCE_DIR}/compizconfig_ccs_mock_mate_integrated_setting_composition.c)
+
+=== modified file 'compizconfig/libcompizconfig/tests/CMakeLists.txt'
+--- a/compizconfig/libcompizconfig/tests/CMakeLists.txt 2013-07-17 06:06:08 +0000
++++ b/compizconfig/libcompizconfig/tests/CMakeLists.txt 2015-07-30 19:56:19 +0000
+@@ -9,7 +9,7 @@
+ link_directories (${CMAKE_CURRENT_BINARY_DIR}/../../tests/)
+ link_directories (${CMAKE_CURRENT_BINARY_DIR}/../src/)
+
+-set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+
+ add_definitions (-DSYSCONFDIR=\\\"${COMPIZ_SYSCONFDIR}\\\")
+
+
diff --git a/switcher-background.patch b/switcher-background.patch
new file mode 100644
index 000000000000..5ed29bd85f35
--- /dev/null
+++ b/switcher-background.patch
@@ -0,0 +1,162 @@
+=== modified file 'plugins/compiztoolbox/include/compiztoolbox/compiztoolbox.h'
+--- a/plugins/compiztoolbox/include/compiztoolbox/compiztoolbox.h 2013-10-31 15:59:14 +0000
++++ b/plugins/compiztoolbox/include/compiztoolbox/compiztoolbox.h 2015-08-22 21:46:01 +0000
+@@ -63,7 +63,7 @@
+ AllViewports,
+ Panels,
+ Group
+-} SwitchWindowSelection;
++} SwitchWindowSelection;
+
+ class BaseSwitchScreen
+ {
+@@ -75,6 +75,7 @@
+ void setSelectedWindowHint (bool focus);
+ void activateEvent (bool activating);
+ void updateForegroundColor ();
++ void updateBackground (bool useBackgroundColor, unsigned short backgroundColor[]);
+
+ CompWindow *switchToWindow (bool toNext, bool autoChangeVPOption, bool focus);
+ static bool compareWindows (CompWindow *w1, CompWindow *w2);
+
+=== modified file 'plugins/compiztoolbox/src/compiztoolbox.cpp'
+--- a/plugins/compiztoolbox/src/compiztoolbox.cpp 2013-05-12 08:13:05 +0000
++++ b/plugins/compiztoolbox/src/compiztoolbox.cpp 2015-08-22 21:46:01 +0000
+@@ -124,6 +124,24 @@
+ return "";
+ }
+
++void
++BaseSwitchScreen::updateBackground(bool useBackgroundColor,
++ unsigned short backgroundColor[])
++{
++ if (!popupWindow)
++ return;
++
++ unsigned long background_pixel = 0ul;
++ if (useBackgroundColor)
++ {
++ background_pixel = ((((static_cast<unsigned long>(backgroundColor [3]) * backgroundColor [2]) >> 24) & 0x0000ff) |
++ (((backgroundColor [3] * backgroundColor [1]) >> 16) & 0x00ff00) |
++ (((backgroundColor [3] * backgroundColor [0]) >> 8) & 0xff0000) |
++ (((backgroundColor [3] & 0xff00) << 16)));
++ }
++
++ XSetWindowBackground (screen->dpy(), popupWindow, background_pixel);
++}
+
+ void
+ BaseSwitchScreen::setSelectedWindowHint (bool focus)
+
+=== modified file 'plugins/staticswitcher/src/staticswitcher.cpp'
+--- a/plugins/staticswitcher/src/staticswitcher.cpp 2013-06-11 04:45:57 +0000
++++ b/plugins/staticswitcher/src/staticswitcher.cpp 2015-08-22 21:46:01 +0000
+@@ -286,6 +286,7 @@
+ (unsigned char *) &Atoms::winTypeUtil, 1);
+
+ ::screen->setWindowProp (popupWindow, Atoms::winDesktop, 0xffffffff);
++ updateBackground(optionGetUseBackgroundColor(), optionGetBackgroundColor());
+
+ setSelectedWindowHint (false);
+
+@@ -1357,6 +1358,10 @@
+ move (0),
+ mouseSelect (false)
+ {
++ auto bgUpdater = [=] (...){ this->updateBackground (this->optionGetUseBackgroundColor (), this->optionGetBackgroundColor ());};
++ optionSetUseBackgroundColorNotify (bgUpdater);
++ optionSetBackgroundColorNotify (bgUpdater);
++
+ #define SWITCHBIND(a,b,c) boost::bind (switchInitiateCommon, _1, _2, _3, a, b, c)
+
+ optionSetNextButtonInitiate (SWITCHBIND (CurrentViewport, true, true));
+
+=== modified file 'plugins/staticswitcher/staticswitcher.xml.in'
+--- a/plugins/staticswitcher/staticswitcher.xml.in 2012-10-15 10:31:51 +0000
++++ b/plugins/staticswitcher/staticswitcher.xml.in 2015-08-22 21:46:01 +0000
+@@ -293,6 +293,24 @@
+ </default>
+ </option>
+ </subgroup>
++ <subgroup>
++ <_short>Background</_short>
++ <option name="use_background_color" type="bool">
++ <_short>Set background color</_short>
++ <_long>Set background color</_long>
++ <default>false</default>
++ </option>
++ <option name="background_color" type="color">
++ <_short>Background Color</_short>
++ <_long>Background color of the switcher window.</_long>
++ <default>
++ <red>0x3333</red>
++ <green>0x3333</green>
++ <blue>0x3333</blue>
++ <alpha>0xd998</alpha>
++ </default>
++ </option>
++ </subgroup>
+ </group>
+ </options>
+ </plugin>
+
+=== modified file 'plugins/switcher/src/switcher.cpp'
+--- a/plugins/switcher/src/switcher.cpp 2015-07-25 20:01:51 +0000
++++ b/plugins/switcher/src/switcher.cpp 2015-08-22 21:46:01 +0000
+@@ -66,7 +66,6 @@
+ (WIDTH >> 1), HEIGHT - BOX_WIDTH, 0.0f,
+ };
+
+-
+ void
+ SwitchScreen::updateWindowList (int count)
+ {
+@@ -300,6 +299,7 @@
+ (unsigned char *) &Atoms::winTypeUtil, 1);
+
+ screen->setWindowProp (popupWindow, Atoms::winDesktop, 0xffffffff);
++ updateBackground (optionGetUseBackgroundColor (), optionGetBackgroundColor ());
+
+ setSelectedWindowHint (false);
+ }
+@@ -1123,6 +1123,10 @@
+
+ optionSetZoomNotify (boost::bind (&SwitchScreen::setZoom, this));
+
++ auto bgUpdater = [=] (...){ this->updateBackground (this->optionGetUseBackgroundColor (), this->optionGetBackgroundColor ());};
++ optionSetUseBackgroundColorNotify (bgUpdater);
++ optionSetBackgroundColorNotify (bgUpdater);
++
+ #define SWITCHBIND(a,b,c) boost::bind (switchInitiateCommon, _1, _2, _3, a, b, c)
+
+ optionSetNextButtonInitiate (SWITCHBIND (CurrentViewport, true, true));
+
+=== modified file 'plugins/switcher/switcher.xml.in'
+--- a/plugins/switcher/switcher.xml.in 2012-10-15 10:31:51 +0000
++++ b/plugins/switcher/switcher.xml.in 2015-08-22 21:46:01 +0000
+@@ -166,6 +166,24 @@
+ <_long>Rotate to the selected window while switching</_long>
+ <default>false</default>
+ </option>
++ <subgroup>
++ <_short>Background</_short>
++ <option name="use_background_color" type="bool">
++ <_short>Set background color</_short>
++ <_long>Set background color</_long>
++ <default>false</default>
++ </option>
++ <option name="background_color" type="color">
++ <_short>Background Color</_short>
++ <_long>Background color of the switcher window.</_long>
++ <default>
++ <red>0x3333</red>
++ <green>0x3333</green>
++ <blue>0x3333</blue>
++ <alpha>0xd998</alpha>
++ </default>
++ </option>
++ </subgroup>
+ </options>
+ </plugin>
+ </compiz>
+
diff --git a/xfce4-notifyd-nofade.patch b/xfce4-notifyd-nofade.patch
new file mode 100644
index 000000000000..0618604b4a11
--- /dev/null
+++ b/xfce4-notifyd-nofade.patch
@@ -0,0 +1,12 @@
+diff -Nur original/plugins/animation/animation.xml.in modified/plugins/animation/animation.xml.in
+--- original/plugins/animation/animation.xml.in 2015-08-20 14:01:09.000000000 +0100
++++ modified/plugins/animation/animation.xml.in 2015-09-14 14:12:42.950728084 +0100
+@@ -126,7 +126,7 @@
+ <default>
+ <value>(type=Normal | Dialog | ModalDialog | Unknown) &amp; !(name=gnome-screensaver)</value>
+ <value>(type=Menu | PopupMenu | DropdownMenu | Combo)</value>
+- <value>(type=Tooltip | Notification | Utility) &amp; !(name=compiz) &amp; !(title=notify-osd)</value>
++ <value>(type=Tooltip | Notification | Utility) &amp; !(name=compiz) &amp; !(title=notify-osd) &amp; !(name=xfce4-notifyd)</value>
+ </default>
+ </option>
+ <option name="close_options" type="list">