summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2015-11-01 10:59:21 +0000
committerCharles Bos2015-11-01 10:59:21 +0000
commitfeda286a00587da494ad6ddbe55f70a12b3af662 (patch)
tree5d7f50ca96d74e0310d5c8070a8e0d7a373cd547
parent9ab54be326c86cee2a2f8046c23b63cbef573641 (diff)
downloadaur-feda286a00587da494ad6ddbe55f70a12b3af662.tar.gz
add upstream patch for off-center cube cap pics. do not change python build dir - not necessary anymore. do not add ccp to default plugins, this is now default upstream. enable staticswitcher by default - this should not affect existing installs
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--cube-texture.patch26
3 files changed, 38 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1fc6fa455fd..82fed154950d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = compiz
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM
pkgver = 0.9.12.2
- pkgrel = 7
+ pkgrel = 8
url = https://launchpad.net/compiz
install = compiz.install
arch = i686
@@ -40,6 +40,7 @@ pkgbase = compiz
source = c++11.patch
source = switcher-background.patch
source = cmake3.patch
+ source = cube-texture.patch
sha256sums = 8917ac9e6dfdacc740780e1995e932ed865d293ae87821e7a280da5325daec80
sha256sums = f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b
sha256sums = 16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9
@@ -47,6 +48,7 @@ pkgbase = compiz
sha256sums = eb8b432050d1eed9cb1d5f33d2645f81e2bdce2bf55d5cc779986bb751373a45
sha256sums = e3125ed3a7e87a7d4bdaa23f1b6f654a02d0b050ad7a694ce9165fff2c6ff310
sha256sums = e5016fd62f9c9659d887eeafd556c18350615cd6d185c8ffa08825465890c5e0
+ sha256sums = 81780f8c56f5b27b09394ae9ed59d10ae50c58f9ade445e9f85d7c2a00445f7e
pkgname = compiz
diff --git a/PKGBUILD b/PKGBUILD
index 10ffd19307b5..dbc8041f7124 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=compiz
pkgver=0.9.12.2
_pkgseries=0.9.12
-pkgrel=7
+pkgrel=8
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM"
arch=('i686' 'x86_64')
url="https://launchpad.net/compiz"
@@ -24,14 +24,16 @@ source=("https://launchpad.net/${pkgname}/${_pkgseries}/${pkgver}/+download/${pk
"xfce4-notifyd-nofade.patch"
"c++11.patch"
"switcher-background.patch"
- "cmake3.patch")
+ "cmake3.patch"
+ "cube-texture.patch")
sha256sums=('8917ac9e6dfdacc740780e1995e932ed865d293ae87821e7a280da5325daec80'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
'273aa79cb0887922e3a73fbbe97596495cee19ca6f4bd716c6c7057f323d8198'
'eb8b432050d1eed9cb1d5f33d2645f81e2bdce2bf55d5cc779986bb751373a45'
'e3125ed3a7e87a7d4bdaa23f1b6f654a02d0b050ad7a694ce9165fff2c6ff310'
- 'e5016fd62f9c9659d887eeafd556c18350615cd6d185c8ffa08825465890c5e0')
+ 'e5016fd62f9c9659d887eeafd556c18350615cd6d185c8ffa08825465890c5e0'
+ '81780f8c56f5b27b09394ae9ed59d10ae50c58f9ade445e9f85d7c2a00445f7e')
install=${pkgname}.install
prepare() {
@@ -47,9 +49,6 @@ prepare() {
find -type f \( -name 'CMakeLists.txt' -or -name '*.cmake' \) -exec sed -e 's/COMMAND python/COMMAND python2/g' -i {} \;
find compizconfig/ccsm -type f -exec sed -e 's|^#!.*python|#!/usr/bin/env python2|g' -i {} \;
- # Fix Python build directory with CMake 3.2
- sed -i 's/${PY_BUILD_DIR}/lib/g' compizconfig/ccsm/CMakeLists.txt
-
# Fix incorrect extents for GTK+ tooltips, csd etc
patch -Np1 -i "${srcdir}/gtk-extents.patch"
@@ -64,6 +63,9 @@ prepare() {
# Get rid of the cmake policy warning messages
patch -Np1 -i "${srcdir}/cmake3.patch"
+
+ # Fix off-center cube cap pictures
+ patch -Np1 -i "${srcdir}/cube-texture.patch"
}
build() {
@@ -87,7 +89,7 @@ build() {
-DUSE_GSETTINGS=On \
-DCOMPIZ_BUILD_TESTING=Off \
-DCOMPIZ_WERROR=Off \
- -DCOMPIZ_DEFAULT_PLUGINS="composite,opengl,decor,resize,place,move,ccp" \
+ -DCOMPIZ_DEFAULT_PLUGINS="composite,opengl,decor,resize,place,move,compiztoolbox,staticswitcher" \
-DCOMPIZ_DISABLE_PLUGIN_DBUS=On
make
diff --git a/cube-texture.patch b/cube-texture.patch
new file mode 100644
index 000000000000..3c217ad58c9a
--- /dev/null
+++ b/cube-texture.patch
@@ -0,0 +1,26 @@
+=== modified file 'plugins/cubeaddon/src/cubeaddon.cpp'
+--- a/plugins/cubeaddon/src/cubeaddon.cpp 2013-05-09 13:43:07 +0000
++++ b/plugins/cubeaddon/src/cubeaddon.cpp 2015-09-22 13:33:09 +0000
+@@ -591,8 +591,8 @@
+ mCapFill[i * 3 + 1],
+ mCapFill[i * 3 + 2],
+ 1.0f);
+- float s = v * sGen;
+- float t = v * tGen;
++ float s = v * sGen + 0.5;
++ float t = v * tGen + 0.5;
+
+ *(texCoordsPtr++) = s;
+ *(texCoordsPtr++) = t;
+@@ -653,8 +653,8 @@
+ * texCoord.s = dot (vec4 (obj, 1.0), sGenPlane)
+ * texCoord.t = dot (vec4 (obj, 1.0), tGenPlane)
+ */
+- float s = v * sGen;
+- float t = v * tGen;
++ float s = v * sGen + 0.5;
++ float t = v * tGen + 0.5;
+
+ *(texCoordsPtr++) = s;
+ *(texCoordsPtr++) = t;
+