summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Bos2019-02-03 18:46:43 +0000
committerCharles Bos2019-02-03 18:46:43 +0000
commit26a1d6025f98174b74bdcdaa6e366a613ec9b7af (patch)
tree08f97eff5f1e306b22ab38c49f466e4add8ea942
parent082e035c235a63c31e0949df99a9495fae8317a6 (diff)
downloadaur-compiz-bzr.tar.gz
Cleanup dependencies list as per namcap, add a comment in prepare, install licenses, don't export PYTHON env var to python2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6036a1623ecb..bc199252189c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,37 +1,28 @@
pkgbase = compiz-bzr
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM (development version)
pkgver = 4191
- pkgrel = 2
+ pkgrel = 3
url = https://launchpad.net/compiz
arch = i686
arch = x86_64
license = GPL
license = LGPL
license = MIT
+ makedepends = boost
makedepends = cmake
makedepends = bzr
makedepends = intltool
makedepends = cython
- depends = boost
+ depends = boost-libs
depends = xorg-server
- depends = libxcomposite
- depends = startup-notification
- depends = librsvg
- depends = dbus
- depends = mesa
- depends = libxslt
- depends = fuse
+ depends = fuse2
depends = glibmm
- depends = libxrender
depends = libwnck3
- depends = desktop-file-utils
+ depends = python-gobject
+ depends = python-cairo
depends = protobuf
depends = metacity
depends = glu
- depends = libsm
- depends = dconf
- depends = python-gobject
- depends = python-cairo
optdepends = xorg-xprop: grab various window properties for use in window matching rules
provides = compiz=0.9.13
provides = compiz-core=0.9.13
diff --git a/PKGBUILD b/PKGBUILD
index d95806debf52..c8ca35889f88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@
pkgname=compiz-bzr
pkgver=4191
-pkgrel=2
+pkgrel=3
_bzrname=compiz
_bzrbranch=0.9.13
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM (development version)"
arch=('i686' 'x86_64')
url="https://launchpad.net/compiz"
license=('GPL' 'LGPL' 'MIT')
-depends=('boost' 'xorg-server' 'libxcomposite' 'startup-notification' 'librsvg' 'dbus' 'mesa' 'libxslt' 'fuse' 'glibmm' 'libxrender' 'libwnck3' 'desktop-file-utils' 'protobuf' 'metacity' 'glu' 'libsm' 'dconf' 'python-gobject' 'python-cairo')
-makedepends=('cmake' 'bzr' 'intltool' 'cython')
+depends=('boost-libs' 'xorg-server' 'fuse2' 'glibmm' 'libwnck3' 'python-gobject' 'python-cairo' 'protobuf' 'metacity' 'glu')
+makedepends=('boost' 'cmake' 'bzr' 'intltool' 'cython')
optdepends=(
'xorg-xprop: grab various window properties for use in window matching rules'
)
@@ -41,6 +41,7 @@ prepare() {
patch -p1 -i "${srcdir}/reverse-unity-config.patch"
# Fix decorator start command
+ # This MUST be run AFTER reverse-unity-config.patch. Otherwise it has no effect at all
sed -i 's/exec \\"${COMPIZ_BIN_PATH}compiz-decorator\\"/exec \/usr\/bin\/compiz-decorator/g' plugins/decor/decor.xml.in
# Set focus prevention level to off which means that new windows will always get focus
@@ -56,8 +57,6 @@ prepare() {
build() {
cd "${_bzrname}"
- export PYTHON="/usr/bin/python2"
-
mkdir build; cd build
cmake .. \
@@ -71,7 +70,7 @@ build() {
-DBUILD_KDE4=Off \
-DCOMPIZ_BUILD_TESTING=Off \
-DCOMPIZ_WERROR=Off \
- -DCOMPIZ_DEFAULT_PLUGINS="composite,opengl,decor,resize,place,move,compiztoolbox,staticswitcher,regex,animation,wall,ccp" \
+ -DCOMPIZ_DEFAULT_PLUGINS="composite,opengl,decor,resize,place,move,compiztoolbox,staticswitcher,regex,animation,wall,ccp"
make
}
@@ -95,5 +94,11 @@ package() {
install -dm755 "${pkgdir}/usr/share/glib-2.0/schemas/"
install -m644 generated/glib-2.0/schemas/*.gschema.xml "${pkgdir}/usr/share/glib-2.0/schemas/"
fi
-}
+ # Install licenses
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 "${srcdir}/${_bzrname}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 "${srcdir}/${_bzrname}/COPYING.GPL" "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 "${srcdir}/${_bzrname}/COPYING.LGPL" "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 "${srcdir}/${_bzrname}/COPYING.MIT" "${pkgdir}/usr/share/licenses/${pkgname}"
+}