summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-07-01 05:49:07 +0000
committerxiota2024-07-01 05:50:10 +0000
commit7db04acb02baa42aa48bf899161bef562b81c5ac (patch)
tree3b4817dee9a0e30612721271d56a06687883e804
parent045700cd9955d35beaec432e4fb3386aacba921e (diff)
downloadaur-compiz-git.tar.gz
add patch to fix crash in vertexbuffer
-rw-r--r--.SRCINFO4
-rw-r--r--1001-fix-crash-in-vertexbuffer.patch13
-rw-r--r--PKGBUILD27
3 files changed, 32 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed8b9be1145e..44456178269f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = compiz-git
pkgdesc = Composite manager for Aiglx and Xgl, with plugins and CCSM
pkgver = 0.9.14.2.r11.g8196e9c
- pkgrel = 1
+ pkgrel = 2
url = https://launchpad.net/compiz
arch = i686
arch = x86_64
@@ -52,11 +52,13 @@ pkgbase = compiz-git
source = 0003-gtk-extents.patch
source = 0004-screenshot-launch-fix.patch
source = 0005-no-compile-gschemas.patch
+ source = 1001-fix-crash-in-vertexbuffer.patch
sha256sums = SKIP
sha256sums = 6ec9c04540ca1649c687d9ab2c8311caea7075831e2cffe719ec7958c9ebab7b
sha256sums = f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b
sha256sums = 16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9
sha256sums = 89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61
sha256sums = 4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a
+ sha256sums = 859dca15821fac3b8d1e231d48932c0fad3f5d3f16cb53a8a761df2bd51b9d3a
pkgname = compiz-git
diff --git a/1001-fix-crash-in-vertexbuffer.patch b/1001-fix-crash-in-vertexbuffer.patch
new file mode 100644
index 000000000000..b44be7a86d07
--- /dev/null
+++ b/1001-fix-crash-in-vertexbuffer.patch
@@ -0,0 +1,13 @@
+diff --git a/plugins/opengl/src/vertexbuffer.cpp b/plugins/opengl/src/vertexbuffer.cpp
+index b102016..4e314c2 100644
+--- a/plugins/opengl/src/vertexbuffer.cpp
++++ b/plugins/opengl/src/vertexbuffer.cpp
+@@ -164,7 +164,7 @@ void GLVertexBuffer::addVertices (GLuint nVertices, const GLfloat *vertices)
+
+ GLfloat *GLVertexBuffer::getVertices() const
+ {
+- return &priv->vertexData[0];
++ return priv->vertexData.data();
+ }
+
+ int GLVertexBuffer::getVertexStride() const
diff --git a/PKGBUILD b/PKGBUILD
index 0efed6a0ff8b..4086327b874e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname='compiz'
pkgname="$_pkgname-git"
pkgver=0.9.14.2.r11.g8196e9c
-pkgrel=1
+pkgrel=2
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM"
url="https://launchpad.net/compiz"
arch=('i686' 'x86_64')
@@ -42,6 +42,15 @@ optdepends=(
'xorg-xprop: grab various window properties for use in window matching rules'
)
+provides=(
+ "ccsm=${pkgver:0:6}"
+ "compiz-bcop=${pkgver:0:6}"
+ "compiz-core=${pkgver:0:6}"
+ "compiz-plugins-extra=${pkgver:0:6}"
+ "compiz-plugins-main=${pkgver:0:6}"
+ "compizconfig-python=${pkgver:0:6}"
+ "libcompizconfig=${pkgver:0:6}"
+)
conflicts=(
'ccsm'
'compiz-bcop'
@@ -54,18 +63,9 @@ conflicts=(
'libcompizconfig'
'simple-ccsm'
)
-provides=(
- "ccsm=${pkgver:0:6}"
- "compiz-bcop=${pkgver:0:6}"
- "compiz-core=${pkgver:0:6}"
- "compiz-plugins-extra=${pkgver:0:6}"
- "compiz-plugins-main=${pkgver:0:6}"
- "compizconfig-python=${pkgver:0:6}"
- "libcompizconfig=${pkgver:0:6}"
-)
-conflicts+=('compiz')
provides+=("compiz=${pkgver:0:6}")
+conflicts+=('compiz')
_pkgsrc="$_pkgname"
source=(
@@ -85,6 +85,9 @@ source=(
# Don't try to compile gschemas during make install
"0005-no-compile-gschemas.patch"
+
+ # https://bugs.launchpad.net/compiz/+bug/2060620
+ "1001-fix-crash-in-vertexbuffer.patch"
)
sha256sums=(
'SKIP'
@@ -94,6 +97,8 @@ sha256sums=(
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
'89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61'
'4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a'
+
+ '859dca15821fac3b8d1e231d48932c0fad3f5d3f16cb53a8a761df2bd51b9d3a'
)
pkgver() {