summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2015-06-08 07:25:04 -0700
committerShadowKyogre2015-06-08 07:25:04 -0700
commited16570d19bf7719363e7000a96bb4f836830463 (patch)
tree5f66b304a05234f7f6cdac8fc0b8aeaf776be772
downloadaur-compiz-pipeitems.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
-rw-r--r--compiz-pipeitems.install14
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5129810eaf53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = compiz-pipeitems
+ pkgdesc = Compiz boxmenu pipeitems, most converted from some openbox pipemenus
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://sourceforge.net/projects/compizboxmenupi
+ install = compiz-pipeitems.install
+ arch = any
+ license = GPL
+ depends = python2
+ depends = bash
+ source = http://master.dl.sourceforge.net/project/compizboxmenupi/tarballs/compiz-boxmenu-pipeitems_-_1.0.1.tar.gz
+ md5sums = 096152235a1fa18567649a56120f2fbe
+
+pkgname = compiz-pipeitems
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..251efca68bfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: ShadowKyogre <shadowkyogre@aim.com>
+
+pkgname=compiz-pipeitems
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Compiz boxmenu pipeitems, most converted from some openbox pipemenus"
+arch=('any')
+url="http://sourceforge.net/projects/compizboxmenupi"
+license=('GPL')
+depends=('python2' 'bash')
+install=$pkgname.install
+_filename=compiz-boxmenu-pipeitems
+source=(http://master.dl.sourceforge.net/project/compizboxmenupi/tarballs/${_filename}_-_${pkgver}.tar.gz)
+md5sums=('096152235a1fa18567649a56120f2fbe')
+
+build() {
+ mkdir -p $pkgdir/usr{/bin,/share/doc/compiz-pipes}
+ msg "Putting pipeitems in correct location"
+ cp -v $srcdir/compiz_pipes/cpz{audacious,bookmarks{,_icons},trash{,_icons},calendar{,_icons}.sh,places{,_icons}.sh,browse,filebrowser,weather.py} $pkgdir/usr/bin
+ cp -v $srcdir/compiz_pipes/manage_menus.sh $pkgdir/usr/bin
+ msg "Putting README in the correct location"
+ cp -v $srcdir/compiz_pipes/README $pkgdir/usr/share/doc/compiz-pipes
+}
diff --git a/compiz-pipeitems.install b/compiz-pipeitems.install
new file mode 100644
index 000000000000..9028dc7804b8
--- /dev/null
+++ b/compiz-pipeitems.install
@@ -0,0 +1,14 @@
+post_install() {
+cat <<-EndOfMessage
+==> How to use a pipeitem:
+Insert <item type="launcher><command mode2="pipe">/path/to/the/script.extifany</command></item> into your menu via
+a text editor. You can also add this by opening the editor, select
+New, then click on pipeitem. Then type in the command for your pipeitem.
+Be sure to also read the README in /usr/share/docs/compiz-pipes/README!
+EndOfMessage
+/bin/true
+}
+
+post_upgrade() {
+ post_install
+}