summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarmelo2018-08-10 20:06:47 -0500
committerCarmelo2018-08-10 20:06:47 -0500
commit49a47d4479a2ebcbea46e7e9d7307970942e8f73 (patch)
treef934902caab038243c4ecd7a722dfdd432108a36
downloadaur-comptray-py3.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f92894e286ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = comptray-py3
+ pkgdesc = Compton toggle for the tray
+ pkgver = 1.0.r0.g2762813
+ pkgrel = 1
+ url = https://gitlab.com/carmelo_/comptray3
+ arch = any
+ license = GPL
+ depends = python
+ depends = gtk3
+ depends = python-gobject
+ depends = python-psutil
+ depends = compton
+ optdepends = compton-conf: GUI configuration for Compton
+ conflicts = comptray
+ source = comptray-py3::git+https://gitlab.com/carmelo_/comptray3.git
+ md5sums = SKIP
+
+pkgname = comptray-py3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ade0235420e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Carmelo <carmelo at cock dot li>
+
+pkgname=comptray-py3
+pkgver=1.0.r0.g2762813
+pkgrel=1
+pkgdesc="Compton toggle for the tray(python3)"
+arch=("any")
+url="https://gitlab.com/carmelo_/comptray3"
+license=("GPL")
+depends=("python" "gtk3" "python-gobject" "python-psutil" "compton")
+optdepends=("compton-conf: GUI configuration for Compton")
+conflicts=("comptray")
+source=("${pkgname}::git+${url}.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd ${pkgname}
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd ${pkgname}
+ install -Dm 755 comptray ${pkgdir}/usr/bin/comptray
+}