summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Burrett2020-10-03 11:27:04 +0100
committerNick Burrett2020-10-03 11:27:04 +0100
commit78f205e047b59ba20c900e4bb534f39279b9a463 (patch)
treefcb3f9211febd394f89c7b81b0fbf81fd2d9e714
parent9c1089d576612c3d6035a79c9bea3d4dc39c4923 (diff)
downloadaur-78f205e047b59ba20c900e4bb534f39279b9a463.tar.gz
Fix compilation errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--compilation.patch25
3 files changed, 36 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a91689ec6c8..64c2187e80fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = comskip
pkgdesc = Comskip is a free MPEG commercial break detector.
pkgver = 0.82.009
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = http://github.com/erikkaashoek/Comskip
arch = x86_64
@@ -11,7 +11,9 @@ pkgbase = comskip
depends = ffmpeg
depends = argtable
source = https://github.com/erikkaashoek/Comskip/archive/0.82.009.tar.gz
+ source = compilation.patch
sha256sums = eae287eff75f018d71a92623ffa67529f8dc75fd6165d07f1b299cdf10c2981a
+ sha256sums = 5ea83b9e7189b9f320e3890891c0273daa5325b35298a3b921a904e9a357b798
pkgname = comskip
diff --git a/PKGBUILD b/PKGBUILD
index 851b6d13264a..b4e100f9dbfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nick Burrett <nick@sqrt.co.uk>
pkgname=comskip
pkgver=0.82.009
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='Comskip is a free MPEG commercial break detector'.
_gitname='comskip'
@@ -10,9 +10,14 @@ arch=('x86_64' 'i686')
license=('GPL3')
makedepends=('git')
depends=('ffmpeg' 'argtable')
-source=("https://github.com/erikkaashoek/Comskip/archive/0.82.009.tar.gz")
-sha256sums=('eae287eff75f018d71a92623ffa67529f8dc75fd6165d07f1b299cdf10c2981a')
+source=("https://github.com/erikkaashoek/Comskip/archive/0.82.009.tar.gz"
+ "compilation.patch")
+sha256sums=('eae287eff75f018d71a92623ffa67529f8dc75fd6165d07f1b299cdf10c2981a'
+ "5ea83b9e7189b9f320e3890891c0273daa5325b35298a3b921a904e9a357b798")
+prepare() {
+ patch -p1 -i ${srcdir}/compilation.patch
+}
build() {
cd "${srcdir}/Comskip-${pkgver}"
diff --git a/compilation.patch b/compilation.patch
new file mode 100644
index 000000000000..3b19e4a92f59
--- /dev/null
+++ b/compilation.patch
@@ -0,0 +1,25 @@
+--- src/Comskip-0.82.009/video_out_sdl.c.orig 2020-10-03 11:22:19.744061757 +0100
++++ src/Comskip-0.82.009/video_out_sdl.c 2020-10-03 11:22:47.983306370 +0100
+@@ -306,10 +306,10 @@
+ unsigned char buf0[MAXWIDTH*MAXHEIGHT*3];
+
+ vo_instance_t * instance;
+-vo_setup_result_t result;
+
+ void vo_init(int width, int height, char *title)
+ {
++ vo_setup_result_t result;
+ instance = vo_sdl_open();
+ SDL_WM_SetCaption(title, "comskip");
+ sdl_setup(instance, width, height, width, height, &result);
+--- src/Comskip-0.82.009/mpeg2dec.c.orig 2020-10-03 11:21:36.328556330 +0100
++++ src/Comskip-0.82.009/mpeg2dec.c 2020-10-03 11:21:43.071709312 +0100
+@@ -161,7 +161,7 @@
+
+ int video_stream_index = -1;
+ int audio_stream_index = -1;
+-int width, height;
++// int width, height;
+ int have_frame_rate ;
+ int stream_index;
+