summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortocic2024-01-20 12:24:19 +0300
committertocic2024-01-20 12:24:19 +0300
commit61d95cbf66c3747c1a7f7040199c523863e7fcce (patch)
tree8a1637b54dbad695c5988ad783ff1bad70c5b55d
parent7388512eb32335c2cbd39cec45659c6dc6b25635 (diff)
downloadaur-concurrentqueue.tar.gz
Switch to SPDX licenses
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7bce6a95e13..b85a01e30e67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,10 @@
pkgbase = concurrentqueue
pkgdesc = A fast multi-producer, multi-consumer lock-free concurrent queue for C++11
pkgver = 1.0.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cameron314/concurrentqueue
arch = any
- license = Boost
- license = BSD
- license = ZLIB
+ license = (BSD-2-Clause AND Zlib) OR (BSL-1.0 AND Zlib)
makedepends = cmake
source = concurrentqueue-1.0.4.tar.gz::https://github.com/cameron314/concurrentqueue/archive/v1.0.4.tar.gz
b2sums = 8019a82e8cac2130e6565a07a153f17762673d1b1254e824ab0aadc9424836452ab89471513975cceb6f161a04480d58ea56679673c8459136d735d4df2de863
diff --git a/PKGBUILD b/PKGBUILD
index b8dd81dc8ee5..50315eed1be1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
pkgname=concurrentqueue
pkgdesc="A fast multi-producer, multi-consumer lock-free concurrent queue for C++11"
pkgver=1.0.4
-pkgrel=1
+pkgrel=2
arch=("any")
url="https://github.com/cameron314/concurrentqueue"
-license=("Boost" "BSD" "ZLIB")
+license=("(BSD-2-Clause AND Zlib) OR (BSL-1.0 AND Zlib)")
makedepends=("cmake")
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/cameron314/concurrentqueue/archive/v${pkgver}.tar.gz")
b2sums=("8019a82e8cac2130e6565a07a153f17762673d1b1254e824ab0aadc9424836452ab89471513975cceb6f161a04480d58ea56679673c8459136d735d4df2de863")
@@ -25,4 +25,7 @@ package() {
install -D --target-directory="${pkgdir}/usr/share/licenses/${pkgname}/" \
--mode=644 \
"${pkgname}-${pkgver}/LICENSE.md"
+ awk "/Copyright/,/\/\/ 3\./" "${pkgname}-${pkgver}/lightweightsemaphore.h" \
+ | sed "s/\/\/ \?//" \
+ > "${pkgdir}/usr/share/licenses/${pkgname}/lightweightsemaphore-Zlib.txt"
}