summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgilcu32022-09-20 17:29:16 +0200
committergilcu32022-09-20 17:29:16 +0200
commit1e6427bf956da5aa0590f1e9870e9b3deb8e00af (patch)
tree73ad9bede7d771ede686db483e5981bc70bd1838
downloadaur-conf2struct-git.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc21a35984ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = conf2struct-git
+ pkgdesc = conf2struct takes a configuration file that describes a configuration file in the libconfig format, and generates a C parser that will read a configuration file directly into a C structure
+ pkgver = 1.5.r0.g6bc9eed
+ pkgrel = 1
+ url = https://www.rutschle.net/tech/conf2struct/README.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = libconfig
+ makedepends = perl-conf-libconfig
+ makedepends = pcre2
+ makedepends = perl
+ depends = libconfig
+ depends = perl
+ depends = perl-conf-libconfig
+ provides = conf2struct
+ conflicts = conf2struct
+ source = conf2struct-git::git+https://github.com/yrutschle/conf2struct.git
+ md5sums = SKIP
+
+pkgname = conf2struct-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4305bf211326
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: gilcu3 <gilcu3 at gmail dot com>
+
+_pkgname=conf2struct
+pkgname=$_pkgname-git
+pkgver=1.5.r0.g6bc9eed
+pkgrel=1
+pkgdesc="conf2struct takes a configuration file that describes a configuration file in the libconfig format, and generates a C parser that will read a configuration file directly into a C structure"
+arch=('i686' 'x86_64')
+url='https://www.rutschle.net/tech/conf2struct/README.html'
+license=('GPL2')
+depends=('libconfig' 'perl' 'perl-conf-libconfig')
+makedepends=('git' 'libconfig' 'perl-conf-libconfig' 'pcre2' 'perl')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=($pkgname::"git+https://github.com/yrutschle/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $pkgname
+}
+
+build() {
+ cd $pkgname
+ make
+}
+
+package() {
+ # Executables
+ install -Dm755 $srcdir/$pkgname/${_pkgname} "$pkgdir/usr/bin/${_pkgname}"
+ # install -Dm755 $srcdir/$pkgname/confcheck "$pkgdir/usr/bin/confcheck"
+}
+