summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwallace2019-02-27 03:35:47 +0900
committerwallace2019-02-27 03:35:47 +0900
commitd6cc724f850b5fed1ae51dffedfbf05e717008ae (patch)
tree2951d68003db99be795adf4f9a95d231ca76d3f9
downloadaur-connectd.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD24
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1f03f7f9730
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = connectd
+ pkgdesc = Core remote.it connectivity tool for remotely connecting to any device without exposing open ports to hackers.
+ pkgver = 2.2.5
+ pkgrel = 1
+ url = https://www.remote.it
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = BSD-3-Clause
+ source_i686 = https://github.com/remoteit/installer/releases/download/v2.2.5/connectd_2.2.5_x86-etch.tar
+ md5sums_i686 = 155ff94fc5d349b4be29a843a38c53fb
+ source_x86_64 = https://github.com/remoteit/installer/releases/download/v2.2.5/connectd_2.2.5_x86_64-etch.tar
+ md5sums_x86_64 = 416fca581f711a3ca238c1e768841f8b
+ source_armv7h = https://github.com/remoteit/installer/releases/download/v2.2.5/connectd_2.2.5_arm-linaro-pi.tar
+ md5sums_armv7h = b5f951ba7fe0baf64281e0e22e15663b
+ source_aarch64 = https://github.com/remoteit/installer/releases/download/v2.2.5/connectd_2.2.5_aarm64-ubuntu16.04_static.tar
+ md5sums_aarch64 = 1e9748bfef481ca051bf5efc89459a4b
+
+pkgname = connectd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..cc34472b0bae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: wallace < str(11) + my_id at gmail dot com>
+
+pkgname='connectd'
+pkgver=2.2.5
+pkgrel=1
+pkgdesc='Core remote.it connectivity tool for remotely connecting to any device without exposing open ports to hackers.'
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url='https://www.remote.it'
+license=('BSD-3-Clause')
+depends=()
+source_i686=("https://github.com/remoteit/installer/releases/download/v${pkgver}/connectd_${pkgver}_x86-etch.tar")
+source_x86_64=("https://github.com/remoteit/installer/releases/download/v${pkgver}/connectd_${pkgver}_x86_64-etch.tar")
+source_armv7h=("https://github.com/remoteit/installer/releases/download/v${pkgver}/connectd_${pkgver}_arm-linaro-pi.tar")
+source_aarch64=("https://github.com/remoteit/installer/releases/download/v${pkgver}/connectd_${pkgver}_aarm64-ubuntu16.04_static.tar")
+md5sums_i686=('155ff94fc5d349b4be29a843a38c53fb')
+md5sums_x86_64=('416fca581f711a3ca238c1e768841f8b')
+md5sums_armv7h=('b5f951ba7fe0baf64281e0e22e15663b')
+md5sums_aarch64=('1e9748bfef481ca051bf5efc89459a4b')
+
+package() {
+ cd "${srcdir}"
+ cp -dpr --no-preserve=ownership {etc,usr} "${pkgdir}"
+ cp -dpr --no-preserve=ownership lib "${pkgdir}/usr"
+}