summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle MacLeod2018-09-04 10:57:20 -0400
committerKyle MacLeod2018-09-04 10:57:20 -0400
commite230070c3e5a6062a741d8b64214a2dea005494c (patch)
tree5e085ffe21ac61410b3e714bd100c17321ad0cf7
downloadaur-corebird-non-streaming-git.tar.gz
initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD42
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b483a8ccad1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = corebird-non-streaming-git
+ pkgdesc = Fork of corebird twitter client, modified to work within new twitter API limitations
+ pkgver = 1.1.r1710.ge843911e
+ pkgrel = 1
+ url = https://corebird.baedert.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = vala
+ makedepends = git
+ makedepends = meson
+ makedepends = intltool
+ depends = gtk3
+ depends = rest
+ depends = libgee
+ depends = sqlite3
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ depends = gst-libav
+ depends = gspell
+ optdepends = noto-fonts-emoji: Emoji support
+ provides = corebird
+ conflicts = corebird
+ conflicts = corebird-git
+ source = corebird-non-streaming-git::git+https://github.com/IBBoard/corebird.git#branch=non-streaming
+ sha1sums = SKIP
+
+pkgname = corebird-non-streaming-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d6df33398bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Kyle MacLeod <aur.kmac5@recursor..net>
+# Modified from corebird-git
+
+pkgname=corebird-non-streaming-git
+pkgver=1.1.r1710.ge843911e
+pkgrel=1
+pkgdesc="Fork of corebird twitter client, modified to work within new twitter API limitations"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="https://corebird.baedert.org/"
+depends=('gtk3'
+ 'rest'
+ 'libgee'
+ 'sqlite3'
+ 'gst-plugins-good'
+ 'gst-plugins-bad'
+ 'gst-libav'
+ 'gspell')
+optdepends=('noto-fonts-emoji: Emoji support')
+makedepends=('vala' 'git' 'meson' 'intltool')
+provides=('corebird')
+conflicts=('corebird' 'corebird-git')
+source=("${pkgname}::git+https://github.com/IBBoard/corebird.git#branch=non-streaming")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${pkgname}
+
+ meson builddir --prefix=/usr -D VIDEO=yes -D SPELLCHECK=yes
+ ninja -C builddir
+}
+
+package() {
+ cd ${pkgname}
+
+ DESTDIR="${pkgdir}" ninja -C builddir install
+}