summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyril Courtiat2015-09-10 07:43:54 +0200
committerCyril Courtiat2015-09-10 07:43:54 +0200
commit3574df164bfa4fe27aef1f6e70f441610d5b4141 (patch)
tree1c1c28786bd2c7748d14786442852250d0d0a8a1
downloadaur-3574df164bfa4fe27aef1f6e70f441610d5b4141.tar.gz
Initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
-rw-r--r--corefreq-git.install17
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07a2c648334e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = corefreq
+ pkgdesc = Processor Core Monitoring
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://github.com/cyring/CoreFreq
+ install = corefreq-git.install
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = linux-headers
+ source = git+https://github.com/cyring/CoreFreq.git
+ md5sums = SKIP
+
+pkgname = corefreq-git
+ pkgdesc = IntelFreq kernel module sources
+ depends = dkms
+ depends = gcc
+ depends = make
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4506642e2ae6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: CyrIng <labs[at]cyring[dot]fr>
+# Contributor: CyrIng <labs[at]cyring[dot]fr>
+pkgbase=corefreq
+pkgname=corefreq-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Processor Core Monitoring'
+arch=('x86_64')
+url='http://github.com/cyring/CoreFreq'
+license=('GPL2')
+makedepends=('git' 'linux-headers')
+source=('git+https://github.com/cyring/CoreFreq.git')
+md5sums=('SKIP')
+install=${pkgname}.install
+
+_gitname=CoreFreq
+
+build() {
+ cd ${srcdir}/${_gitname}
+ make -w -j1
+}
+
+package() {
+ pkgdesc='IntelFreq kernel module sources'
+ depends=('dkms' 'gcc' 'make')
+ install -dm755 "${pkgdir}/usr/src"
+ cd ${srcdir}/${_gitname}
+ install -Dm755 corefreqd "${pkgdir}/usr/bin/corefreqd"
+ install -Dm644 corefreqd.service "${pkgdir}/usr/lib/systemd/system/corefreqd.service"
+ install -m755 corefreq-cli "${pkgdir}/usr/bin/corefreq-cli"
+ mkdir "${pkgdir}/usr/src/${pkgbase}-${pkgver}/"
+ install -Dm644 dkms.conf "${pkgdir}/usr/src/${pkgbase}-${pkgver}/dkms.conf"
+ cp --no-preserve=ownership Makefile *.h *.c dkms.conf *.install \
+ "${pkgdir}/usr/src/${pkgbase}-${pkgver}/"
+}
diff --git a/corefreq-git.install b/corefreq-git.install
new file mode 100644
index 000000000000..b8872789b653
--- /dev/null
+++ b/corefreq-git.install
@@ -0,0 +1,17 @@
+post_install() {
+ dkms install corefreq/${1%%-*}
+ echo 'modprobe or insmod the kernel module intelfreq.ko prior to start corefreqd.service and'
+ echo 'use systemd to start corefreqd.service prior to running corefreq-cli'
+}
+
+pre_upgrade() {
+ pre_remove ${2%%-*}
+}
+
+post_upgrade() {
+ post_install ${1%%-*}
+}
+
+pre_remove() {
+ dkms remove corefreq/${1%%-*} --all
+}