summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-05-09 13:11:49 -0600
committerMark Wagie2024-05-09 13:11:49 -0600
commitc471b61e1e704e80ec7db2502e69daca94419c3b (patch)
treeb04337ab303a8ed9e7549faa6ce3f47e666bede6
parent23b2a30726012172f4458d82d0a690baf88c8e7a (diff)
downloadaur-cosmic-workspaces-git.tar.gz
use mold linker
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1bcf46781140..4e5b8f553e16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,7 @@ pkgbase = cosmic-workspaces-git
license = GPL-3.0-or-later
makedepends = cargo
makedepends = git
+ makedepends = mold
depends = libinput
depends = libxkbcommon
depends = mesa
diff --git a/PKGBUILD b/PKGBUILD
index e7f789b56995..3cd60fa24abf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,6 +16,7 @@ depends=(
makedepends=(
'cargo'
'git'
+ 'mold'
)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -38,7 +39,12 @@ build() {
cd cosmic-workspaces-epoch
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
- make prefix='/usr' VENDOR='1' all
+
+ # use mold instead of lld to speed up build
+ RUSTFLAGS="-C link-arg=-fuse-ld=mold"
+
+ # use nice to build with lower priority
+ nice make prefix='/usr' VENDOR='1' all
}
package() {