summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-06-22 11:58:03 +0300
committerIgor Dyatlov2022-06-22 11:58:03 +0300
commitf5701229d44ee1be62fad01ca250044e6799254a (patch)
tree5ff20fb7dac1d84b4fb2a6c67f5668c0d4d3004b
downloadaur-countdown-git.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc854a84c473
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = countdown-git
+ pkgdesc = Track events until they happen or since they happened
+ pkgver = r35.001f526
+ pkgrel = 1
+ url = https://github.com/lainsce/countdown
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = meson
+ makedepends = gobject-introspection
+ makedepends = vala
+ depends = json-glib
+ depends = libadwaita
+ depends = libgee
+ provides = countdown
+ conflicts = countdown
+ source = git+https://github.com/lainsce/countdown.git
+ b2sums = SKIP
+
+pkgname = countdown-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50684fca0eb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=countdown-git
+pkgver=r35.001f526
+pkgrel=1
+pkgdesc="Track events until they happen or since they happened"
+arch=('x86_64' 'aarch64')
+url="https://github.com/lainsce/countdown"
+license=('GPL3')
+depends=('json-glib' 'libadwaita' 'libgee')
+makedepends=('meson' 'gobject-introspection' 'vala')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(git+$url.git)
+b2sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ arch-meson "${pkgname%-git}" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build || :
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}