summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2019-06-30 13:21:10 +0100
committerEric Engestrom2021-04-25 22:38:06 +0200
commitc7d97829df73cfe4f896531afd9fe9e15ca4e6c3 (patch)
treebd8493e81d7445071c39d29bf3ff511f54e471ed
parent26a0072c5003cc4791ce7ed4c261152edfea7d3d (diff)
downloadaur-c7d97829df73cfe4f896531afd9fe9e15ca4e6c3.tar.gz
drop unnecessary external file for PATH handling
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--cov-analysis.sh1
3 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e730891dac8b..c721bd5c243b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,8 +9,6 @@ pkgbase = cov-analysis
makedepends = libarchive
depends = java-environment
options = !strip
- source = cov-analysis.sh
- sha256sums = a36e738b4eae818cbc2c6ace3cae8a075c7e6f5d282c059397441e91208c8e97
source_i686 = https://scan.coverity.com/download/cxx/linux32
sha256sums_i686 = a0e6c35db1effbbc33194f5aa8db63619911306314ce29c278a0bec2002038ed
source_x86_64 = https://scan.coverity.com/download/cxx/linux64
diff --git a/PKGBUILD b/PKGBUILD
index 5c7c71adc575..9a14b0da48b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,6 @@ url='https://scan.coverity.com/download'
arch=('i686' 'x86_64')
license=('custom')
depends=('java-environment')
-source=("$pkgname.sh")
-sha256sums=('a36e738b4eae818cbc2c6ace3cae8a075c7e6f5d282c059397441e91208c8e97')
makedepends=('libarchive')
options=('!strip')
@@ -27,7 +25,9 @@ package() {
chown root: -R "$pkgdir/opt/$pkgname/"
cd "$srcdir"
- install -dm755 "$pkgdir/etc/profile.d"
- sed "s#@PATH@#/opt/$pkgname/bin#g" "$pkgname.sh" > "$pkgdir/etc/profile.d/$pkgname.sh"
+ install -d "$pkgdir/etc/profile.d"
+ printf > "$pkgdir/etc/profile.d/$pkgname.sh" \
+ 'export PATH="$PATH":%s\n' \
+ "/opt/$pkgname/bin"
chmod 644 "$pkgdir/etc/profile.d/$pkgname.sh"
}
diff --git a/cov-analysis.sh b/cov-analysis.sh
deleted file mode 100644
index 46e321ceeeea..000000000000
--- a/cov-analysis.sh
+++ /dev/null
@@ -1 +0,0 @@
-export PATH=$PATH:@PATH@