summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-06-12 13:55:41 +0200
committerMattias Andrée2015-06-12 13:55:41 +0200
commit9265e03b9f79c66b24d946f7207e23573ebc8004 (patch)
tree5ea79f412158529a58c4db1504685701de35d71b
downloadaur-cowberry-boot.tar.gz
Initial import, version 1.0.1
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD33
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e78dba3ac766
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = cowberry-boot
+ pkgdesc = A minimal sysvinit script set designed for Raspberry Pi
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/maandree/cowberry-boot
+ arch = armv6h
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = make
+ makedepends = gcc
+ makedepends = glibc
+ makedepends = coreutils
+ depends = sysvinit
+ depends = dash
+ depends = coreutils
+ depends = util-linux
+ depends = grep
+ depends = filesystem
+ depends = glibc
+ optdepends = kbd
+ optdepends = kmod
+ optdepends = udev
+ conflicts = initscripts
+ conflicts = initscripts-fork
+ conflicts = pony-initialisation
+ backup = etc/rc.local.devd.wait
+ backup = etc/rc.local.hooks
+ backup = etc/rc.local.shutdown
+ backup = etc/rc.local
+ backup = etc/rc.multi
+ backup = etc/rc.shutdown
+ backup = etc/rc.single
+ backup = etc/rc.sysinit
+ backup = etc/inittab
+ backup = etc/rc.conf
+ source = https://github.com/maandree/cowberry-boot/archive/1.0.1.tar.gz
+ sha256sums = 19841d59d8f9a416f76afc4b8fe665eea9918d9a0843bccd5fec14b2753e0ec3
+
+pkgname = cowberry-boot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..506bfa886b14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=cowberry-boot
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A minimal sysvinit script set designed for Raspberry Pi"
+url="https://github.com/maandree/cowberry-boot"
+arch=(armv6h x86_64 i686)
+license=(GPL3)
+backup=(etc/rc.local{.devd.wait,.hooks,.shutdown,} etc/rc.{multi,shutdown,single,sysinit} etc/{inittab,rc.conf})
+depends=(sysvinit dash coreutils util-linux grep filesystem glibc)
+optdepends=(kbd kmod udev)
+makedepends=(make gcc glibc coreutils)
+conflicts=(initscripts initscripts-fork pony-initialisation)
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(19841d59d8f9a416f76afc4b8fe665eea9918d9a0843bccd5fec14b2753e0ec3)
+
+
+build() {
+ cd "${srcdir}/cowberry-boot-${pkgver}"
+ make DESTDIR="${pkgdir}"
+
+ # Use util-linux::agetty instead of gates-of-tartaros as default
+ sed -i 's:/sbin/got tty\([0-9]*\) TERM=linux:/sbin/agetty -8 -s 38400 tty\1 linux:' conf/inittab
+}
+
+package() {
+ cd "${srcdir}/cowberry-boot-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ _dir="${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+