summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Gjengset2015-10-06 19:47:59 -0400
committerJon Gjengset2015-10-06 19:48:55 -0400
commit7cdbd3104fda2d1ff45d8f7a99dd56f2fb6eda69 (patch)
tree669ae0687adda7f0de06b8045ee213edea1bf0e3
parentdc33e63b8b60f57267cb30b14cf1b6348c4e8c7f (diff)
downloadaur-7cdbd3104fda2d1ff45d8f7a99dd56f2fb6eda69.tar.gz
tput patch has been merged
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--tput.patch28
3 files changed, 6 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 497f33d89024..0be5ad98f863 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = coz-git
pkgdesc = a new kind of profiler that measures optimization potential
- pkgver = r239.935fc29
+ pkgver = r241.3a4fa41
pkgrel = 1
url = https://github.com/plasma-umass/coz
arch = x86_64
@@ -11,11 +11,9 @@ pkgbase = coz-git
source = coz-git::git+https://github.com/plasma-umass/coz.git
source = python2.patch
source = no-force-preload.patch
- source = tput.patch
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
md5sums = SKIP
+ md5sums = f3ff4dcc098eb00e949b362594918517
+ md5sums = b7926ac1504babe0b2551983d2d5ed25
pkgname = coz-git
diff --git a/PKGBUILD b/PKGBUILD
index 76f0859517b3..88cf537d5eb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jon Gjengset <jon@thesquareplanet.com>
pkgname=coz-git
-pkgver=r239.935fc29
+pkgver=r241.3a4fa41
pkgrel=1
pkgdesc="a new kind of profiler that measures optimization potential"
arch=('x86_64')
@@ -11,11 +11,10 @@ makedepends=('git')
options=()
install=
source=('coz-git::git+https://github.com/plasma-umass/coz.git'
- 'python2.patch' 'no-force-preload.patch' 'tput.patch')
+ 'python2.patch' 'no-force-preload.patch')
md5sums=('SKIP'
'f3ff4dcc098eb00e949b362594918517'
- 'b7926ac1504babe0b2551983d2d5ed25'
- 'e14ecdc19cbf244388d6af0a55046083')
+ 'b7926ac1504babe0b2551983d2d5ed25')
pkgver() {
cd "$srcdir/$pkgname"
@@ -26,7 +25,6 @@ prepare() {
cd "$srcdir/$pkgname"
patch -Np1 < "$srcdir/python2.patch"
patch -Np1 < "$srcdir/no-force-preload.patch"
- patch -Np1 < "$srcdir/tput.patch"
}
build() {
diff --git a/tput.patch b/tput.patch
deleted file mode 100644
index b14996663781..000000000000
--- a/tput.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/common.mk b/common.mk
-index 643e91d..dcc7b0e 100644
---- a/common.mk
-+++ b/common.mk
-@@ -26,8 +26,8 @@ OTHER_TARGETS := $(filter-out %.so, $(filter-out %.a, $(TARGETS)))
- MAKEPATH ?= `basename $(PWD)`
-
- # Log the build path in gray, following by a log message in bold green
--LOG_PREFIX := "\033[37;0m[$(MAKEPATH)]\033[0m\033[32;1m"
--LOG_SUFFIX := "\033[0m"
-+LOG_PREFIX := "$(shell tput setaf 7)[$(MAKEPATH)]$(shell tput sgr0)$(shell tput setaf 2)"
-+LOG_SUFFIX := "$(shell tput sgr0)"
-
- # Build all targets by default
- all:: $(TARGETS)
-@@ -77,10 +77,10 @@ bench_inputs:
- test_inputs:
-
- bench:: $(OTHER_TARGETS) bench_inputs
-- $(ROOT)/coz run $(COZ_ARGS) --- ./$< $(BENCH_ARGS)
-+ coz run $(COZ_ARGS) --- ./$< $(BENCH_ARGS)
-
- test:: $(OTHER_TARGETS) test_inputs
-- $(ROOT)/coz run $(COZ_ARGS) --- ./$< $(TEST_ARGS)
-+ coz run $(COZ_ARGS) --- ./$< $(TEST_ARGS)
- endif
-
- # Include dependency rules for all objects