summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAliaksandr Mianzhynski2020-07-02 17:40:15 +0300
committerAliaksandr Mianzhynski2020-07-02 17:40:15 +0300
commitd67db9336dd3fe609620bde8ab581e6d67e10c48 (patch)
tree07323565f12b6948fe0c8561608e648fd10e9c97
parent1247d25fab52f3475bc52cfa9f370d4ca65d7892 (diff)
downloadaur-cp210x.tar.gz
Move dkms version to separate pkgbuild
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
-rw-r--r--README.md5
-rw-r--r--dkms.conf9
4 files changed, 4 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 820188c215ab..f1ad857b72f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,16 @@
pkgbase = cp210x
pkgdesc = Silicon Labs CP210x RS232 serial adaptor driver
pkgver = 2019.7.12
- pkgrel = 5
+ pkgrel = 6
url = https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers
arch = x86_64
license = GPL
makedepends = linux-headers
depends = linux
source = https://www.silabs.com/documents/login/software/Linux_3.x.x_4.x.x_VCP_Driver_Source.zip
- source = dkms.conf
source = override-kversion.patch
sha256sums = 7d624cd66ee610fd9c6598793534ed593ac1309b3d3b3699c101d921ad9ccd7c
- sha256sums = 62da72a3f8f9566326168a759cb5cc54b8c39aeb6594e1b4229774868c7eb3d2
sha256sums = 4dfcb1fff04a30ccd4b1b6f8d7bba0aada7712aac2b6f3deff792d98f98f651f
pkgname = cp210x
-pkgname = cp210x-dkms
- arch = any
- depends = dkms
- provides = cp210x=2019.7.12-5
- conflicts = cp210x
-
diff --git a/PKGBUILD b/PKGBUILD
index 7aa212b41f53..48b4d3b79351 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Alexander Menzhinsky <amenzhinsky@gmail.com>
-pkgbase=cp210x
-pkgname=(cp210x cp210x-dkms)
+pkgname=cp210x
pkgver=2019.7.12
-pkgrel=5
+pkgrel=6
pkgdesc='Silicon Labs CP210x RS232 serial adaptor driver'
url='https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers'
arch=("$(uname -m)")
@@ -10,17 +9,15 @@ license=('GPL')
depends=('linux')
makedepends=('linux-headers')
source=("https://www.silabs.com/documents/login/software/Linux_3.x.x_4.x.x_VCP_Driver_Source.zip"
- dkms.conf
override-kversion.patch)
sha256sums=('7d624cd66ee610fd9c6598793534ed593ac1309b3d3b3699c101d921ad9ccd7c'
- '62da72a3f8f9566326168a759cb5cc54b8c39aeb6594e1b4229774868c7eb3d2'
'4dfcb1fff04a30ccd4b1b6f8d7bba0aada7712aac2b6f3deff792d98f98f651f')
prepare() {
patch Makefile < override-kversion.patch
}
-package_cp210x() {
+package() {
make KVERSION="$(</usr/src/linux/version)"
install -Dt "$pkgdir/usr/lib/modules/$(</usr/src/linux/version)/extramodules" -m644 *.ko
find "$pkgdir" -name '*.ko' -exec xz {} +
@@ -29,16 +26,3 @@ package_cp210x() {
mkdir -p "$pkgdir/usr/share/cp210x"
}
-
-package_cp210x-dkms() {
- arch=("any")
- depends=(dkms)
- provides=("cp210x=$pkgver-$pkgrel")
- conflicts=(cp210x)
-
- install -Dt "$pkgdir/usr/src/$pkgbase-$pkgver" -m644 Makefile cp210x.c dkms.conf
-
- echo cp210x | install -Dm644 /dev/stdin "$pkgdir/usr/lib/modules-load.d/cp210x.conf"
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/README.md b/README.md
deleted file mode 100644
index 5e939699f8ad..000000000000
--- a/README.md
+++ /dev/null
@@ -1,5 +0,0 @@
-# cp210x
-
-Silicon Labs CP210x USB to UART Bridge VCP kernel modules for Arch Linux.
-
-Provides both [standalone](https://aur.archlinux.org/packages/cp210x/) and [dkms](https://aur.archlinux.org/packages/cp210x-dkms/) versions.
diff --git a/dkms.conf b/dkms.conf
deleted file mode 100644
index 5723f5bdb79b..000000000000
--- a/dkms.conf
+++ /dev/null
@@ -1,9 +0,0 @@
-PACKAGE_NAME="cp210x"
-PACKAGE_VERSION="#MODULE_VERSION#"
-AUTOINSTALL="yes"
-
-MAKE[0]="make KVERSION=$kernelver"
-CLEAN="make clean"
-
-BUILT_MODULE_NAME[0]="cp210x"
-DEST_MODULE_LOCATION[0]="/kernel/drivers/cp210x"