summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSonic-Y3k2015-06-09 00:14:20 +0200
committerSonic-Y3k2015-06-09 00:14:20 +0200
commitf8aaf18dce6ae81533ac06bef217cac579429b5e (patch)
tree7e12128a46817abfaf9b2c2944c80c8a92f4bba9
downloadaur-cpm-git.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD46
-rw-r--r--cpm-git.install13
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0411d3af5d99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cpm-git
+ pkgdesc = Curses based password manager using PGP-encryption
+ pkgver = 0.32.r0.ge90c7f0
+ pkgrel = 1
+ url = http://github.com/comotion/cpm
+ install = cpm-git.install
+ arch = i686
+ arch = x86_64
+ license = GNU2
+ makedepends = git
+ makedepends = libcdk>=5.0
+ makedepends = txt2man
+ depends = gpgme
+ depends = libxml2>=2.6.16
+ depends = cracklib
+ provides = cpm
+ source = cpm-git::git://github.com/comotion/cpm.git
+ sha512sums = SKIP
+
+pkgname = cpm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..382ee508e38a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Sonic-Y3k <sonic.y3k@googlemail.com>
+pkgname=cpm-git
+pkgver=0.32.r16.gbcd387e
+pkgrel=1
+pkgdesc="Curses based password manager using PGP-encryption"
+arch=('i686' 'x86_64')
+url="http://github.com/comotion/cpm"
+license=('GPL2')
+depends=('gpgme' 'libxml2>=2.6.16' 'cracklib' 'libcdk>=5.0' 'dotconf')
+makedepends=('git' 'libcdk>=5.0' 'txt2man')
+provides=('cpm')
+conflicts=('cpm-git')
+install=$pkgname.install
+source=("$pkgname"::'git://github.com/comotion/cpm.git')
+
+sha512sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ sed 's%/usr/include/cdk/cdk.h%/usr/include/cdk.h%g' -i configure
+}
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./configure --prefix=/usr \
+ --with-cracklib-dir=/usr/share/cracklib \
+ --with-cracklib-dict=/usr/share/cracklib/pw_dict \
+ --with-cdk-dir=/usr/include/cdk
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -d "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/share/locale/de/LC_MESSAGES"
+
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+
+ install -d "$pkgdir/usr/share/cpm"
+ cp -r $srcdir/$pkgname/share/cpm/* "$pkgdir/usr/share/cpm/"
+}
diff --git a/cpm-git.install b/cpm-git.install
new file mode 100644
index 000000000000..051e6d5de466
--- /dev/null
+++ b/cpm-git.install
@@ -0,0 +1,13 @@
+post_install () {
+ post_upgrade
+}
+
+post_upgrade () {
+ # Create new database
+ echo "You must have a keypair:
+ /usr/bin/gpg --gen-key"
+ echo
+ echo "To create a new password database run:
+ /usr/bin/create-cpmdb"
+ echo
+}