summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2020-09-13 10:55:09 +0200
committerKenjiTakahashi2020-09-13 10:55:09 +0200
commit82825be104f7e26d92a1711b0c34482861121f21 (patch)
tree232855483d7c856a3e9160411b015ed0b3660d7c
parentb559a56e099491a9c80e3c129b23b968261b92f4 (diff)
downloadaur-cpputest.tar.gz
4.0-1: Bumped version
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD4
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f25aceaf0e3a..c368dff122cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Jun 5 19:24:30 UTC 2016
pkgbase = cpputest
pkgdesc = unit testing and mocking framework for C/C++
- pkgver = 3.8
+ pkgver = 4.0
pkgrel = 1
url = http://cpputest.org
arch = i686
@@ -11,8 +9,8 @@ pkgbase = cpputest
provides = cpputest
options = staticlibs
options = !strip
- source = https://github.com/cpputest/cpputest/releases/download/v3.8/cpputest-3.8.tar.gz
- md5sums = e8fdbbb5dd37d32d65919f240f984905
+ source = https://github.com/cpputest/cpputest/releases/download/v4.0/cpputest-4.0.tar.gz
+ sha256sums = 21c692105db15299b5529af81a11a7ad80397f92c122bd7bf1e4a4b0e85654f7
pkgname = cpputest
diff --git a/.gitignore b/.gitignore
index d778e6b9e155..df5f8cf4200c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,5 @@
*.tar.gz
pkg/
src/
+*.log
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index b50c355c537a..a7f8140a328d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
pkgname=cpputest
-pkgver=3.8
+pkgver=4.0
pkgrel=1
pkgdesc="unit testing and mocking framework for C/C++"
url="http://cpputest.org"
@@ -10,7 +10,7 @@ license=('BSD')
provides=('cpputest')
options=('staticlibs' '!strip')
source=("https://github.com/${pkgname}/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('e8fdbbb5dd37d32d65919f240f984905')
+sha256sums=('21c692105db15299b5529af81a11a7ad80397f92c122bd7bf1e4a4b0e85654f7')
build() {
cd ${srcdir}/${pkgname}-${pkgver}