summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Lui Geh2023-05-29 17:20:47 -0300
committerRenato Lui Geh2023-05-29 17:20:47 -0300
commit013215a41f2d6e03e3375a88746cc2d163d3bbdf (patch)
tree72a675ffa7d9db5beec901c3494b6221e177edec
parent375021cbb5aa0724973d97f3f94042545e44992f (diff)
downloadaur-cppyy-backend.tar.gz
Follow AUR standards
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a27d557d6fa6..b714f01971f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = cppyy-backend
pkgdesc = Cling-based Python-C++ bindings (backend)
pkgver = 1.14.11
- pkgrel = 1
+ pkgrel = 2
url = https://cppyy.readthedocs.io/en/latest/index.html
arch = any
license = LBNL BSD
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = cppyy-cling
- depends = python-wheel
- source = https://files.pythonhosted.org/packages/46/d4/d0c61d448891aa37253c98acf5cde26abd4ac5851e108976aa58b97c5011/cppyy-backend-1.14.11.tar.gz
+ source = https://files.pythonhosted.org/packages/source/c/cppyy-backend/cppyy-backend-1.14.11.tar.gz
sha256sums = 2d329adce65b421a4e8a1af36116fb1756571349dc6b22a9ac3dde54b2a30af1
pkgname = cppyy-backend
diff --git a/PKGBUILD b/PKGBUILD
index b7711c0427ea..455afc405783 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,22 @@
pkgname=cppyy-backend
pkgver=1.14.11
-pkgrel=1
+pkgrel=2
pkgdesc="Cling-based Python-C++ bindings (backend)"
arch=('any')
url="https://cppyy.readthedocs.io/en/latest/index.html"
license=('LBNL BSD')
-depends=('python' 'cppyy-cling' 'python-wheel')
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/46/d4/d0c61d448891aa37253c98acf5cde26abd4ac5851e108976aa58b97c5011/${pkgname}-${pkgver}.tar.gz")
+depends=('python' 'cppyy-cling')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('2d329adce65b421a4e8a1af36116fb1756571349dc6b22a9ac3dde54b2a30af1')
build() {
- cd $srcdir/${pkgname}-${pkgver}
- python3 setup.py build
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd $srcdir/${pkgname}-${pkgver}
- python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
-