summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXorg2020-03-11 19:06:29 +0100
committerXorg2020-03-11 19:06:29 +0100
commitcfa1da6db2c87ed221e969928bb2504c4c5d6095 (patch)
tree08cd913076719d094706aa17cbb5e103ff53454a
parente483a3bf6f7828e9ade67087f90e22107f2c27b2 (diff)
downloadaur-cfa1da6db2c87ed221e969928bb2504c4c5d6095.tar.gz
Disable libcurl support (pkgrel=2)
As suggested by @utsi
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5d72b9816b5..a580f3023c38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cpu-x-git
pkgdesc = A Free software that gathers information on CPU, motherboard and more
- pkgver = 3.2.4.r55.g2c44e34
- pkgrel = 1
+ pkgver = 3.2.4.r90.g6af5049
+ pkgrel = 2
url = http://X0rg.github.io/CPU-X/
arch = i686
arch = x86_64
@@ -10,13 +10,14 @@ pkgbase = cpu-x-git
makedepends = nasm
depends = gtk3
depends = ncurses
- depends = curl
depends = json-c
depends = libcpuid
depends = pciutils
depends = procps-ng
provides = cpu-x
conflicts = cpu-x
+ options = !strip
+ options = debug
source = git+https://github.com/X0rg/CPU-X.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 50cb9e95f76c..cc9727c80e6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
_realname=CPU-X
pkgname=cpu-x-git
-pkgver=3.2.4.r55.g2c44e34
-pkgrel=1
+pkgver=3.2.4.r90.g6af5049
+pkgrel=2
pkgdesc="A Free software that gathers information on CPU, motherboard and more"
arch=('i686' 'x86_64')
url="http://X0rg.github.io/CPU-X/"
license=('GPL3')
-depends=('gtk3' 'ncurses' 'curl' 'json-c' 'libcpuid' 'pciutils' 'procps-ng')
+depends=('gtk3' 'ncurses' 'json-c' 'libcpuid' 'pciutils' 'procps-ng')
makedepends=('cmake' 'nasm')
provides=('cpu-x')
conflicts=('cpu-x')
source=("git+https://github.com/X0rg/CPU-X.git")
md5sums=('SKIP')
+options=('!strip' 'debug')
pkgver() {
cd "$_realname"
@@ -26,9 +27,10 @@ prepare() {
}
build() {
+ export CFLAGS="$CFLAGS -Wno-implicit-function-declaration" # To avoid warning about 'check_new_version()' caused by 'WITH_LIBCURL=0'
cd "$_realname/build"
msg2 "Run 'cmake'..."
- cmake -DCMAKE_BUILD_TYPE=Debug -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBEXECDIR=/usr/lib/cpu-x ..
+ cmake -DCMAKE_BUILD_TYPE=Debug -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBEXECDIR=/usr/lib/cpu-x -DWITH_LIBCURL=0 ..
msg2 "Run 'make'..."
make