summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLitao Lu2018-08-03 15:29:45 +0800
committerVic Luo2018-08-03 15:29:45 +0800
commit33b4e6a831f8f1d801753a54c7747e952f189318 (patch)
treecc08080ea3144340d5320d6e1437ae15bc644b0d
parent24800b283d7b6996741f368ba0a3797e1929903e (diff)
downloadaur-33b4e6a831f8f1d801753a54c7747e952f189318.tar.gz
update to cmake build system
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79e5ee5fcf78..4000b03d6a56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
# Maintainer: Vic Luo <vicluo96 at gmail.com>
+# Contributor: Litao Lu <lulitao1997 at gmail.com>
pkgname=cquery-git
_pkgname=cquery
-pkgver=1562.c552d97a
+pkgver=1942.3ac1ff24
pkgrel=1
pkgdesc='Low-latency vscode language server for large C++ code-bases, powered by libclang.'
-arch=('any')
+arch=('x86_64')
url='https://github.com/cquery-project/cquery/'
license=('MIT')
depends=('clang')
-makedepends=("git" "python" "llvm")
+makedepends=('cmake')
+
source=('git+https://github.com/cquery-project/cquery.git')
md5sums=(
'SKIP'
@@ -22,22 +24,18 @@ pkgver() {
prepare() {
cd $_pkgname
- git submodule update --init
+ git submodule update --init --recursive
}
build() {
cd $_pkgname
- # --variant=custom will not add extra CXXFLAGS
- python waf configure --variant=custom --prefix="$pkgdir/usr" --llvm-config=/usr/bin/llvm-config
- python waf build --variant=custom
+ mkdir -p build
+ cd build
+ cmake -DSYSTEM_CLANG=ON -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ make -j$(nproc)
}
-#check() {
-# cd $_pkgname
-# yes | build/custom/bin/cquery --test-unit --test-index --clang-sanity-check
-#}
-
package() {
- cd $_pkgname
- python waf install --variant=custom
+ cd $_pkgname/build
+ make DESTDIR="$pkgdir/" install
}