summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFangrui Song2018-02-02 14:27:16 -0800
committerFangrui Song2018-02-02 14:27:16 -0800
commitefd29b58b7922d70f07c4151a4f2084bf1907f51 (patch)
treea71f53a20efa8c0cc37825307cc386446d44db34
parente50c42c0930a278a52a2ae6f94ef80556c88142f (diff)
downloadaur-efd29b58b7922d70f07c4151a4f2084bf1907f51.tar.gz
--variant=custom
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb91d89e4bf6..4ad29874003c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cquery-git
_pkgname=cquery
-pkgver=1284.f96f20f
+pkgver=1374.ae0323a
pkgrel=1
pkgdesc='Low-latency vscode language server for large C++ code-bases, powered by libclang.'
arch=('any')
@@ -30,15 +30,15 @@ build() {
cd $_pkgname
# --variant=custom will not add extra CXXFLAGS
python waf configure --variant=custom --prefix="$pkgdir/usr" --llvm-config=/usr/bin/llvm-config
- python waf build
+ python waf build --variant=custom
}
check() {
cd $_pkgname
- yes | build/release/bin/cquery --test-unit --test-index --clang-sanity-check
+ yes | build/custom/bin/cquery --test-unit --test-index --clang-sanity-check
}
package() {
cd $_pkgname
- python waf install
+ python waf install --variant=custom
}