aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Miller2017-12-05 22:55:14 -0800
committerAaron Miller2017-12-05 22:55:14 -0800
commitdcecfc29c7e187c438c240e68e765d3b0d81ec03 (patch)
tree2dcc4b08999ccbb923dbda23c8569f8adde8af89
parente78f58ed0feb74c86ed8b9dc38cb761160501189 (diff)
downloadaur-dcecfc29c7e187c438c240e68e765d3b0d81ec03.tar.gz
move installation to /opt/crashplan, misc clean up
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD65
-rw-r--r--crashplan-pro.service10
3 files changed, 45 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3dabd86dc9cf..d0ff2d118420 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
pkgbase = crashplan-pro
pkgdesc = An business online/offsite backup solution
pkgver = 6.6.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.crashplan.com/business
install = crashplan-pro.install
arch = x86_64
license = custom
makedepends = cpio
depends = bash
- depends = java-runtime=8
+ depends = java-runtime-headless=8
depends = alsa-lib
depends = gconf
depends = gtk2
+ conflicts = crashplan
source = https://web-ebm-msp.crashplanpro.com/client/installers/CrashPlanSmb_6.6.0_1506661200660_4347_Linux.tgz
source = crashplan-pro
source = crashplan-pro.service
sha256sums = 3345e13e06b9f39006376c33c7fc692febab9f83a40384efa756c47a1d30fdff
sha256sums = b306d7da0dd41341512ce80ddcfb21bff8a9bb73ab5018696e69d08b89f7f1b6
- sha256sums = c631a971f300bfbfe52e3ec8faa4d7b735eaa069d73e11d6021567e29d053dc3
+ sha256sums = fd4c80dbd2ea3dcfc9966832a599f1bb310f705f813474d1900c1867ea55155c
pkgname = crashplan-pro
diff --git a/PKGBUILD b/PKGBUILD
index 0f2dd13564ea..91d65bb1db87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,79 +3,82 @@
# Contributor: Griffin Smith <wildgriffin [at] gmail [dot] com>
# Contributor: Bill Durr <billyburly [at] gmail [dot] com>
pkgname=crashplan-pro
+_pkgname=crashplan
pkgver=6.6.0
-pkgrel=1
+pkgrel=2
_pkgbuild=4347
_pkgtimestamp=1506661200660
pkgdesc="An business online/offsite backup solution"
url="http://www.crashplan.com/business"
arch=('x86_64')
license=('custom')
-depends=('bash' 'java-runtime=8' 'alsa-lib' 'gconf' 'gtk2')
+depends=('bash' 'java-runtime-headless=8' 'alsa-lib' 'gconf' 'gtk2')
makedepends=('cpio')
+conflicts=('crashplan')
install=crashplan-pro.install
source=(https://web-ebm-msp.crashplanpro.com/client/installers/CrashPlanSmb_${pkgver}_${_pkgtimestamp}_${_pkgbuild}_Linux.tgz
crashplan-pro
crashplan-pro.service)
sha256sums=('3345e13e06b9f39006376c33c7fc692febab9f83a40384efa756c47a1d30fdff'
'b306d7da0dd41341512ce80ddcfb21bff8a9bb73ab5018696e69d08b89f7f1b6'
- 'c631a971f300bfbfe52e3ec8faa4d7b735eaa069d73e11d6021567e29d053dc3')
+ 'fd4c80dbd2ea3dcfc9966832a599f1bb310f705f813474d1900c1867ea55155c')
build() {
cd $srcdir/crashplan-install
echo ""
- echo "You must review and agree to the EULA before using Crashplan PRO."
+ echo "You must review and agree to the EULA before using CrashPlan PRO."
echo "You can do so at:"
echo " - https://support.code42.com/Terms_and_conditions/Legal_terms_and_conditions/CrashPlan_for_Small_Business_EULA"
echo ""
echo "" > install.vars
echo "JAVACOMMON=`which java`" >> install.vars
- echo "#APP_BASENAME=CrashPlan" >> install.vars
- echo "TARGETDIR=/opt/$pkgname" >> install.vars
+ echo "APP_BASENAME=CrashPlan" >> install.vars
+ echo "TARGETDIR=/opt/$_pkgname" >> install.vars
echo "BINSDIR=" >> install.vars
- echo "MANIFESTDIR=/opt/$pkgname/manifest" >> install.vars
+ echo "MANIFESTDIR=/opt/$_pkgname/manifest" >> install.vars
echo "INITDIR=" >> install.vars
echo "RUNLVLDIR=" >> install.vars
NOW=`date +%Y%m%d`
echo "INSTALLDATE=$NOW" >> install.vars
- sed -imod "s|Exec=.*|Exec=/opt/$pkgname/bin/CrashPlanDesktop|" scripts/CrashPlan.desktop
- sed -imod "s|Icon=.*|Icon=/opt/$pkgname/skin/icon_app_64.74.png|" scripts/CrashPlan.desktop
+ sed -imod "s|Exec=.*|Exec=/opt/$_pkgname/bin/CrashPlanDesktop|" scripts/CrashPlan.desktop
+ sed -imod "s|Icon=.*|Icon=/opt/$_pkgname/bin/icon_app.png|" scripts/CrashPlan.desktop
sed -imod "s|Categories=.*|Categories=System;|" scripts/CrashPlan.desktop
}
package() {
- mkdir -p $pkgdir/opt/$pkgname
- cd $pkgdir/opt/$pkgname
+ mkdir -p $pkgdir/opt/$_pkgname
+ cd $pkgdir/opt/$_pkgname
cat $srcdir/crashplan-install/CrashPlanSmb_$pkgver.cpi | gzip -d -c - | cpio -i --no-preserve-owner
- chmod 777 $pkgdir/opt/$pkgname/log
- sed -i "s|<manifestPath>manifest</manifestPath>|<manifestPath>/opt/$pkgname/manifest</manifestPath>|g" $pkgdir/opt/$pkgname/conf/default.service.xml
+
+ chmod 777 log
+ chmod 775 electron/crashplan
+
+ mv app.asar electron/resources
+
+ sed -i "s|<backupConfig>|<backupConfig>\n\t\t\t<manifestPath>/opt/$_pkgname/manifest</manifestPath>|g" conf/default.service.xml
mkdir -p $pkgdir/usr/bin
- ln -s "/opt/$pkgname/bin/CrashPlanDesktop" $pkgdir/usr/bin/CrashPlanDesktop
+ ln -s "/opt/$_pkgname/bin/CrashPlanDesktop" $pkgdir/usr/bin/CrashPlanDesktop
# Fix for encoding troubles (CrashPlan ticket 178827)
# Make sure the daemon is running using the same localization as
# the (installing) user
echo "" >> $srcdir/crashplan-install/scripts/run.conf
- echo "export LC_ALL=$LANG" >> $srcdir/crashplan-install/scripts/run.conf
+ echo "LC_ALL=$LANG" >> $srcdir/crashplan-install/scripts/run.conf
# Use systemctl start/stop commands when it attempts to auto-update
- sed -i 's/^$ENGINE_SCRIPT stop.*/systemctl stop crashplan-pro >> $logfile 2>\&1/g' "$pkgdir/opt/${pkgname}/bin/restartLinux.sh"
- sed -i 's/^$ENGINE_SCRIPT start.*/systemctl start crashplan-pro >> $logfile 2>\&1/g' "$pkgdir/opt/${pkgname}/bin/restartLinux.sh"
+ sed -i 's/^$ENGINE_SCRIPT stop.*/systemctl stop crashplan-pro >> $logFile 2>\&1/g' "$pkgdir/opt/${_pkgname}/bin/restartLinux.sh"
+ sed -i 's/^$ENGINE_SCRIPT start.*/systemctl start crashplan-pro >> $logFile 2>\&1/g' "$pkgdir/opt/${_pkgname}/bin/restartLinux.sh"
- install -D -m 644 $srcdir/crashplan-install/install.vars $pkgdir/opt/$pkgname/install.vars
+ install -D -m 644 $srcdir/crashplan-install/install.vars install.vars
- #Removed as of Version 4.8.0 as the EULA is no longer included in the source
- #install -D -m 644 $srcdir/crashplan-install/EULA.txt $pkgdir/opt/$pkgname/EULA.txt
- #install -D -m 644 $srcdir/crashplan-install/EULA.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- install -D -m 755 $srcdir/crashplan-install/scripts/CrashPlanDesktop $pkgdir/opt/$pkgname/bin/CrashPlanDesktop
- install -D -m 644 $srcdir/crashplan-install/scripts/run.conf $pkgdir/opt/$pkgname/bin/run.conf
- install -D -m 755 $srcdir/crashplan-install/scripts/CrashPlanEngine $pkgdir/opt/$pkgname/bin/CrashPlanEngine
+ install -D -m 755 $srcdir/crashplan-install/scripts/CrashPlanDesktop bin/CrashPlanDesktop
+ install -D -m 644 $srcdir/crashplan-install/scripts/run.conf bin/run.conf
+ install -D -m 755 $srcdir/crashplan-install/scripts/CrashPlanEngine bin/CrashPlanEngine
install -D -m 755 $srcdir/crashplan-install/scripts/CrashPlan.desktop $pkgdir/usr/share/applications/crashplan.desktop
# rc.d daemon
@@ -85,8 +88,12 @@ package() {
}
post_install() {
- echo ""
- echo "Consider raising fs.inotify_max_user_watches as described on the wiki: "
- echo " - https://wiki.archlinux.org/index.php/CrashPlan#Real_time_protection"
- echo ""
+ INOTIFY_WATCHES=$(cat /proc/sys/fs/inotify/max_user_watches)
+ if [[ $INOTIFY_WATCHES -le 8192 ]]; then
+ echo ""
+ echo "Your Linux system is currently configured to watch $INOTIFY_WATCHES files in real time."
+ echo "CrashPlan recommends using a larger value; see the the arch wiki for details:"
+ echo " - https://wiki.archlinux.org/index.php/CrashPlan#Real_time_protection"
+ echo ""
+ fi
}
diff --git a/crashplan-pro.service b/crashplan-pro.service
index 8ab11b2a87da..88f7c2614b3b 100644
--- a/crashplan-pro.service
+++ b/crashplan-pro.service
@@ -5,11 +5,11 @@ After=network.target
[Service]
Type=forking
-PIDFile=/opt/crashplan-pro/CrashPlanEngine.pid
-EnvironmentFile=/opt/crashplan-pro/bin/run.conf
-WorkingDirectory=/opt/crashplan-pro
-ExecStart=/opt/crashplan-pro/bin/CrashPlanEngine start
-ExecStop=/opt/crashplan-pro/bin/CrashPlanEngine stop
+PIDFile=/opt/crashplan/CrashPlanEngine.pid
+EnvironmentFile=/opt/crashplan/bin/run.conf
+WorkingDirectory=/opt/crashplan
+ExecStart=/opt/crashplan/bin/CrashPlanEngine start
+ExecStop=/opt/crashplan/bin/CrashPlanEngine stop
Restart=always
[Install]