summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheodoros Theodoridis2023-09-11 12:07:35 +0200
committerTheodoros Theodoridis2023-09-11 12:08:36 +0200
commit96b2e5179bb79bd9e447cbcb965b12b1de241bd7 (patch)
tree9b08591f8a995b638fd54d26d3fde16a5ddc3746
parentba08292c0750d60b99f2f4513a57a97b0b2ce29e (diff)
downloadaur-creduce-git.tar.gz
Drop the LLVM 15 patch
LLVM 16 is now in Extra
-rw-r--r--.SRCINFO2
-rw-r--r--LLVM-15-Fix.patch78
-rw-r--r--PKGBUILD8
3 files changed, 2 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45c22e9c0c96..3f6094569dbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,8 +16,6 @@ pkgbase = creduce-git
depends = zlib
optdepends = perl-term-readkey
source = creduce-git::git+https://github.com/csmith-project/creduce.git
- source = LLVM-15-Fix.patch
md5sums = SKIP
- md5sums = e795c5de0fbec8236be01a783654352d
pkgname = creduce-git
diff --git a/LLVM-15-Fix.patch b/LLVM-15-Fix.patch
deleted file mode 100644
index d82dcb0427a1..000000000000
--- a/LLVM-15-Fix.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From 7dbd1e24703843d77c27a708d772f763eb6081a3 Mon Sep 17 00:00:00 2001
-From: Theodoros Theodoridis <theodoros.theodoridis@inf.ethz.ch>
-Date: Fri, 25 Aug 2023 12:17:12 +0200
-Subject: [PATCH] LLVM 15 Fix
-
----
- clang_delta/CommonRenameClassRewriteVisitor.h | 3 ++-
- clang_delta/ExpressionDetector.cpp | 4 ++--
- clang_delta/TemplateArgToInt.cpp | 3 +--
- clang_delta/Transformation.cpp | 2 +-
- 4 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/clang_delta/CommonRenameClassRewriteVisitor.h b/clang_delta/CommonRenameClassRewriteVisitor.h
-index 023937a..47d5883 100644
---- a/clang_delta/CommonRenameClassRewriteVisitor.h
-+++ b/clang_delta/CommonRenameClassRewriteVisitor.h
-@@ -420,7 +420,8 @@ bool CommonRenameClassRewriteVisitor<T>::TraverseTemplateArgumentLoc(
- return getDerived().TraverseStmt(ArgLoc.getSourceExpression());
-
- case TemplateArgument::Pack:
-- return getDerived().TraverseTemplateArguments(Arg);
-+ return getDerived().TraverseTemplateArguments(Arg.pack_begin(),
-+ Arg.pack_size());
- }
-
- return true;
-diff --git a/clang_delta/ExpressionDetector.cpp b/clang_delta/ExpressionDetector.cpp
-index cf70392..e708cd6 100644
---- a/clang_delta/ExpressionDetector.cpp
-+++ b/clang_delta/ExpressionDetector.cpp
-@@ -62,7 +62,7 @@ public:
- virtual void InclusionDirective(SourceLocation HashLoc,
- const Token &IncludeTok,
- StringRef FileName, bool IsAngled,
-- CharSourceRange FilenameRange, OptionalFileEntryRef File,
-+ CharSourceRange FilenameRange, Optional<FileEntryRef> File,
- StringRef SearchPath, StringRef RelativePath,
- const Module *Imported,
- SrcMgr::CharacteristicKind FileType) override;
-@@ -82,7 +82,7 @@ void IncludesPPCallbacks::InclusionDirective(SourceLocation HashLoc,
- StringRef FileName,
- bool /*IsAngled*/,
- CharSourceRange /*FilenameRange*/,
-- OptionalFileEntryRef /*File*/,
-+ Optional<FileEntryRef> /*File*/,
- StringRef /*SearchPath*/,
- StringRef /*RelativePath*/,
- const Module * /*Imported*/,
-diff --git a/clang_delta/TemplateArgToInt.cpp b/clang_delta/TemplateArgToInt.cpp
-index e8b44a2..2d3c3ec 100644
---- a/clang_delta/TemplateArgToInt.cpp
-+++ b/clang_delta/TemplateArgToInt.cpp
-@@ -357,8 +357,7 @@ void TemplateArgToInt::handleOneType(const Type *Ty)
- if (!SubstType)
- return;
-
-- const TemplateTypeParmDecl *ParmDecl = SubstType->getReplacedParameter();
-- TransAssert(ParmDecl && "Invalid ParmDecl!");
-+ const TemplateTypeParmDecl *ParmDecl = SubstType->getReplacedParameter()->getDecl(); TransAssert(ParmDecl && "Invalid ParmDecl!");
- const TemplateDecl *TmplD = ParamToTemplateDecl[ParmDecl];
- if (TmplD == NULL) {
- const DeclContext *Ctx = ParmDecl->getDeclContext();
-diff --git a/clang_delta/Transformation.cpp b/clang_delta/Transformation.cpp
-index b350eec..305d5e3 100644
---- a/clang_delta/Transformation.cpp
-+++ b/clang_delta/Transformation.cpp
-@@ -807,7 +807,7 @@ const CXXRecordDecl *Transformation::getBaseDeclFromType(const Type *Ty)
-
- case Type::TypeOf: {
- return getBaseDeclFromType(
-- dyn_cast<TypeOfType>(Ty)->getUnmodifiedType().getTypePtr());
-+ dyn_cast<TypeOfType>(Ty)->getUnderlyingType().getTypePtr());
- }
-
- default:
---
-2.41.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 01365d4611d8..e2ff32be1d01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,13 +11,9 @@ depends=('clang' 'llvm' 'perl-exporter-lite' 'perl-file-which' 'perl-getopt-tabu
'perl-regexp-common' 'zlib')
optdepends=('perl-term-readkey')
makedepends=('git')
-source=("$pkgname::git+https://github.com/csmith-project/creduce.git" "LLVM-15-Fix.patch")
-md5sums=('SKIP'
- 'e795c5de0fbec8236be01a783654352d')
+source=("$pkgname::git+https://github.com/csmith-project/creduce.git")
+md5sums=('SKIP')
-prepare() {
- patch --directory="$pkgname" --forward --strip=1 --input="${srcdir}/LLVM-15-Fix.patch"
-}
pkgver() {
cd "$srcdir/$pkgname"