summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2017-03-12 23:48:29 -0700
committerMike Swanson2017-03-12 23:48:29 -0700
commit1e1b59fe801be7b5db2eddd3dfa27914c242e90b (patch)
tree1d49af418e6d7c10b63ad3e956835a579fbcc6e3
parent8c33b472e2c1c1248396076eed7ba544717a526b (diff)
downloadaur-1e1b59fe801be7b5db2eddd3dfa27914c242e90b.tar.gz
Update to 4.0
Also including a patch so bash-completion works.
-rw-r--r--.SRCINFO18
-rw-r--r--0001-bash-completion-Use-autoconf-substitutions-for-the-c.patch167
-rw-r--r--0001-man-docgen-simplecpp-Force-UTF-8-reading-and-writing.patch84
-rw-r--r--PKGBUILD17
4 files changed, 184 insertions, 102 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15c6e895a808..3f370320d79b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Mar 2 22:32:58 UTC 2017
+# Mon Mar 13 06:48:00 UTC 2017
pkgbase = crispy-doom
pkgdesc = Vanilla-compatible enhanced Doom engine
- pkgver = 3.5
- pkgrel = 4
+ pkgver = 4.0
+ pkgrel = 1
url = http://fabiangreffrath.github.io/crispy-doom
install = crispy-doom.install
arch = i686
@@ -15,12 +15,12 @@ pkgbase = crispy-doom
depends = sdl_mixer
depends = sdl_net
optdepends = freedm: Free deathmatch game
- optdepends = freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)
- optdepends = freedoom2: Free Doom II/Final Doom-compatible game (not vanilla compatible, but useful for mods)
- source = https://github.com/fabiangreffrath/crispy-doom/archive/crispy-doom-3.5.tar.gz
- source = 0001-man-docgen-simplecpp-Force-UTF-8-reading-and-writing.patch
- sha512sums = cc664ec85d8c376075223c8a92e7e70274972fd97a8007abc5936cd020f1555794398676e58231cb19786a2f9bb6b1f01f5152efc4563d3d3f8f62fcb31f3961
- sha512sums = e2702dc1fb684f31abfc443f10bd99409f01ac9540fcecb2dbdd9ff738e50f283314f998bae8569aad7f720a60a12ada4fad443c60ae3320c60ca5638e68361c
+ optdepends = freedoom1: Free Ultimate Doom-compatible game
+ optdepends = freedoom2: Free Doom II/Final Doom-compatible game
+ source = https://github.com/fabiangreffrath/crispy-doom/archive/crispy-doom-4.0.tar.gz
+ source = 0001-bash-completion-Use-autoconf-substitutions-for-the-c.patch
+ sha512sums = c5726e6624c367cb0c9f308bc317e19c91b2ce954e03724977116af8782062405de123bbbe5d86858b3bdb44bc3c14f02d2e1cf867b5bcd89233218627c57fb1
+ sha512sums = 8e3a10bc58bed9ac0623d9962ee3449a8c7dc07cc368445ee2d0a3aea14d1d46074d9655a78a61459683325c8cffee0b1b3c5201010271318c22e0543892357f
pkgname = crispy-doom
diff --git a/0001-bash-completion-Use-autoconf-substitutions-for-the-c.patch b/0001-bash-completion-Use-autoconf-substitutions-for-the-c.patch
new file mode 100644
index 000000000000..b3dc05b020f1
--- /dev/null
+++ b/0001-bash-completion-Use-autoconf-substitutions-for-the-c.patch
@@ -0,0 +1,167 @@
+From e61ea3e2251a5a84c321aab4c861497089edc791 Mon Sep 17 00:00:00 2001
+From: Mike Swanson <mikeonthecomputer@gmail.com>
+Date: Sun, 12 Mar 2017 23:27:11 -0700
+Subject: [PATCH] bash-completion: Use autoconf substitutions for the chocolate
+ name
+
+Introduce a new PROGRAM_SPREFIX variable in configure.ac, which is
+basically identical to PROGRAM_PREFIX but without the trailing hyphen.
+PROGRAM_PREFIX was also redefined so that it bases its name from
+PACKAGE_SHORTNAME, reducing the number of hardcoded chocolates in the
+source.
+---
+ configure.ac | 12 ++++++++----
+ man/bash-completion/.gitignore | 1 +
+ man/bash-completion/{doom.template => doom.template.in} | 6 +++---
+ .../{heretic.template => heretic.template.in} | 6 +++---
+ man/bash-completion/{hexen.template => hexen.template.in} | 6 +++---
+ man/bash-completion/{strife.template => strife.template.in} | 6 +++---
+ 6 files changed, 21 insertions(+), 16 deletions(-)
+ rename man/bash-completion/{doom.template => doom.template.in} (87%)
+ rename man/bash-completion/{heretic.template => heretic.template.in} (85%)
+ rename man/bash-completion/{hexen.template => hexen.template.in} (84%)
+ rename man/bash-completion/{strife.template => strife.template.in} (85%)
+
+diff --git a/configure.ac b/configure.ac
+index 7d1ffa9d..e622b2c1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -146,15 +146,15 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+ WINDOWS_RC_VERSION=`echo $PACKAGE_VERSION | sed 's/-.*//; s/\./, /g; s/$/, 0, 0/'`
+
+-# This controls the prefix added to the start of program names. For example,
+-# if this is changed to "lemon-", the programs generated will be named
+-# lemon-doom, lemon-heretic, etc.
++PROGRAM_PREFIX=${PACKAGE_SHORTNAME,}-
+
+-PROGRAM_PREFIX=crispy-
++dnl Without a hyphen. This is used for the bash-completion scripts.
++PROGRAM_SPREFIX=${PACKAGE_SHORTNAME,}
+
+ AC_SUBST(PROGRAM_PREFIX)
+ AC_DEFINE_UNQUOTED(PROGRAM_PREFIX, "$PROGRAM_PREFIX",
+ Change this when you create your awesome forked version)
++AC_SUBST(PROGRAM_SPREFIX)
+
+ AM_CONFIG_HEADER(config.h:config.hin)
+
+@@ -184,6 +184,10 @@ AC_OUTPUT([
+ Makefile
+ man/Makefile
+ man/bash-completion/Makefile
++man/bash-completion/doom.template
++man/bash-completion/heretic.template
++man/bash-completion/hexen.template
++man/bash-completion/strife.template
+ opl/Makefile
+ opl/examples/Makefile
+ pcsound/Makefile
+diff --git a/man/bash-completion/.gitignore b/man/bash-completion/.gitignore
+index 74c4d54a..488df26a 100644
+--- a/man/bash-completion/.gitignore
++++ b/man/bash-completion/.gitignore
+@@ -2,3 +2,4 @@
+ *heretic
+ *hexen
+ *strife
++*.template
+diff --git a/man/bash-completion/doom.template b/man/bash-completion/doom.template.in
+similarity index 87%
+rename from man/bash-completion/doom.template
+rename to man/bash-completion/doom.template.in
+index 535ad2a0..e4f3dcb0 100644
+--- a/man/bash-completion/doom.template
++++ b/man/bash-completion/doom.template.in
+@@ -1,6 +1,6 @@
+-# bash completion for Chocolate Doom -*- shell-script -*-
++# bash completion for @PACKAGE_SHORTNAME@ Doom -*- shell-script -*-
+
+-_chocolate_doom()
++_@PROGRAM_SPREFIX@_doom()
+ {
+ local cur prev words cword
+ _init_completion || return
+@@ -46,6 +46,6 @@ _chocolate_doom()
+ fi
+ } &&
+
+-complete -F _chocolate_doom chocolate-doom
++complete -F _@PROGRAM_SPREFIX@_doom @PROGRAM_PREFIX@doom
+
+ # ex: ts=4 sw=4 et filetype=sh
+diff --git a/man/bash-completion/heretic.template b/man/bash-completion/heretic.template.in
+similarity index 85%
+rename from man/bash-completion/heretic.template
+rename to man/bash-completion/heretic.template.in
+index 5d658d46..a46b19cc 100644
+--- a/man/bash-completion/heretic.template
++++ b/man/bash-completion/heretic.template.in
+@@ -1,6 +1,6 @@
+-# bash completion for Chocolate Heretic -*- shell-script -*-
++# bash completion for @PACKAGE_SHORTNAME@ Heretic -*- shell-script -*-
+
+-_chocolate_heretic()
++_@PROGRAM_SPREFIX@_heretic()
+ {
+ local cur prev words cword
+ _init_completion || return
+@@ -43,6 +43,6 @@ _chocolate_heretic()
+ fi
+ } &&
+
+-complete -F _chocolate_heretic chocolate-heretic
++complete -F _@PROGRAM_SPREFIX@_heretic @PROGRAM_PREFIX@heretic
+
+ # ex: ts=4 sw=4 et filetype=sh
+diff --git a/man/bash-completion/hexen.template b/man/bash-completion/hexen.template.in
+similarity index 84%
+rename from man/bash-completion/hexen.template
+rename to man/bash-completion/hexen.template.in
+index b7e75f7f..f80853bc 100644
+--- a/man/bash-completion/hexen.template
++++ b/man/bash-completion/hexen.template.in
+@@ -1,6 +1,6 @@
+-# bash completion for Chocolate Hexen -*- shell-script -*-
++# bash completion for @PACKAGE_SHORTNAME@ Hexen -*- shell-script -*-
+
+-_chocolate_hexen()
++_@PROGRAM_SPREFIX@_hexen()
+ {
+ local cur prev words cword
+ _init_completion || return
+@@ -37,6 +37,6 @@ _chocolate_hexen()
+ fi
+ } &&
+
+-complete -F _chocolate_hexen chocolate-hexen
++complete -F _@PROGRAM_SPREFIX@_hexen @PROGRAM_PREFIX@hexen
+
+ # ex: ts=4 sw=4 et filetype=sh
+diff --git a/man/bash-completion/strife.template b/man/bash-completion/strife.template.in
+similarity index 85%
+rename from man/bash-completion/strife.template
+rename to man/bash-completion/strife.template.in
+index 13c8a8ce..a044ef0b 100644
+--- a/man/bash-completion/strife.template
++++ b/man/bash-completion/strife.template.in
+@@ -1,6 +1,6 @@
+-# bash completion for Chocolate Strife -*- shell-script -*-
++# bash completion for @PACKAGE_SHORTNAME@ Strife -*- shell-script -*-
+
+-_chocolate_strife()
++_@PROGRAM_SPREFIX@_strife()
+ {
+ local cur prev words cword
+ _init_completion || return
+@@ -43,6 +43,6 @@ _chocolate_strife()
+ fi
+ } &&
+
+-complete -F _chocolate_strife chocolate-strife
++complete -F _@PROGRAM_SPREFIX@_strife @PROGRAM_PREFIX@strife
+
+ # ex: ts=4 sw=4 et filetype=sh
+--
+2.12.0
+
diff --git a/0001-man-docgen-simplecpp-Force-UTF-8-reading-and-writing.patch b/0001-man-docgen-simplecpp-Force-UTF-8-reading-and-writing.patch
deleted file mode 100644
index 184ca02dd74d..000000000000
--- a/0001-man-docgen-simplecpp-Force-UTF-8-reading-and-writing.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-From e44e012d063559e8a502d91f5b0916babd41b54b Mon Sep 17 00:00:00 2001
-From: Mike Swanson <mikeonthecomputer@gmail.com>
-Date: Thu, 19 Jan 2017 12:48:35 -0800
-Subject: [PATCH] man/{docgen,simplecpp}: Force UTF-8 reading and writing
- regardless of locale
-
-When encountering non-ASCII UTF-8 characters in source files (as
-exists in Crispy Doom), the Python scripts would fail to work with
-a UnicodeDecodeError if the locale was not a UTF-8 one (eg, the C
-locale as encountered in chroot build environments).
-
-Let's just use UTF-8 on both open() and replace print() statements with
-sys.stdout.buffer.write(). This guarantees that all input and output is
-UTF-8 regardless.
----
- man/docgen | 10 +++++-----
- man/simplecpp | 2 +-
- 2 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/man/docgen b/man/docgen
-index 510c2ba2..d40e5c7b 100755
---- a/man/docgen
-+++ b/man/docgen
-@@ -300,7 +300,7 @@ class Parameter:
- # Read list of wiki pages
-
- def read_wikipages():
-- f = open("wikipages")
-+ f = open("wikipages", encoding='UTF-8')
-
- try:
- for line in f:
-@@ -356,7 +356,7 @@ def process_file(file):
-
- current_config_file = None
-
-- f = open(file)
-+ f = open(file, encoding='UTF-8')
-
- try:
- param = None
-@@ -422,7 +422,7 @@ def process_files(path):
- process_file(path)
-
- def print_template(template_file, content):
-- f = open(template_file)
-+ f = open(template_file, encoding='UTF-8')
-
- try:
- for line in f:
-@@ -432,7 +432,7 @@ def print_template(template_file, content):
- print_template(filename, content)
- else:
- line = line.replace("@content", content)
-- print(line.rstrip())
-+ sys.stdout.buffer.write(line.rstrip().encode('UTF-8') + b'\n')
-
- finally:
- f.close()
-@@ -452,7 +452,7 @@ def wiki_output(targets, template):
- read_wikipages()
-
- for t in targets:
-- print(t.wiki_output())
-+ sys.stdout.buffer.write(t.wiki_output().encode('UTF-8') + b'\n')
-
- def plaintext_output(targets, template_file):
-
-diff --git a/man/simplecpp b/man/simplecpp
-index 4cb58a4c..d3590d6d 100755
---- a/man/simplecpp
-+++ b/man/simplecpp
-@@ -76,7 +76,7 @@ def parse_stream(stream):
- raise Exception("Mismatched #if in '%s'" % stream.name)
-
- def parse_file(filename):
-- f = open(filename)
-+ f = open(filename, encoding='UTF-8')
-
- try:
- parse_stream(f)
---
-2.11.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 1a30f76882c3..2c796a131268 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
pkgname=crispy-doom
pkgdesc="Vanilla-compatible enhanced Doom engine"
-pkgver=3.5
-pkgrel=4
+pkgver=4.0
+pkgrel=1
arch=('i686' 'x86_64')
url="http://fabiangreffrath.github.io/crispy-doom"
license=('GPL2')
depends=('libpng' 'libsamplerate' 'sdl_mixer' 'sdl_net')
makedepends=('python')
optdepends=('freedm: Free deathmatch game'
- 'freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)'
- 'freedoom2: Free Doom II/Final Doom-compatible game (not vanilla compatible, but useful for mods)')
+ 'freedoom1: Free Ultimate Doom-compatible game'
+ 'freedoom2: Free Doom II/Final Doom-compatible game')
install=crispy-doom.install
source=(https://github.com/fabiangreffrath/$pkgname/archive/$pkgname-$pkgver.tar.gz
- 0001-man-docgen-simplecpp-Force-UTF-8-reading-and-writing.patch)
-sha512sums=('cc664ec85d8c376075223c8a92e7e70274972fd97a8007abc5936cd020f1555794398676e58231cb19786a2f9bb6b1f01f5152efc4563d3d3f8f62fcb31f3961'
- 'e2702dc1fb684f31abfc443f10bd99409f01ac9540fcecb2dbdd9ff738e50f283314f998bae8569aad7f720a60a12ada4fad443c60ae3320c60ca5638e68361c')
+ 0001-bash-completion-Use-autoconf-substitutions-for-the-c.patch)
+sha512sums=('c5726e6624c367cb0c9f308bc317e19c91b2ce954e03724977116af8782062405de123bbbe5d86858b3bdb44bc3c14f02d2e1cf867b5bcd89233218627c57fb1'
+ '8e3a10bc58bed9ac0623d9962ee3449a8c7dc07cc368445ee2d0a3aea14d1d46074d9655a78a61459683325c8cffee0b1b3c5201010271318c22e0543892357f')
prepare() {
# GitHub's generated archive prefix kind of sucks.
@@ -46,6 +46,5 @@ package() {
cd "$pkgdir"/usr
rm -rf share/man/man5/default.cfg.5 \
- share/man/man6/chocolate-{server,setup}.6 \
- share/bash-completion
+ share/man/man6/chocolate-{server,setup}.6
}