summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2014-10-27 06:17:00 -0700
committerMike Swanson2014-10-27 06:17:00 -0700
commit60500c3141e15e30b826ab06c5b78fadab970278 (patch)
treec786621651cb926b1a7851a438c45d15e8ab7a34
parent128515fee5eecb9491846196bed864b7d6c03fe1 (diff)
downloadaur-60500c3141e15e30b826ab06c5b78fadab970278.tar.gz
Update crispy-doom to 2.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
-rw-r--r--crispy-doom.install2
3 files changed, 30 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e4a63b79482..bbc8dddfffc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = crispy-doom
pkgdesc = Chocolate Doom with vanilla-compatible enhancements
- pkgver = 1.5
+ pkgver = 2.0
pkgrel = 1
url = http://fabiangreffrath.github.io/crispy-doom
- install = crispy-doom.install
arch = i686
arch = x86_64
license = GPL2
@@ -12,8 +11,8 @@ pkgbase = crispy-doom
depends = libsamplerate
depends = sdl_mixer
depends = sdl_net
- source = https://github.com/fabiangreffrath/crispy-doom/archive/crispy-doom-1.5.tar.gz
- sha256sums = 43f3f58266b1744a361df8678cf97a83839952a8dc0f5ecbfd68345abc90313a
+ source = https://github.com/fabiangreffrath/crispy-doom/archive/crispy-doom-2.0.tar.gz
+ sha256sums = 9de6519981cd83e62e12948c3a4e40d5ac663f14a9b8f19cabff5e2ce593d85f
pkgname = crispy-doom
pkgdesc = Doom port accurately reproducing the original DOS EXEs.
@@ -21,6 +20,9 @@ pkgname = crispy-doom
depends = sdl_mixer
depends = sdl_net
depends = crispy-common
+ optdepends = freedm: Free deathmatch game
+ optdepends = freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)
+ optdepends = freedoom2: Free Doom II/Final Doom-compatible game (not vanilla compatible, but useful for mods)
pkgname = crispy-heretic
pkgdesc = Heretic port accurately reproducing the original DOS EXEs.
@@ -28,6 +30,7 @@ pkgname = crispy-heretic
depends = sdl_mixer
depends = sdl_net
depends = crispy-common
+ optdepends = blasphemer: Free Heretic-compatible game
pkgname = crispy-hexen
pkgdesc = Hexen port accurately reproducing the original DOS EXEs.
@@ -45,5 +48,6 @@ pkgname = crispy-strife
pkgname = crispy-common
pkgdesc = Files shared in common with Crispy Doom-based games.
+ install = crispy-doom.install
depends = sdl_net
diff --git a/PKGBUILD b/PKGBUILD
index 49f27bce9511..76a63b66d2a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=(crispy-{doom,heretic,hexen,strife,common})
-_pkgname=${pkgname[0]}
+pkgbase=${pkgname[0]}
pkgdesc="Chocolate Doom with vanilla-compatible enhancements"
-pkgver=1.5
+pkgver=2.0
pkgrel=1
arch=('i686' 'x86_64')
url="http://fabiangreffrath.github.io/crispy-doom"
license=('GPL2')
depends=('libsamplerate' 'sdl_mixer' 'sdl_net')
makedepends=('autoconf' 'python')
-install=crispy-doom.install
-source=(https://github.com/fabiangreffrath/${_pkgname}/archive/${_pkgname}-${pkgver}.tar.gz)
-sha256sums=('43f3f58266b1744a361df8678cf97a83839952a8dc0f5ecbfd68345abc90313a')
+source=(https://github.com/fabiangreffrath/${pkgbase}/archive/${pkgbase}-${pkgver}.tar.gz)
+sha256sums=('9de6519981cd83e62e12948c3a4e40d5ac663f14a9b8f19cabff5e2ce593d85f')
-build() {
+prepare() {
# GitHub's generated archive prefix kind of sucks.
- mv "${_pkgname}-${_pkgname}-${pkgver}" "${_pkgname}-${pkgver}"
- cd "${_pkgname}-${pkgver}"
+ mv "${pkgbase}-${pkgbase}-${pkgver}" "${pkgbase}-${pkgver}"
+ cd "${pkgbase}-${pkgver}"
# Change binary dir from /usr/games to /usr/bin
sed 's|/games|/bin|g' -i src{,/setup}/Makefile.am
+}
+
+build() {
+ cd "${pkgbase}-${pkgver}"
./autogen.sh --prefix=/usr
make
@@ -29,8 +32,9 @@ build() {
package_crispy-common() {
pkgdesc="Files shared in common with Crispy Doom-based games."
depends=('sdl_net')
+ install=crispy-doom.install
- cd "${_pkgname}-${pkgver}"
+ cd "${pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -dm 755 "${pkgdir}"/usr/share/games/doom
@@ -51,8 +55,11 @@ package_crispy-common() {
package_crispy-doom() {
pkgdesc="Doom port accurately reproducing the original DOS EXEs."
depends=(${depends[@]} 'crispy-common')
+ optdepends=('freedm: Free deathmatch game'
+ 'freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)'
+ 'freedoom2: Free Doom II/Final Doom-compatible game (not vanilla compatible, but useful for mods)')
- cd "${_pkgname}-${pkgver}"
+ cd "${pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
cd "${pkgdir}"/usr/bin
@@ -70,8 +77,9 @@ package_crispy-doom() {
package_crispy-heretic() {
pkgdesc="Heretic port accurately reproducing the original DOS EXEs."
depends=(${depends[@]} 'crispy-common')
+ optdepends=('blasphemer: Free Heretic-compatible game')
- cd "${_pkgname}-${pkgver}"
+ cd "${pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
cd "${pkgdir}"/usr/bin
@@ -91,7 +99,7 @@ package_crispy-hexen() {
pkgdesc="Hexen port accurately reproducing the original DOS EXEs."
depends=(${depends[@]} 'crispy-common')
- cd "${_pkgname}-${pkgver}"
+ cd "${pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
cd "${pkgdir}"/usr/bin
@@ -111,7 +119,7 @@ package_crispy-strife() {
pkgdesc="Strife port accurately reproducing the original DOS EXEs."
depends=(${depends[@]} 'crispy-common')
- cd "${_pkgname}-${pkgver}"
+ cd "${pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
cd "${pkgdir}"/usr/bin
diff --git a/crispy-doom.install b/crispy-doom.install
index ebe08e9d8ca3..36b0264e5388 100644
--- a/crispy-doom.install
+++ b/crispy-doom.install
@@ -1,6 +1,6 @@
post_install() {
cat <<EOF
->>> Copy any IWAD files to the global default /usr/share/games/doom
+>>> Install IWADs into /usr/share/games/doom or /usr/local/share/games/doom
>>>
>>> In order to allow co-existence with Chocolate Doom, the following
>>> manual pages have been removed: