aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiacoLenzo21092021-02-25 15:52:05 +0100
committerGiacoLenzo21092021-02-25 15:52:05 +0100
commit79ff9c8df21cda75b76f351849282acacef0be26 (patch)
tree19cac6316bb8d2dbb6ec00867388f23d5a87d53d
downloadaur-croco-boot-repair-git.tar.gz
Upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
-rw-r--r--README.md3
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a06356c52809
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = croco-boot-repair-git
+ pkgdesc = A Grub repair utility for Croco OS
+ pkgver = r7.a128fab
+ pkgrel = 1
+ url = https://gitlab.com/croco-os/applications/croco-boot-repair
+ arch = any
+ groups = croco-git
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ depends = xdg-utils
+ depends = grub
+ depends = polkit
+ provides = croco-boot-repair
+ conflicts = croco-boot-repair
+ source = git+https://gitlab.com/croco-os/applications/croco-boot-repair.git
+ md5sums = SKIP
+
+pkgname = croco-boot-repair-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdd4cff6ad32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+_pkgname=croco-boot-repair
+pkgname=${_pkgname}-git
+pkgver=r7.a128fab
+pkgrel=1
+pkgdesc="A Grub repair utility for Croco OS"
+arch=('any')
+url="https://gitlab.com/croco-os/applications/croco-boot-repair"
+license=('GPL3')
+depends=('qt5-base' 'xdg-utils' 'grub' 'polkit')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('croco-git')
+source=("git+https://gitlab.com/croco-os/applications/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake-qt5 ${_pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..969088b6d92c
--- /dev/null
+++ b/README.md
@@ -0,0 +1,3 @@
+# croco-boot-repair-git
+
+PKGBUILD for croco-boot-repair-git