summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFirstAirBender2024-04-08 11:42:26 -0600
committerFirstAirBender2024-04-08 11:42:26 -0600
commit092d569abf426b48a07399d6c37d0e67f3dd69c3 (patch)
tree37237612317dce96930526b911557c89ef07913c
parentdf33f97668da020bbde1cd2ad256d4e1152cd0f4 (diff)
downloadaur-crowdsec-nginx-bouncer.tar.gz
update to v1.0.8
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD56
2 files changed, 31 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa81b453b712..8841aca9c0f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = crowdsec-nginx-bouncer
pkgdesc = CrowdSec bouncer for Nginx
- pkgver = 1.0.5
- pkgrel = 2
+ pkgver = 1.0.8
+ pkgrel = 1
url = https://doc.crowdsec.net/docs/bouncers/nginx
install = cs-nginx-bouncer.install
arch = any
@@ -19,11 +19,9 @@ pkgbase = crowdsec-nginx-bouncer
backup = etc/nginx/lua/templates/crowdsec/captcha.html
backup = etc/nginx/conf.d/crowdsec_nginx.conf
backup = etc/crowdsec/bouncers/crowdsec-nginx-bouncer.conf
- source = crowdsec-nginx-bouncer-1.0.5.tar.gz::https://github.com/crowdsecurity/cs-nginx-bouncer/releases/download/v1.0.5/crowdsec-nginx-bouncer.tgz
+ source = crowdsec-nginx-bouncer-1.0.8.tar.gz::https://github.com/crowdsecurity/cs-nginx-bouncer/releases/download/v1.0.8/crowdsec-nginx-bouncer.tgz
source = cs-nginx-bouncer-nginx-module.conf
- source = cs-nginx-bouncer.install
- sha256sums = 2bb65903558598fc72c20de512267cbf0759d79f0e038c5a3b8ecf2626470d3f
+ sha256sums = a6c600640d15cca3d8909ff1996f4f6df61390b80e13cdaa1e6015a2a3ff4444
sha256sums = 48b8356f3652ae766496a28714a661c30c9616c12b9cb39ff75dfa78f4677f99
- sha256sums = 6f11751ebbbedcf88ba9a08697b2d33f457caa4c57bf46722a67d2018b568607
pkgname = crowdsec-nginx-bouncer
diff --git a/PKGBUILD b/PKGBUILD
index 0419c8cd7d38..fc0e8fbeffb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: FirstAirBender <noblechuk5 at web dot de>
pkgname=crowdsec-nginx-bouncer
-pkgver=1.0.5
-pkgrel=2
+pkgver=1.0.8
+pkgrel=1
pkgdesc="CrowdSec bouncer for Nginx"
arch=('any')
url="https://doc.crowdsec.net/docs/bouncers/nginx"
@@ -11,45 +11,43 @@ replaces=('cs-nginx-bouncer')
provides=('cs-nginx-bouncer')
conflicts=('cs-nginx-bouncer')
depends=(
- 'crowdsec'
- 'nginx-mainline-mod-lua'
- 'luajit-openresty'
- 'lua51'
- 'luarocks'
+ 'crowdsec'
+ 'nginx-mainline-mod-lua'
+ 'luajit-openresty'
+ 'lua51'
+ 'luarocks'
)
makedepends=(
- 'gettext'
+ 'gettext'
)
backup=(
- etc/nginx/lua/templates/crowdsec/{ban,captcha}.html
- etc/nginx/conf.d/crowdsec_nginx.conf
- etc/crowdsec/bouncers/crowdsec-nginx-bouncer.conf
+ etc/nginx/lua/templates/crowdsec/{ban,captcha}.html
+ etc/nginx/conf.d/crowdsec_nginx.conf
+ etc/crowdsec/bouncers/crowdsec-nginx-bouncer.conf
)
install=cs-nginx-bouncer.install
source=(
- "$pkgname-$pkgver.tar.gz::${_giturl}/releases/download/v${pkgver}/${pkgname}.tgz"
- "cs-nginx-bouncer-nginx-module.conf"
- "cs-nginx-bouncer.install"
+ "$pkgname-$pkgver.tar.gz::${_giturl}/releases/download/v${pkgver}/${pkgname}.tgz"
+ "cs-nginx-bouncer-nginx-module.conf"
)
-sha256sums=('2bb65903558598fc72c20de512267cbf0759d79f0e038c5a3b8ecf2626470d3f'
- '48b8356f3652ae766496a28714a661c30c9616c12b9cb39ff75dfa78f4677f99'
- '6f11751ebbbedcf88ba9a08697b2d33f457caa4c57bf46722a67d2018b568607')
+sha256sums=('a6c600640d15cca3d8909ff1996f4f6df61390b80e13cdaa1e6015a2a3ff4444'
+ '48b8356f3652ae766496a28714a661c30c9616c12b9cb39ff75dfa78f4677f99')
prepare() {
- cd "$pkgname-v$pkgver"
- sed -i s:var/lib/crowdsec/lua/templates:etc/nginx/lua/templates/crowdsec: lua-mod/config_example.conf
- # $prefix see https://openresty-reference.readthedocs.io/en/latest/Directives/#lua_package_path
- sed -i s:/usr/local/lua/crowdsec/:'$prefix/lua/plugins/crowdsec/': nginx/crowdsec_nginx.conf
+ cd "$pkgname-v$pkgver"
+ sed -i s:var/lib/crowdsec/lua/templates:etc/nginx/lua/templates/crowdsec: lua-mod/config_example.conf
+ # $prefix see https://openresty-reference.readthedocs.io/en/latest/Directives/#lua_package_path
+ sed -i s:/usr/local/lua/crowdsec/:'$prefix/lua/plugins/crowdsec/': nginx/crowdsec_nginx.conf
}
package() {
- cd "$pkgname-v$pkgver"
- install -dm755 $pkgdir/etc/nginx/lua/plugins/crowdsec/
- install -dm755 $pkgdir/etc/nginx/lua/templates/crowdsec/
+ cd "$pkgname-v$pkgver"
+ install -dm755 $pkgdir/etc/nginx/lua/plugins/crowdsec/
+ install -dm755 $pkgdir/etc/nginx/lua/templates/crowdsec/
- install -Dm644 {nginx,$pkgdir/etc/nginx/conf.d}/crowdsec_nginx.conf
- install -Dm644 $srcdir/cs-nginx-bouncer-nginx-module.conf -t $pkgdir/etc/nginx/modules
- cp -R lua-mod/lib/* $pkgdir/etc/nginx/lua/plugins/crowdsec/
- cp -R lua-mod/templates/* $pkgdir/etc/nginx/lua/templates/crowdsec/
- install -Dm600 lua-mod/config_example.conf $pkgdir/etc/crowdsec/bouncers/crowdsec-nginx-bouncer.conf
+ install -Dm644 {nginx,$pkgdir/etc/nginx/conf.d}/crowdsec_nginx.conf
+ install -Dm644 $srcdir/cs-nginx-bouncer-nginx-module.conf -t $pkgdir/etc/nginx/modules
+ cp -R lua-mod/lib/* $pkgdir/etc/nginx/lua/plugins/crowdsec/
+ cp -R lua-mod/templates/* $pkgdir/etc/nginx/lua/templates/crowdsec/
+ install -Dm600 lua-mod/config_example.conf $pkgdir/etc/crowdsec/bouncers/crowdsec-nginx-bouncer.conf
}