summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-09-07 16:49:03 +0200
committerbegin-theadventure2023-09-07 16:49:03 +0200
commitbae3481cb05bc0144d8cfa3623e5f8a77a55d11e (patch)
treecbd118904e73235e5a1ba604aecbf25db8cc217f
downloadaur-cryptocam-companion-bin.tar.gz
0.2.3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06ac3bf2102d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cryptocam-companion-bin
+ pkgdesc = A tool to decrypt files created by Cryptocam (binary release)
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://gitlab.com/cryptocam/cryptocam-companion
+ arch = x86_64
+ license = GPL3
+ depends = ffmpeg
+ depends = qt5-quickcontrols
+ provides = cryptocam-companion
+ conflicts = cryptocam-companion
+ source = 0.2.3-cryptocam-companion::https://gitlab.com/cryptocam/cryptocam-companion/-/jobs/1246114286/artifacts/raw/cryptocam-qt
+ source = https://gitlab.com/cryptocam/cryptocam-companion/-/raw/master/cryptocam-companion.svg
+ sha256sums = 70884febf79cd0ca8abe906217b4f8726539975fa6ab260653222ec6aa4e6f45
+ sha256sums = SKIP
+
+pkgname = cryptocam-companion-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea8b09deb548
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+
+_pkgname=cryptocam-companion
+pkgname=$_pkgname-bin
+pkgdesc="A tool to decrypt files created by Cryptocam (binary release)"
+pkgver=0.2.3
+pkgrel=1
+arch=('x86_64')
+url="https://gitlab.com/cryptocam/cryptocam-companion"
+license=('GPL3')
+depends=('ffmpeg' 'qt5-quickcontrols')
+conflicts=($_pkgname)
+provides=($_pkgname)
+source=("$pkgver-$_pkgname::$url/-/jobs/1246114286/artifacts/raw/cryptocam-qt"
+ "$url/-/raw/master/cryptocam-companion.svg")
+sha256sums=('70884febf79cd0ca8abe906217b4f8726539975fa6ab260653222ec6aa4e6f45'
+ 'SKIP')
+
+prepare() {
+ # Create a shortcut
+ echo "Comment=A tool to decrypt files created by Cryptocam" > desktop
+ sed -i '1 i\Categories=Utility;' desktop
+ sed -i '1 i\Terminal=false' desktop
+ sed -i '1 i\Type=Application' desktop
+ sed -i '1 i\Icon=cryptocam-companion' desktop
+ sed -i '1 i\Exec=cryptocam-companion' desktop
+ sed -i '1 i\Name=Cryptocam Companion' desktop
+ sed -i '1 i\[Desktop Entry]' desktop
+ mv desktop $_pkgname.desktop
+}
+
+package() {
+ install -Dm644 $_pkgname.svg -t "$pkgdir/usr/share/icons/hicolor/scalable/apps"
+ install -Dm644 $_pkgname.desktop -t "$pkgdir/usr/share/applications"
+ install -Dm755 $pkgver-$_pkgname "$pkgdir/usr/bin/$_pkgname"
+}