summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeSnake042021-08-25 00:50:39 +0200
committerLeSnake042021-08-25 00:50:39 +0200
commit7c892bba72e32c550bc900a7f44e0147d6d28010 (patch)
treecc9428f769bb2c386ee92ff723f36ed585203aa4
downloadaur-cryptocam-companion-cli-git.tar.gz
v0.1.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cf3da14f9fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cryptocam-companion-cli-git
+ pkgdesc = Companion for Cryptocam, the encrypted android camera app – CLI version
+ pkgver = 0.1.0.f149dcb
+ pkgrel = 1
+ url = https://gitlab.com/cryptocam/cryptocam-companion-cli
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = rust
+ makedepends = cargo
+ makedepends = gcc
+ makedepends = clang
+ depends = ffmpeg
+ provides = cryptocam-companion-cli
+ conflicts = cryptocam-companion-cli
+ source = cryptocam-companion-cli-git::git+https://gitlab.com/cryptocam/cryptocam-companion-cli.git
+ sha512sums = SKIP
+
+pkgname = cryptocam-companion-cli-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac17aabdadf6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: LeSnake04 <dev.lesnake@posteo.de>
+
+_pkgname=cryptocam-companion-cli
+pkgname="$_pkgname-git"
+_pkgver=0.1.0
+pkgver=0.1.0.f149dcb
+pkgrel=1
+arch=('x86_64')
+pkgdesc="Companion for Cryptocam, the encrypted android camera app – CLI version"
+url="https://gitlab.com/cryptocam/cryptocam-companion-cli"
+license=('GPL3')
+depends=('ffmpeg')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+makedepends=('git' 'rust' 'cargo' 'gcc' 'clang')
+source=("${pkgname}::git+${url}.git")
+sha512sums=('SKIP')
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s" "$_pkgver" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ _repodir=$srcdir/$pkgname
+ cd $_repodir
+ cargo build --release
+}
+
+package() {
+ _repodir=$srcdir/$pkgname
+ _binsrc=$_repodir/target/release/cryptocam
+ _bintarget=$pkgdir/usr/bin/$_pkgname
+ install -Dm755 $_binsrc $_bintarget
+}