summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Amundsen2021-11-28 19:46:48 +0100
committerJonas Amundsen2021-11-28 19:46:48 +0100
commit95729e5a4e33ffd707018e8cda138c42a0368c2a (patch)
treebb2bc4d7d2b768b7b782e348660940774a04a802
downloadaur-cucumber-json-formatter.tar.gz
Publish cucumber-json-formatter-19.0.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 26 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee7986de3e30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = cucumber-json-formatter
+ pkgdesc = This standalone JSON Formatter provide a language agnostic tool to convert cucumber messages into a JSON document.
+ pkgver = 19.0.0
+ pkgrel = 1
+ url = https://github.com/cucumber/common/tree/main/json-formatter
+ arch = x86_64
+ license = MIT
+ source = https://github.com/cucumber/common/releases/download/json-formatter%2Fgo%2Fv19.0.0/cucumber-json-formatter-linux-amd64
+ sha1sums = fd87d036bd379393262784da5d766e79c935fa03
+
+pkgname = cucumber-json-formatter
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4d96c47c140
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+# Maintainer: Jonas Amundsen <jonasba+aur at gmail dot com>
+
+pkgname=cucumber-json-formatter
+pkgver=19.0.0
+pkgrel=1
+pkgdesc="This standalone JSON Formatter provide a language agnostic tool to convert cucumber messages into a JSON document."
+arch=("x86_64")
+url="https://github.com/cucumber/common/tree/main/json-formatter"
+license=("MIT")
+source=("https://github.com/cucumber/common/releases/download/json-formatter%2Fgo%2Fv$pkgver/cucumber-json-formatter-linux-amd64")
+sha1sums=("fd87d036bd379393262784da5d766e79c935fa03")
+
+package() {
+ install -D "$srcdir/cucumber-json-formatter-linux-amd64" "${pkgdir}/usr/bin/cucumber-json-formatter"
+}